DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 908673 - Ultima modifica: martedì 21 settembre 2010 - Revisione: 1.0

Hotfix disponibile per il download
Visualizza e richiedi i download dell'hotfix
 
 

In questa pagina

Sintomi

Si tenta di trasferire dei file verso o da una periferica connessa a un universal serial bus (USB) 2.0 in Windows XP, Windows Vista o Windows 7 di hub. In tal caso, potrebbero verificarsi uno o più dei seguenti sintomi:
  • Quando si tenta di trasferire file, il trasferimento del file non riesce. È possibile che venga visualizzato un messaggio di errore relativo a un errore di scrittura rimandata. Il messaggio di errore visualizzato può variare a seconda della periferica che si sta utilizzando.
  • USB di altre periferiche collegate all'hub USB 2.0 potrebbero smettere di funzionare. È possibile ricevere notifica i dispositivi USB sono state disconnessi o riconnessi.
  • Energia potrebbero essere disattivate nei dispositivi USB. Quindi, le periferiche vengono rienumerate.
  • Tastiera A USB potrebbe smettere di funzionare correttamente. Ad esempio, il comportamento dei tasti può essere irregolare. Quando si preme un tasto, la voce può essere ripetuta più volte. In alternativa, quando si preme un tasto, nulla può verificarsi affatto.
NotaAlcuni computer dispongono di un hub USB 2.0 interno. Ad esempio, un computer portatile potrebbe avere un singolo bus USB e potrebbe utilizzare un hub USB interno per fornire due o più porte USB al computer. Pertanto, questo problema può verificarsi se il dispositivo è connesso direttamente a una porta USB del computer.

Questo problema può verificarsi anche se la periferica è interna e connessa internamente all'hub USB 2.0 interno. Ad esempio, questo problema potrebbe verificarsi se si utilizza un computer portatile con una radio Bluetooth interna connessa a un hub USB 2.0 interno. Quando si utilizza questo dispositivo Bluetooth per trasferire i file su un'altra periferica, potrebbero verificarsi i sintomi descritti nella sezione "Sintomi".

Cause

Questo problema può verificarsi quando vi è molto traffico dell'hub USB 2.0 e trasferimento di file a bassa velocità o una periferica USB massima velocità. Il problema non si verifica quando si trasferiscono file a una periferica USB ad alta velocità.

Per ulteriori informazioni sulla velocità di trasferimento dati USB 2.0, vedere la sezione "informazioni".

, Inoltre, il problema è stato osservato nei computer che utilizzano processori Transmeta (CPU).

Risoluzione

Risoluzione per Windows 7


Per risolvere questo problema in Windows 7, aggiungere unEnHcSoftRetryvoce del Registro di sistema con valore 1 nella seguente sottochiave del Registro di sistema DWORD:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\ < id hw > \ < id istanza > \Device Parameters

NotaOttenere < id hw > e < id istanza >, aprire la pagina delle proprietà per ogni controller host EHCI USB Gestione periferiche, scegliere laDettaglischeda, quindi selezionarePercorso di istanza perifericanell'elenco. La maggior parte dei sistemi sono solo uno o due controller host EHCI, pertanto non deve essere troppo difficile.

Informazioni sull'hotfix per Windows Vista

È disponibile un hotfix supportato . Questo hotfix è tuttavia destinato alla correzione del problema descritto in questo articolo. Applicare questa correzione solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe eseguite ulteriori verifiche. Se questo problema non causa gravi difficoltà, si consiglia pertanto attendere il successivo aggiornamento software contenente questo hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non compare, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

NotaSe ulteriori problemi o se è necessaria la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo del servizio clienti Microsoft e supporto numeri di telefono o per creare una richiesta di assistenza separata, visitare il seguente sito Web:
http://support.Microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
NotaIl modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se la lingua non viene visualizzata, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario disporre di Windows Vista sia installato. Dopo avere installato questo hotfix, è necessario impostare ilEnHcSoftRetryvoce del Registro di sistema nella seguente sottochiave del Registro di sistema:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\ < hw id > \ < id istanza > \Device Parameters
La voce del Registro di sistema è configurato per un valore DWORD pari a 1. Questo valore consente il percorso del codice Riprova Soft viene utilizzato in questo hotfix.

NotaOttenere < id hw > e < id istanza >, aprire la pagina delle proprietà per ogni controller host EHCI USB Gestione periferiche, scegliere laDettaglischeda, quindi selezionarePercorso di istanza perifericanell'elenco. La maggior parte dei sistemi hanno solo uno o due controller host EHCI, pertanto non deve essere troppo difficile.

Necessità di riavvio

è necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

Versione dell'inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella seguente. Date e ore dei file sono elencate nell'ora UTC (UTC). Quando si visualizzano le informazioni sul file, viene convertita in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare ilFuso orariodello strumento Data e ora in Control Panel.

Windows Vista, versione x 86

Riduci questa tabellaEspandi questa tabella
Nome fileVersione fileDimensioni fileDataOraPiattaforma
Usbccgp.sys6.0.6000.2080973.21609-Apr-200802.02x 86
Usbhub.sys6.0.6000.20809194.04809-Apr-200802: 03x 86
Usbccgp.sys6.0.6001.2215373.21609-Apr-200812: 02x 86
Usbhub.sys6.0.6001.22153194.56009-Apr-200812: 02x 86
Hccoin.dll6.0.6000.208098.70409-Apr-200804: 04x 86
Hcrstco.dll6.0.6000.2080914.33609-Apr-200804: 04x 86
Usbd.sys6.0.6000.208095,88809-Apr-200802.02Non applicabile
Usbehci.sys6.0.6000.2080938.91209-Apr-200802.02x 86
Usbhub.sys6.0.6000.20809194.04809-Apr-200802: 03x 86
Usbohci.sys6.0.6000.2080919.45609-Apr-200802.02x 86
Usbport.sys6.0.6000.20809224,76809-Apr-200802.02x 86
Usbuhci.sys6.0.6000.2080923.55209-Apr-200802.02x 86
Hccoin.dll6.0.6001.221538.70409-Apr-200805: 06x 86
Hcrstco.dll6.0.6001.2215315,87209-Apr-200805: 06x 86
Usbd.sys6.0.6001.221535,88809-Apr-200812: 02Non applicabile
Usbehci.sys6.0.6001.2215339.93609-Apr-200812: 02x 86
Usbhub.sys6.0.6001.22153194.56009-Apr-200812: 02x 86
Usbohci.sys6.0.6001.2215319.45609-Apr-200812: 02x 86
Usbport.sys6.0.6001.22153226,30409-Apr-200812: 02x 86
Usbuhci.sys6.0.6001.2215323.55209-Apr-200812: 02x 86

Windows Vista, versione x 64

Riduci questa tabellaEspandi questa tabella
Nome fileVersione fileDimensioni fileDataOraPiattaforma
Usbccgp.sys6.0.6000.2080995.74409-Apr-200802: 29x 64
Usbhub.sys6.0.6000.20809268,80009-Apr-200802: 29x 64
Usbccgp.sys6.0.6001.2215395.74409-Apr-200802: 41x 64
Usbhub.sys6.0.6001.22153269,82409-Apr-200802: 42x 64
Hccoin.dll6.0.6000.2080910.75209-Apr-200804: 27x 64
Hcrstco.dll6.0.6000.2080916.38409-Apr-200804: 27x 64
Usbd.sys6.0.6000.208097,55209-Apr-200802: 29x 64
Usbehci.sys6.0.6000.2080948.64009-Apr-200802: 29x 64
Usbhub.sys6.0.6000.20809268,80009-Apr-200802: 29x 64
Usbohci.sys6.0.6000.2080924.06409-Apr-200802: 29x 64
Usbport.sys6.0.6000.20809258.04809-Apr-200802: 29x 64
Usbuhci.sys6.0.6000.2080929.18409-Apr-200802: 29x 64
Hccoin.dll6.0.6001.2215310.75209-Apr-200804: 41x 64
Hcrstco.dll6.0.6001.2215317.92009-Apr-200804: 41x 64
Usbd.sys6.0.6001.221537.68009-Apr-200802: 41x 64
Usbehci.sys6.0.6001.2215349.66409-Apr-200802: 41x 64
Usbhub.sys6.0.6001.22153269,82409-Apr-200802: 42x 64
Usbohci.sys6.0.6001.2215324.06409-Apr-200802: 41x 64
Usbport.sys6.0.6001.22153259,58409-Apr-200802: 41x 64
Usbuhci.sys6.0.6001.2215329.18409-Apr-200802: 41x 64


Windows Vista, versione basato su IA64

Riduci questa tabellaEspandi questa tabella
Nome fileVersione fileDimensioni fileDataOraPiattaforma
Usbccgp.sys6.0.6001.22153208,38409-Apr-200802: 31IA-64
Usbhub.sys6.0.6001.22153853,50409-Apr-200802: 31IA-64
Hccoin.dll6.0.6001.2215322.52809-Apr-200804: 20IA-64
Hcrstco.dll6.0.6001.2215324.57609-Apr-200804: 20IA-64
Usbd.sys6.0.6001.2215311,64809-Apr-200802: 31Non applicabile
Usbehci.sys6.0.6001.22153122.36809-Apr-200802: 31IA-64
Usbhub.sys6.0.6001.22153853,50409-Apr-200802: 31IA-64
Usbohci.sys6.0.6001.2215358,36809-Apr-200802: 31IA-64
Usbport.sys6.0.6001.22153645,63209-Apr-200802: 31IA-64
Usbuhci.sys6.0.6001.2215380,38409-Apr-200802: 31IA-64

Informazioni sull'hotfix per Windows XP

È disponibile un hotfix supportato . Questo hotfix è tuttavia destinato alla correzione del problema descritto in questo articolo. Applicare questa correzione solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe eseguite ulteriori verifiche. Se questo problema non causa gravi difficoltà, si consiglia pertanto attendere il successivo aggiornamento software contenente questo hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non compare, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

NotaSe ulteriori problemi o se è necessaria la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo del servizio clienti Microsoft e supporto numeri di telefono o per creare una richiesta di assistenza separata, visitare il seguente sito Web:
http://support.Microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
NotaIl modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se la lingua non viene visualizzata, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario installare Windows XP SP2.

Dopo aver installato questo aggiornamento rapido, la seguente sottochiave del Registro di sistema viene automaticamente aggiunto e configurata:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USB\EnSoftRetry
La chiave del Registro di sistema è configurato per un valore DWORD pari a 1. Questo valore consente il percorso del codice Riprova Soft viene utilizzato in questo hotfix.

Se si installa una versione successiva di questo aggiornamento rapido (hotfix che contiene le versioni successive di Usbport.sys e Usbehci.sys), inclusi Windows XP SP3, questo valore verrà non automaticamente aggiunto e configurato. Il valore deve essere aggiunto manualmente e configurato come descritto in precedenza per attivare il percorso del codice Riprova Soft fornito in questo hotfix.

Informazioni sui file

Versione dell'inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella seguente. Date e ore dei file sono elencate nell'ora UTC (UTC). Quando si visualizzano le informazioni sul file, viene convertita in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare ilFuso orariodello strumento Data e ora nel Pannello di controllo.
Riduci questa tabellaEspandi questa tabella
Nome fileVersione fileDimensioni fileDataOraPiattaformaSP requisitoRamo del servizio
Usbehci.sys5.1.2600.278327,26425 Ottobre 200523: 39x 86Service Pack 2SP2QFE
Usbport.sys5.1.2600.2783143,10425 Ottobre 200523: 39x 86Service Pack 2SP2QFE

Comportamento dopo l'applicazione dell'hotfix

Quando viene applicato questo hotfix e la funzionalità Riprova Soft viene attivata con il valore di registro appropriato (a seconda della versione di Windows, come descritto in precedenza), un trasferimento USB che non riesce per motivi specifici viene automaticamente riprovata anziché completata e indicato lo stato "errore". Quando si verifica questo processo, driver di periferica USB client potrebbero non ricevere notifica di errore di comunicazione con la periferica a causa di un errore di livello inferiore del bus USB.

Se il driver della periferica USB interessato richiede segnalazione accurati per funzionare correttamente, non è necessario applicare questo hotfix. In alternativa, è necessario disattivare la funzionalità Riprova Soft impostando il valore di registro appropriato su 0 o eliminando il valore Riprova Soft interamente (a seconda della versione di Windows, come descritto in precedenza).

A Soft-Riprova processo verrà eseguito quando si verificano le condizioni seguenti:
  • Il valore del Registro di sistema è attivato.
  • L'errore segnalato dal controller host Enhanced Host Controller Interface (EHCI USB) per il trasferimento completato è uno dei seguenti errori:
    • Errore di transazione (XactErr)
    • Cornice di micro Missed
    Queste condizioni di errore sono documentate in USB EHCI Specifica controller come segue:
    Transaction Error (XactErr). Set to a one by the Host Controller during status update in the case where the host did not receive a valid response from the device (Timeout, CRC, Bad PID, etc.). Refer to Section 4.15.1.1 for summary of the conditions that affect this bit. 
    Missed Micro-Frame. This bit is set when the host controller detected that a host-induced hold-off caused the host controller to miss a required complete-split transaction. 
Per ulteriori informazioni sulla specifica USB EHCI, visitare il seguente sito Web:
http://www.Intel.com/technology/usb/ehcispec.htm (http://www.intel.com/technology/usb/ehcispec.htm)

Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Velocità USB 2.0 viene supportato il trasferimento dei dati

USB 2.0 supporta la velocità di trasferimento dati massima seguenti, a seconda della larghezza di banda di bus che richiede un dispositivo:
  • 1,5 megabit al secondo (Mbps) per le periferiche a bassa velocità che non richiedono grandi quantità di larghezza di banda. Tali periferiche includono periferiche mouse e tastiere.
  • 12 Mbps per le periferiche di massima velocità, la successiva esecuzione. Quali dispositivi di archiviazione, altoparlanti, scanner e videocamere.
  • 480 Mbps per le periferiche ad alta velocità. Questi dispositivi sono periferiche di archiviazione di massa e registratori di CD ad alta velocità o un DVD.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descrizione della terminologia standard che viene utilizzata per descrivere gli aggiornamenti software Microsoft

Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Service Pack 1
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
Chiavi: 
kbautohotfix kbexpertisebeginner kbqfe kbhotfixserver kbmt KB908673 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 908673  (http://support.microsoft.com/kb/908673/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store