DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 927525 - Ultima modifica: mercoledì 26 marzo 2014 - Revisione: 1.0

Il supporto per Windows Vista senza alcun Service Pack installato non è più disponibile dal 13 aprile 2010. Per continuare a ricevere gli aggiornamenti della protezione per Windows, utilizzare Windows Vista con Service Pack 2 (SP2). Per ulteriori informazioni, fare riferimento alla pagina Web Microsoft riportata di seguito: Per alcune versioni di Windows, il supporto non è più disponibile (http://windows.microsoft.com/it-it/windows/help/end-support)

In questa pagina

Sintomi

Dopo l'installazione di un dispositivo o l'aggiornamento di un driver di dispositivo su un computer che esegue Windows Vista o Windows 7, il sistema operativo potrebbe non avviarsi.

Cause

Questo problema può verificarsi in presenza di una delle seguenti condizioni:
  • Il nuovo dispositivo o il driver causa conflitti con altri driver installati nel computer.
  • Si verifica un problema specifico dell'hardware.
  • Il driver installato è danneggiato.

Risoluzione

Per risolvere il problema, utilizzare la procedura per la risoluzione dei problemi riportata di seguito per determinare l'esatta causa e adottare le contromisure appropriate.

Avviare Windows Vista o Windows 7

  1. Se è stato installato un nuovo dispositivo, rimuoverlo, quindi provare ad avviare il computer. Se Il sistema operativo non viene avviato, andare al passaggio 2. Se ilsistema operativo viene avviato, andare alla sezione "Risolvere la causa del problema di avvio" di questo articolo.
  2. Avviare il computer e premere F8. Nella schermata Opzioni di avvio avanzate selezionare Ultima configurazione valida nota, quindi premere INVIO. Se il sistema operativo non viene avviato, andare al passaggio 3. Se il sistema operativo viene avviato, andare alla sezione "Risolvere la causa del problema di avvio" di questo articolo.
  3. Avviare il computer e premere F8. Nella schermata Opzioni di avvio avanzate selezionare Modalità provvisoria, quindi premere INVIO. Se il sistema operativoviene avviato in modalità provvisoria, andare alla sezione "Risolvere la causa del problema di avvio" di questo articolo. Se non è possibile avviare il sistema operativo in modalità provvisoria, andare alla sezione "Utilizzare Ambiente di ripristino Windows per eseguire il ripristino di Windows Vista o Windows 7" di questo articolo.

Utilizzare Ambiente ripristino Windows per ripristinare Windows Vista o Windows 7

Importante In questa sezione, metodo o attività viene illustrato come modificare il Registro di sistema. L'errata modifica del Registro di sistema può causare seri problemi. Attenersi quindi scrupolosamente alla procedura indicata. Per maggiore protezione, eseguire una copia di backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile effettuarne il ripristino in caso di problemi. Per ulteriori informazioni su come eseguire il backup del Registro di sistema e su come ripristinarlo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756  (http://support.microsoft.com/kb/322756/it/ ) Esecuzione del backup e del ripristino del Registro di sistema in Windows


Per utilizzare Ambiente ripristino Windows, è necessario disporre del disco di installazione di Windows Vista o Windows 7. Per avviare Ambiente ripristino Windows, attenersi alla seguente procedura:
  1. Inserire il disco di installazione nell'unità disco, quindi avviare il computer.
  2. Premere un tasto quando richiesto.
  3. Selezionare la lingua, la data e l'ora e la valuta, una tastiera o un metodo di input, quindi scegliere Avanti.
  4. Fare clic su Ripristina il computer.
  5. Nella finestra di dialogo Opzioni ripristino di sistema fare clic sul sistema operativo che si desidera ripristinare, quindi scegliere Avanti.
Utilizzare gli strumenti disponibili in Ambiente ripristino Windows per ripristinare Windows Vista o Windows 7. A questo scopo, attenersi alla procedura seguente:
  1. Se il computer non si avvia in modalità provvisoria, fare clic su Ripristino all'avvio nella finestra di dialogo Opzioni ripristino di sistema per correggere alcuni problemi che potrebbero impedire il corretto avvio del sistema operativo. Se lo strumento Ripristino all'avvio non consente di diagnosticare o risolvere il problema, passare al punto 2. Se Windows Vista o Windows 7 vengono avviati, andare alla sezione "Risolvere la causa del problema di avvio".

    For more information about how to use Startup Repair, click the following article number to view the article in the Microsoft Knowledge Base:
    925810  (http://support.microsoft.com/kb/925810/it/ ) Si verifica un errore irreversibile o il computer si blocca durante il tentativo di avvio di Windows Vista o Windows 7
  2. Nella finestra di dialogo Opzioni ripristino di sistema, fare clic su Ripristino configurazione di sistema per ripristinare ilsistema operativo al punto di ripristino creato durante l'installazione del programma o del driver. Se non è possibile utilizzare lo strumento Ripristino configurazione di sistema per avviare il computer, passare al punto 3.
  3. Utilizzare l'opzione Prompt dei comandi in Ambiente ripristino Windows per disabilitare il driver che impedisce l'avvio del sistema operativo. Per eseguire questa operazione, attenersi alla procedura descritta di seguito.
    1. Nella finestra di dialogo Opzioni ripristino di sistema scegliere Prompt dei comandi.
    2. Digitare i comandi riportati di seguito. Premere INVIO dopo ogni comando.
      cd \Windows\INF
      notepad setupapi.app.log
    3. Osservare la data all'inizio di ogni sezione relativa all'installazione di un nuovo dispositivo o driver. Utilizzare queste date per determinare l'ultimo driver installato.
    4. Dopo avere determinato qual è l'ultimo driver installato, verificare se il driver è necessario per l'avvio del computer. A questo scopo, leggere le informazioni contenute nella sezione del file Setupapi.app.log in cui è descritto il driver. Se il driver è correlato al controller del disco o al chipset oppure se il driver è fornito dal sistema operativo, cercare il nome del driver e il sintomo del problema sul seguente sito Web Microsoft:
      http://www.microsoft.com/it/it/default.aspx (http://www.microsoft.com/it/it/default.aspx)
      Determinare se è possibile disattivare il driver prima di continuare. Se l'ultimo driver installato non è necessario per l'avvio del computer, passare al punto e.
    5. Al prompt dei comandi digitare regedit, quindi scegliere OK.
    6. Fare clic su HKEY_LOCAL_MACHINE, quindi scegliere Carica hive dal menu File.
    7. Individuare e fare clic sul file C:\Windows\System32\Config\System e scegliere Apri.
    8. Nella finestra di dialogo Carica hive digitare Offline, quindi scegliere OK.
    9. Espandere System, quindi fare clic su Seleziona.
    10. Nel riquadro destro individuare Current e prendere nota del valore nella colonna Dati.
    11. Espandere ControlSet00x, quindi Services. x è il valore della colonna Dati annotato al punto j.
    12. Individuare la sottochiave corrispondente all'ultimo driver installato. Se non è possibile trovare una corrispondenza, fare clic su Servizi, scegliere Trova dal menu Modifica, digitare il nome del driver nella casella Trova quindi fare clic su Trova successivo.
    13. Fare clic sulla sottochiave con il nome del driver.
    14. Nel riquadro destro fare clic con il pulsante destro del mouse su Start, quindi scegliere Modifica.
    15. Nella casella Dati valore digitare 4, quindi scegliere OK. Questo passaggio impedirà l'avvio del driver.
    16. Individuare e selezionare la seguente sottochiave del Registro di sistema:
      HKEY_LOCAL_MACHINE\Offline
    17. Scegliere Scarica hive dal menu File, quindi scegliere nella finestra di dialogo Conferma scaricamento hive.
    18. Chiudere l'editor del Registro di sistema.
    19. Riavviare il computer.
    20. Se il sistema operativo non si avvia, avviare Ambiente ripristino Windows e ripetere i punti da a fino a s. Potrebbe essere necessario ripetere la procedura finché non saranno stati disattivati tutti i driver installati dall'ultimo avvio corretto.
  4. Quando è possibile avviare il sistema operativo, contattare il produttore del dispositivo o del driver per informazioni sui problemi di compatibilità o sugli aggiornamenti eventualmente disponibili.

Risolvere la causa del problema di avvio

  1. Aprire Gestione dispositivi. A questo scopo, fare clic sul pulsante Start
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , digitare Gestione dispositivi nella casella Inizia la ricerca, quindi fare clic su Gestione dispositivi nell'elenco Programmi.
  2. Se è stato aggiornato il driver di un dispositivo, fare clic con il pulsante destro del mouse sul dispositivo corrispondete in Gestione dispositivi, scegliere Proprietà, quindi fare clic su Ripristina driver nella scheda Driver.
  3. Se è stato installato un nuovo dispositivo, fare clic con il pulsante destro del mouse in Gestione dispositivi, quindi scegliere Disinstalla.
  4. Se è stato installato un programma che include un nuovo driver, attenersi alla procedura riportata di seguito:
    1. Fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante Start
      , digitare appwiz.cpl nella casella Inizia la ricerca, quindi fare clic su appwiz.cpl nell'elenco Programmi.
    2. Fare clic sul nome del programma installato, quindi scegliere Disinstalla/Cambia.
      Riduci l'immagineEspandi l'immagine
      Autorizzazione Controllo dell'account utente
      Se viene chiesta l'autorizzazione per continuare, fare clic su Continua.
    3. Quando viene visualizzato il messaggio in cui viene chiesto se si desidera continuare, scegliere .
  5. Riavviare Windows Vista o Windows 7.
Nota: questo è un articolo a "PUBBLICAZIONE RAPIDA", creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento vengono fornite "così come sono" in risposta alle problematiche riscontrate. A causa della rapidità con cui vengono resi disponibili, i materiali possono contenere errori di battitura e sono soggetti a modifica senza preavviso, in qualsiasi momento. Per altre considerazioni, vedere le Condizioni per l'utilizzo (http://go.microsoft.com/fwlink/?LinkId=151500) .

Le informazioni in questo articolo si applicano a:
  • Windows Vista Ultimate
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Enterprise
  • Windows Vista Business 64-bit edition
  • Windows Vista Business
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows 7 Enterprise
Chiavi: 
kbexpertisebeginner kbtshoot kbprb KB927525
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store