DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 928218 - Ultima modifica: venerdì 2 maggio 2014 - Revisione: 11.0

 

In questa pagina

Sommario

In questo articolo fornisce i metodi che è possibile seguire per disinstallare o rimuovere applicazioni Microsoft Office 2007.

Si desidera disinstallare una versione diversa di Microsoft Office?

Per visualizzare informazioni su come rimuovere o disinstallare un'altra versione di Microsoft Office, fare clic sul collegamento corrispondente alla versione di Office:

Come disinstallare o rimuovere gruppi di Microsoft Office 2010 (http://support.microsoft.com/kb/290301/)
Come disinstallare o rimuovere le famiglie di prodotti di Microsoft Office 2003 (http://support.microsoft.com/kb/2639197/)
Come disinstallare o rimuovere Microsoft Office per Mac 2011 (http://support.microsoft.com/kb/2398768/)
Come disinstallare o rimuovere Microsoft Office per Mac 2008 (http://support.microsoft.com/kb/2500821/)

Risoluzione

Si consiglia di seguire i metodi forniti in questo articolo nell'ordine. Tuttavia, se si è tentato in precedenza di uno dei metodi per rimuovere Office e non è riuscita, è possibile passare a un altro metodo rapidamente da questo elenco:
  • Metodo 1: Disinstallare suite Microsoft Office 2007 dal Pannello di controllo
  • Metodo 2: Disinstallare Microsoft Office 2007 Suite con Microsoft Fix it
  • Metodo 3: Gruppi disinstallazione di Microsoft Office 2007 con la risoluzione dei problemi il programma di installazione e disinstallazione
  • Metodo 4: Rimuovere manualmente suite Microsoft Office 2007

Metodo 1: Disinstallare suite Microsoft Office 2007 dal Pannello di controllo

Riduci l'immagineEspandi l'immagine
Per rimuovere Microsoft Office 2007 dal Pannello di controllo, attenersi alla seguente procedura:
  1. Fare clic su Start.
  2. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  3. Fare clic su Esegui e quindi fare clic nella casella Apri
  4. Tipo appwiz. cpl, quindi scegliere OK.
  5. Individuare la voce di Microsoft Office nell'elenco dei programmi attualmente installati.
  6. Selezionarlo e quindi fare clic su Disinstalla (o rimuovere in Windows XP).
Se si verificano problemi di disinstallazione del sistema di Microsoft Office 2007 nel Pannello di controllo, passare al metodo successivo.
Riduci l'immagineEspandi l'immagine

Metodo 2: Disinstallare Microsoft Office 2007 Suite con Microsoft Fix it

Riduci l'immagineEspandi l'immagine
Avviso: la correzione è soluzione non rimuove i singoli programmi di Office installati separatamente nel computer in uso. Ad esempio, se si dispone di Microsoft Office Professional 2007 e Microsoft Office Visio 2007, la correzione tale soluzione consente di rimuovere solo Microsoft Office Professional 2007. Visio 2007 non verrà rimosso. Fare clic qui per visualizzare come disinstallare o rimuovere applicazioni Microsoft Office 2007. (http://support.microsoft.com/kb/928218)

IMPORTANTE - leggere queste note prima di utilizzare la correzione tale soluzione:
  • Se si dispone di un sistema operativo di Windows a 64 bit, scaricare e salvare la correzione è soluzione sul desktop e fare doppio clic su ed eseguirlo nel computer in uso. Se si tenta di eseguire la soluzione direttamente dall'articolo si avranno problemi di esecuzione correttamente.
  • È necessario riavviare il computer se si utilizza la correzione tale soluzione.
  • La procedura guidata può essere solo in lingua inglese. Tuttavia, la correzione automatica funziona inoltre per altre versioni di lingua di Windows.
  • Se non si è sul computer che presenta il problema, salvare la soluzione è la soluzione in un'unità memoria flash o un CD o DVD, quindi eseguirlo sul computer che presenta il problema.
La correzione, soluzione per applicazioni Microsoft Office 2007 rimuoverà tutte le edizioni di Office 2007. Sono incluse tutte le versioni di valutazione di Office 2007.

Per disinstallare automaticamente la suite di Microsoft Office 2007, scegliere il pulsante di risolvere il problema o il collegamento. Fare clic su Esegui nella finestra di dialogo Download del File e quindi seguire le istruzioni della procedura guidata.
Riduci l'immagineEspandi l'immagine
Risolvere il problema (http://go.microsoft.com/?linkid=9669698)
Microsoft Fix it 50154
Riduci l'immagineEspandi l'immagine


Se non si riesce a disinstallare la suite di Microsoft Office, passare al metodo successivo.
Riduci l'immagineEspandi l'immagine

Metodo 3: Gruppi disinstallazione di Microsoft Office 2007 con la risoluzione dei problemi il programma di installazione e disinstallazione

Riduci l'immagineEspandi l'immagine
È possibile provare a disinstallare la suite di Microsoft Office eseguendo il programma di installazione e la risoluzione dei problemi di disinstallazione. Per eseguire la risoluzione dei problemi, visitare il seguente articolo della Microsoft knowledge base riportato di seguito:



Se non si riesce a disinstallare la suite di Microsoft Office, passare al metodo successivo.
Riduci l'immagineEspandi l'immagine

Metodo 4: Rimuovere manualmente suite Microsoft Office 2007

Riduci l'immagineEspandi l'immagine
Nota che è necessario essere connessi a Windows con un account utente amministratore del computer per completare il metodo. Se si tratta del computer in uso, è probabile che sia già stato effettuato l'accesso con un account amministratore. Se si tratta di un computer che fa parte di una rete, potrebbe essere necessario richiedere assistenza all'amministratore del sistema. Per verificare che si è connessi a Windows con un account utente amministratore del computer, visitare il seguente articolo della Microsoft knowledge base riportato di seguito:

Come determinare il tipo di account utente in Windows (http://support.microsoft.com/kb/2663817/)


IMPORTANTE - informazioni che è necessario conoscere prima di rimuovere Office 2007:
  • Per utilizzare il menu Visualizza o Strumenti in Windows 7 o Vista, è necessario premere il tasto ALT per visualizzare la barra dei menu.
  • È necessario visualizzare cartelle e file nascosti. A tale scopo, attenersi alla seguente procedura:
    1. Aprire Esplora risorse.
    2. Scegliere Opzioni cartella dal menu Strumenti. In Windows 7 o Vista, premere il tasto ALT per visualizzare la barra dei menu.
    3. Fare clic sulla scheda Visualizza
    4. Nel riquadro Impostazioni avanzate in cartelle e file nascosti, fare clic su Visualizza cartelle e file nascosti.
    5. Deselezionare Nascondi le estensioni per i tipi di file conosciuti.
    6. Fare clic su OK e chiudere le finestre.

Passaggio 1: Rimuovere tutti i pacchetti Windows Installer rimanenti del sistema Microsoft Office 2007.
  1. Fare clic su Start.
  2. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  3. Fare clic su Esegui e quindi fare clic nella casella Apri
  4. Tipo programma di installazione, quindi scegliere OK.
    Verrà aperta la cartella %windir%\Installer.

  5. Dal menu Visualizza , fare clic su Scegli dettagli.
  6. Fare clic per selezionare la casella di controllo dell'oggetto , tipo 340 la larghezza della colonna selezionata (in pixel) , quindi OK.
    Nota. Potrebbe richiedere alcuni minuti per gli oggetti vengano visualizzati accanto a ciascuna.File MSI.

  7. Dal menu Visualizza , scegliere Ordina per in Windows 7 o Vista, o scegliere Disponi icone per , in Windows XP e fare clic su oggetto.
  8. Se viene visualizzata una finestra di dialogo Controllo Account utente, fare clic su Consenti per continuare.
  9. Individuare i variFile MSI dove l'oggetto è "Microsoft Office 2007, di <product name="">" destro la.MSI file e quindi fare clic su Disinstalla.
    Nota. <product name="">è un segnaposto per il nome del prodotto Microsoft Office 2007.
    </product></product>
Passaggio 2: arrestare il servizio Office Source Engine.
  1. Fare clic su Start.
  2. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  3. Fare clic su Esegui e quindi fare clic nella casella Apri
  4. Tipo Services. msc, quindi scegliere OK.
  5. Nella finestra Servizi, determinare se è in esecuzione il servizio Office Source Engine ("Avviato" verrà visualizzato nella colonna Stato). Se il servizio è in esecuzione, destro del mouse suOffice Source Enginee quindi fare clic su Interrompi.
  6. Chiudere la finestra Servizi.
Passaggio 3: Rimuovere le cartelle di installazione di Microsoft Office 2007 rimanenti.
  1. Fare clic su Start.
  2. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  3. Fare clic su Esegui e quindi fare clic nella casella Apri
  4. Digitare %CommonProgramFiles%\Microsoft Sharede quindi fare clic su OK.
    Nota. In un computer che esegue una versione a 64 bit di Windows 7 o Vista, digitare % CommonProgramFiles(x86) %\Microsoft Sharede quindi fare clic su OK.

  5. Se sono presenti le seguenti cartelle, è necessario eliminarle:
    • Office12
    • Source Engine
  6. Fare clic su Start.
  7. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  8. Fare clic su Esegui e quindi fare clic nella casella Apri
  9. Digitare %ProgramFiles%\Microsoft Officee quindi fare clic su OK.
    Nota. In un computer che esegue una versione a 64 bit di Windows 7 o Vista, digitare % ProgramFiles(x86) %\Microsoft Officee quindi fare clic su OK.

  10. Eliminare la cartella Office 12.
  11. Nella cartella principale di ogni disco rigido, individuare e aprire la cartella MSOCache. Se non è possibile visualizzare questa cartella, attenersi alla seguente procedura:
    1. Aprire Esplora risorse e quindi fare clic su Opzioni cartelladal menu Strumenti .
    2. Fare clic sulla scheda Visualizza
    3. Nel riquadro Impostazioni avanzate in cartelle e file nascosti, fare clic su Visualizza cartelle e file nascosti.
    4. Deselezionare la casella di controllo Nascondi file protetti di sistema e quindi fare clic su OK.
  12. Aprire la cartella Tutti gli utenti nella cartella MSOCache e quindi eliminare ogni cartella che contiene 0FF1CE}- nel testo del nome della cartella.
    Nota. Questo testo contiene uno zero e uno per le lettere "O" e "I".
    Esempio {90140000-001B-0409-0000-0000000FF1CE}-C
Passaggio 4: Rimuovere i file di installazione di Microsoft Office 2007 rimanenti.
  1. Fare clic su Start.
  2. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  3. Fare clic su Esegui e quindi fare clic nella casella Apri
  4. Digitare %appdata%\microsoft\templatese quindi fare clic su OK.
  5. Eliminare i seguenti file:
    • Normal.dotm
    • Normalemail.dotm
  6. Fare clic su Start.
  7. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  8. Fare clic su Esegui e quindi fare clic nella casella Apri
  9. Digitare %appdata%\microsoft\document building blocchie quindi fare clic su OK.
  10. Aprire la sottocartella nella cartella Blocchi predefiniti del documento
    Nota. Il titolo della sottocartella sarà un numero di quattro cifre che rappresentano la lingua della famiglia di prodotti Microsoft Office.

  11. Eliminare il file building blocks.dotx.
  12. Chiudere tutti i programmi prima di eseguire il resto dei passaggi.
  13. Fare clic su Start.
  14. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  15. Fare clic su Esegui e quindi fare clic nella casella Apri
  16. Digitare % temp %e quindi fare clic su OK.
  17. Dal menu Modifica , fare clic su Seleziona tutto.
  18. Dal menu File , fare clic su Elimina.
  19. Fare clic su Start.
  20. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  21. Fare clic su Esegui e quindi fare clic nella casella Apri
  22. Digitare %AllUsersprofile%\Application applicazioni\Microsoft\Office\Datae quindi fare clic su OK.
  23. Eliminare il file Opa12 dat (e solo questo file).
Passaggio 5: Rimuovere le sottochiavi del Registro di sistema del sistema di Microsoft Office 2007.
Avviso. L'errata modifica del Registro di sistema utilizzando l'Editor del Registro di sistema o un altro metodo può causare problemi gravi. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che questi problemi possano essere risolti. Modificare il Registro di sistema a proprio rischio.

Importante In questo articolo contiene informazioni su come modificare il Registro di sistema. Assicurarsi di eseguire il backup del Registro di sistema prima di modificarlo. Assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Come eseguire il backup e il ripristino del Registro di sistema in Windows

Individuare ed eliminare le sottochiavi del Registro di sistema di Office 2007 se sono presenti. A tale scopo, attenersi alla seguente procedura:
  1. Fare clic su Start.
  2. Fare clic su Tutti i programmie quindi aprire la cartella Accessori (ignorare questo passaggio in Windows XP).
  3. Fare clic su Esegui e quindi fare clic nella casella Apri
  4. Digitare regedite quindi fare clic su OK.
  5. Fare clic sulla seguente sottochiave del Registro di sistema:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  6. Dal menu File , fare clic su Esporta, digitare DeletedKey01e quindi fare clic su Salva.
  7. Dal menu Modifica, fare clic su Elimina e quindi fare clic su per confermare.
  8. Ripetere questi passaggi (da 1 a 7) per ciascuna sottochiave del Registro di sistema riportati di seguito. Modificare il nome della chiave esportata, uno per ciascuna sottochiave.
    Esempio Digitare DeletedKey02 per la seconda chiave, digitare DeletedKey03 per la terza chiave e così via.
Nota. Nelle seguenti chiavi del Registro di sistema, il carattere asterisco (*) rappresenta uno o più caratteri nel nome della sottochiave.

Versioni a 32 bit di Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\ * Office12 *
Versioni a 64 bit di Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\ * F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\ * F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\ * Office12 *
Continuare con queste sottochiavi del Registro di sistema:
  1. Individuare la seguente sottochiave del Registro di sistema:

    32 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    64 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

  2. Dal menu File , fare clic su Esporta, digitare UninstallKey01e quindi fare clic su Salva.
  3. Nella sottochiave Uninstall individuata al passaggio 1, fare clic su ogni sottochiave e quindi determinare se alla sottochiave è assegnato il valore riportato di seguito:
    • Nome: UninstallString
    • Dati: file_name path\Office Setup Controller\Setup.exe path

      Nota. In questo esempio, nome_file è un segnaposto per il nome di un programma di installazione e percorso è un segnaposto per il percorso del file.
  4. Se la sottochiave contiene il nome e i dati descritti nel passaggio 3, scegliere Elimina dal menu Modifica. In caso contrario, andare al passaggio 5.
  5. Ripetere i passaggi 3 e 4 fino a individuare ed eliminare ogni sottochiave corrispondente al nome e ai dati descritti nel passaggio 3.
  6. Chiudere l'Editor del Registro di sistema.
Passaggio 6: riavviare il computer.
Riavviare il computer. Se la rimozione è stata eseguita correttamente, la procedura è terminata ed è possibile reinstallare Microsoft Office se si desidera. Se la rimozione non è stata completata, passare alla sezione "Riferimenti" in questo articolo.
Riduci l'immagineEspandi l'immagine



Le informazioni in questo articolo si applicano a:
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Basic 2007
Chiavi: 
kbexpertiseinter kberrmsg kbregistry kbsetup kbinstallation kbtshoot kbprb kbfixme kbmsifixme kbcip kbmt KB928218 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 928218  (http://support.microsoft.com/kb/928218/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store