DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 933741 - Ultima modifica: mercoledì 20 agosto 2014 - Revisione: 12.0

 

INTRODUZIONE

In questo articolo contiene informazioni su Microsoft Network Monitor 3. Network Monitor 3 è un analizzatore di protocollo. Consente di acquisire, visualizzare e analizzare i dati di rete. Consente di risolvere i problemi con le applicazioni in rete.

In questo articolo contiene download e informazioni di supporto, note di installazione e informazioni generiche sull'utilizzo sul Monitor di rete 3. Network Monitor 3.4 è la versione più recente.

Informazioni

Network Monitor 3 è una revisione completa di Network Monitor 2 precedenti.x versione. Alcune delle funzionalità principali di Monitor di rete 3 comprendono:
  • Modello parser basato su script con aggiornamenti frequenti
  • Sessioni simultanee acquisizione live
  • Supporto per Windows 7
  • Supporto per piattaforme a 32 bit e piattaforme a 64 bit
  • Supporto per le conversazioni di rete e il processo di rilevamento
  • API per accedere a acquisizione e il motore di analisi
  • Wireless Monitor modalità acquisizione

Download e informazioni di supporto

Per scaricare l'ultima versione di Network Monitor, Network Monitor 3.4, visitare il seguente sito Web Microsoft:
http://go.microsoft.com/fwlink/?LinkId=103158&clcid=0x409 (http://go.microsoft.com/fwlink/?LinkID=103158&clcid=0x409)
Informazioni di supporto per 3.4 del Monitor di rete si trova nel forum Microsoft TechNet seguente:

http://go.microsoft.com/fwlink/?LinkId=151800 (http://go.microsoft.com/fwlink/?LinkID=151800)

Note sull'installazione

Network Monitor 3.4 può coesistere con Network Monitor 2. x. Per impostazione predefinita, viene installato Network Monitor 3.4 nel "3" cartella di programma Files%\Microsoft Network Monitor %. Pertanto, non si verifichino conflitti se è installata una versione precedente in una cartella diversa sul computer. Durante l'installazione di Network Monitor 3.4, qualsiasi versione precedente di Monitor di rete 3 viene disinstallato.

Network Monitor 3.4 include un nuovo driver per Windows Vista, Windows Server 2008 e Windows 7. Questo nuovo driver supporta le nuove funzionalità del driver NDIS Network Driver Interface Specification () 6.0. Se si utilizzano strumenti che si basano su Network Monitor 2.x NPPTools, gli strumenti non funzioneranno più. Per acquisire i dati di rete in Windows Vista, è necessario utilizzare Network Monitor 3.4. Network Monitor 2.x non acquisire i dati di rete correttamente in Windows Vista.

Hardware consigliati per eseguire Network Monitor 3.4 è elencato come segue:
  • Processore 1 GHz o superiore
  • 1 GB di memoria
  • 60 MB di spazio disponibile sul disco rigido e lo spazio su disco per memorizzare i file di acquisizione
3.4 di Network Monitor è supportato nei sistemi operativi seguenti:
  • Windows 7
  • Windows Server 2008
  • Windows Vista
  • Windows XP
  • Windows Server 2003
Avvisi e avvertenze

Attualmente, si sconsiglia di eseguire Network Monitor 3 sui sistemi di produzione in cui il carico aggiuntivo potrebbe influire sull'esecuzione. In scenari in cui il carico è un elemento da prendere in considerazione, è possibile utilizzare la versione della riga di comando di Monitor di rete 3 per acquisire i dati di rete. La versione della riga di comando è Nmcap.exe. Per ulteriori informazioni su Nmcap.exe, vedere la sezione "Strumento della riga di comando Nmcap.exe".

Network Monitor 3 potrebbe consumare grandi quantità di risorse di sistema. Di seguito sono riportati alcuni aspetti da considerare.
  • Spazio su disco

    Quando si avvia una sessione di acquisizione, Network Monitor 3 memorizza fotogrammi in una sequenza di file di acquisizione che si trovano nella cartella \Temp. Per impostazione predefinita, la dimensione di ogni file è di 20 MB. Per impostazione predefinita, se non si interrompe la sessione di acquisizione, Network Monitor 3 continua a memorizzare i file di acquisizione nella cartella \Temp fino a quando lo spazio disponibile sul disco rigido del computer è inferiore al 2%. Quindi, Monitor di rete 3 interrompe la sessione di acquisizione.

    È possibile configurare la dimensione del file di acquisizione, la posizione in cui sono archiviati i file di acquisizione, il limite di spazio disponibile su disco rigido e altre opzioni di acquisizione. A tale scopo, dal menu Strumenti , scegliere Opzionie quindi fare clic sulla scheda di acquisizione .
  • Utilizzo della memoria

    Oltre a acquisizione dei dati, Monitor di rete 3 assegna le proprietà di frame e quindi vengono utilizzate le proprietà per raggruppare i fotogrammi in conversazioni. Network Monitor 3 consente di visualizzare le conversazioni e le cornici associate in una struttura ad albero nel riquadro delle Conversazioni di rete .

    La funzionalità di conversazioni di Monitor di rete 3 aumenta notevolmente l'utilizzo della memoria. Ciò può causare il blocco del computer. Per impostazione predefinita, la funzionalità di conversazioni è attivata. Alcuni filtri protocollo di livello superiore richiedono proprietà di conversazione. Per disattivare la funzionalità di conversazioni, scegliere Opzioni dal menu Strumenti , fare clic sulla scheda di acquisizione e quindi fare clic per deselezionare la casella di controllo Abilita le conversazioni .
  • Utilizzo del processore

    La funzionalità di conversazioni di Monitor di rete 3 può aumentare notevolmente l'utilizzo del processore durante l'elaborazione di grandi quantità di frame. Per impostazione predefinita, la funzionalità di conversazioni è disattivata, come indicato nella sezione "Utilizzo della memoria".

Utilizzo generale

Informazioni generali sull'utilizzo di Monitor di rete 3 sono elencati come indicato di seguito.
  • Acquisire i dati di rete

    Come accennato in precedenza, Monitor di rete 3 potrebbe utilizzare grandi quantità di risorse di sistema. Pertanto, se si desidera ridurre al minimo l'effetto sulle risorse di sistema che possono verificarsi quando si utilizza Monitor di rete 3 per acquisire i dati, utilizzare lo strumento della riga di comando Nmcap.exe per acquisire i dati.

    Network Monitor 3 consente di raccogliere dati di rete e visualizzare i dati di rete in tempo reale, come i dati vengono acquisiti. Per avviare una sessione di acquisizione in Monitor di rete 3, fare clic sulla scheda Pagina iniziale , fare clic su Crea una nuova scheda di acquisizionee quindi fare clic sul pulsante Avvia acquisizione oppure premere F10.
  • Filtri

    Network Monitor 3 utilizza una sintassi semplice che è basato sull'espressione di filtro frame. All'utente vengono visualizzati tutti i frame che corrispondono all'espressione. Per ulteriori informazioni sui filtri, effettuare una delle seguenti operazioni:
    • Visualizzare gli argomenti disponibili nella sezione "Utilizzo di filtri" del manuale dell'utente di Network Monitor 3. A tale scopo, dal menu ? , scegliere Sommario e SDKe quindi fare doppio clic sull'Utilizzo di filtri.
    • Dal menu ? , scegliere ricerca per categoriee quindi fare clic su Usa filtri.
    • Utilizzare la scheda di Filtro di acquisizione o il Filtro di visualizzazione per visualizzare i filtri standard.
  • Conversazioni

    Per impostazione predefinita, la funzionalità di conversazioni è ora attivata. La funzionalità di conversazioni può occupare molta memoria, soprattutto in scenari di acquisire i dati per lunghi periodi di tempo. Per disattivare la funzionalità di conversazioni, scegliere Opzioni dal menu Strumenti , fare clic per deselezionare la casella di controllo Abilita le conversazioni nella scheda di acquisizione .

    Quando è attivata la funzionalità di conversazioni, cornici vengono raggruppati e visualizzati nel riquadro di Conversazioni di rete in una struttura ad albero secondo le conversazioni a cui appartengono, con le informazioni sul processo. Ad esempio, i dati TCP che utilizza la stessa porta di origine e la stessa porta di destinazione sono organizzati in un gruppo. Quando si fa clic su un nodo nel riquadro delle Conversazioni di rete , ai fotogrammi nel riquadro Riepilogo della cornice viene applicato automaticamente il filtro corrispondente di conversazione. Vengono visualizzati solo i fotogrammi che appartengono a quel particolare conversazione.
  • Strumento della riga di comando Nmcap.exe

    Lo strumento della riga di comando Nmcap.exe consente di configurare quando si desidera avviare una sessione di acquisizione o di interrompere una sessione di acquisizione. Inoltre, è possibile utilizzare lo strumento della riga di comando Nmcap.exe per creare le acquisizioni concatenate. Acquisizioni concatenate consentono di creare più file di acquisizione. Tuttavia, la dimensione dei file di acquisizione rimane piccola. Attualmente, NMCap Impossibile salvare le informazioni di processo.
  • Rete durante l'analisi del linguaggio (NPL)

    Network Monitor 3 parser sono scritti in un linguaggio in modo specifico per rendere più semplice lo sviluppo di parser. Fornisce inoltre un livello di protezione contro lo sfruttamento di potenziale da codice dannoso che potrebbe verificarsi se il parser sono stati creati come file DLL. NPL fornisce l'accesso al parser. È possibile visualizzare o modificare i parser inclusi in Monitor di rete 3.

Problemi comuni

I problemi comuni includono:
  • Protocolli non possono essere analizzate correttamente. Questo problema può verificarsi se si verifica una delle seguenti condizioni:
    • La funzionalità di conversazioni è disattivata.

      Alcuni protocolli dipendono dalle proprietà di conversazione per memorizzare i valori di stato che possono rivelarsi necessarie in fotogrammi successivi. Ad esempio, TCP deve conversazioni per memorizzare informazioni sui frame ritrasmessi. Il filtro per TCP ritrasmetterà non funzionerà a meno che non è abilitata la funzionalità di conversazioni.

      Allo stesso modo, il protocollo Server Message Block (SMB) è possibile convertire la risposta a un comando di Transact, poiché la risposta non contiene il comando originale. Le informazioni vengono salvate nelle proprietà di conversazione.
    • Parser completo può non essere abilitato. Per impostazione predefinita, è possibile attivare un sottoinsieme di parser di completo per motivi di prestazioni. Per attivare l'insieme completo, attenersi alla seguente procedura:
      1. Scegliere Opzionidal menu Strumenti .
      2. Fare clic sulla scheda Parser .
      3. Selezionare la riga di Windows e quindi fare clic sul pulsante di stub fino a quando la colonna impostare Visualizza completo.
  • Viene visualizzato uno dei seguenti messaggi di errore quando si esegue Monitor di rete 3 su un computer basato su Windows Vista:
    Nessuna delle schede di rete sono associata al driver Netmon
    Questa scheda di rete non è configurata per l'acquisizione di Network Monitor
    Questo problema si verifica se si verifica una delle seguenti condizioni:
    • Monitor di rete 3 non si esegue come amministratore.
    • Non è un membro del gruppo Users Netmon.
    Durante l'installazione di Monitor di rete 3 in Windows Vista o versioni successive, è necessario aggiungere l'account di programmi di installazione al gruppo utenti Netmon. Ma questo non ha effetto fino a quando non si disconnette e quindi nuovamente. Se è necessario acquisire un'immediatamente, è possibile eseguire Monitor di rete 3 come amministratore.

    Per ulteriori informazioni, vedere che il Monitor di rete 3 rilascia note o l'argomento "Funziona su Windows Vista" nella Guida di Network Monitor 3.

Riferimenti

Per informazioni di supporto su Monitor di rete 3, visitare i seguenti siti Web Microsoft:
Forum TechNet su Monitor di rete (http://go.microsoft.com/fwlink/?LinkID=151800)
Blog di Monitor di rete e la pagina di destinazione (http://go.microsoft.com/fwlink/?LinkID=92890)
Parser Open Source di Network Monitor (http://go.microsoft.com/fwlink/?LinkID=125105)
Strumenti di analisi degli esperti di Network Monitor (http://go.microsoft.com/fwlink/?LinkID=133950)

Le informazioni in questo articolo si applicano a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
  • Windows 7 Beta
Chiavi: 
kbhowto kbinfo kbexpertiseinter kbmt KB933741 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 933741  (http://support.microsoft.com/kb/933741/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store