DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 937193 - Ultima modifica: giovedì 11 ottobre 2007 - Revisione: 2.6

Hotfix disponibile per il download
Visualizza e richiedi i download dell'hotfix
 
 
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows

In questa pagina

Sintomi

Si utilizza una stampante di rete cui nome contiene un nome di dominio completo (FQDN) su un computer che esegue Microsoft Windows Server 2003 o Microsoft Windows XP. Il nome della stampante di rete è in uno dei seguenti formati:
  • print server name. different Domain Name System (DNS) domain name \ shared printer name
  • shared printer namesul print server name. different DNS domain name
In un'applicazione, si tenta di selezionare la stampante di rete da un elenco. Tuttavia, un nome di stampante di rete che contiene un nome di dominio completo è troppo lungo che il nome completo non può essere visualizzato nell'elenco. Non è pertanto possibile individuare la stampante di rete che si desidera.

Questo comportamento si verifica se le seguenti condizioni sono vere:
  • La stampante di rete si trova in un dominio. Tuttavia, il server di stampa che ospita la stampante di rete si trova in un altro dominio. In alternativa, i nomi di host del server di stampa configurati in uno spazio dei nomi disgiunto.

    Nota In uno spazio dei nomi disgiunto, il suffisso DNS primario del server di stampa non corrisponde al nome del dominio che include il server di stampa.
  • Stampanti di rete sono creati da utenti in un dominio diverso dal dominio che include il server di stampa. Queste stampanti create con le stampanti pubblicate nel servizio directory Active Directory.

Cause

Nome della stampante deve essere un nome di dominio completo, se le seguenti condizioni sono true:
  • Si desidera distinguere le stampanti di rete da un altro.
  • Queste stampanti di rete hanno lo stesso nome di stampante condivisa.
  • Queste stampanti di rete sono in domini diversi.
Se i nomi delle stampanti di rete non contengono i nomi FQDN, è impossibile distinguere le stampanti di rete uno da altro. Tuttavia, un nome di stampante sarà molto più tempo se il nome contiene un nome di dominio completo. Di conseguenza, è Impossibile visualizzare il nome completo della stampante di rete in un elenco.

Risoluzione

È possibile risolvere questo problema applicando un aggiornamento rapido (hotfix). Tuttavia, devono essere true per applicare l'aggiornamento rapido (hotfix) il seguenti condizioni:
  • I nomi di host dei server di stampa possono essere risolto correttamente.
  • Ogni server di stampa dispone di un nome host univoco sulla rete.
  • Ogni connessione di stampante di rete in tutti i profili utente è stato disconnesso.
Nota Se queste condizioni non sono vere, si potrebbe perdere accesso alle stampanti di rete dopo avere applicato l'hotfix.

Informazioni sull'aggiornamento rapido (hotfix) di Windows Server 2003

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Per installare questo aggiornamento rapido (hotfix), è necessario uno dei seguenti Windows Server 2003 service pack installato nel computer:
  • Windows Server 2003 Service Pack 1 (SP1)
  • Windows Server 2003 Service Pack 2 (SP2)

Necessità di riavvio

È necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix rilasciati in precedenza.

Informazioni del Registro di sistema

Per applicare questo aggiornamento rapido (hotfix), è necessario apportare modifiche al Registro di sistema. Ulteriori informazioni, vedere la sezione "applicare questo aggiornamento rapido (hotfix)".

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows Server 2003 con SP1, versioni 86 e x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Printui.dll5.2.3790.2933577,02410 Maggio 200705: 46x 86
Windows Server 2003 con SP2, versioni 86 e x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Printui.dll5.2.3790.4077568,83210 Maggio 200706: 04x 86
Windows Server 2003 con SP1, versioni basate su Itanium
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Printui.dll5.2.3790.29331,184,25609-200715: 51IA-64SP1Non applicabile
Wprintui.dll5.2.3790.2933577,02409-200715: 51x 86SP1WOW
Windows Server 2003 con SP2, versioni basate su Itanium
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Printui.dll5.2.3790.40771,184,25609-200715: 59IA-64SP2Non applicabile
Wprintui.dll5.2.3790.4077568,83209-200715: 59x 86SP2WOW
Windows Server 2003, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Printui.dll5.2.3790.2933950,27209-200715: 51x 64SP1Non applicabile
Wprintui.dll5.2.3790.2933577,02409-200715: 51x 86SP1WOW
Windows Server 2003 con SP2, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Printui.dll5.2.3790.4077950,27209-200715: 58x 64SP2Non applicabile
Wprintui.dll5.2.3790.4077568,83209-200715: 58x 86SP2WOW

Informazioni sull'aggiornamento rapido (hotfix) di Windows XP

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Per installare questo aggiornamento rapido (hotfix) in un computer di x 86, è necessario Windows XP SP2.

Necessità di riavvio

È necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix rilasciati in precedenza.

Informazioni del Registro di sistema

Per applicare questo aggiornamento rapido (hotfix), è necessario apportare modifiche al Registro di sistema. Per ulteriori informazioni, vedere la sezione "applicare questo aggiornamento rapido (hotfix)".

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows XP Con SP2, versioni basate su 86 su x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Printui.dll5.1.2600.3135560,64010 Maggio 200706: 52x 86
Windows XP con SP2, versioni basate su x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Printui.dll5.2.3790.4077950,27209-200715: 58x 64SP2Non applicabile
Wprintui.dll5.2.3790.4077568,83209-200715: 58x 86SP2WOW
Windows XP con SP1, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Printui.dll5.2.3790.2933950,27209-200715: 51x 64SP1Non applicabile
Wprintui.dll5.2.3790.2933577,02409-200715: 51x 86SP1WOW

Come applicare questo aggiornamento rapido (hotfix)

avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Per applicare questo aggiornamento rapido (hotfix), è necessario aggiungere la voce del Registro di sistema ConnectPrintersWithShortNames. Per eseguire questa attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare e selezionare la seguente sottochiave:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
  3. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  4. Digitare ConnectPrintersWithShortNames e quindi premere INVIO.
  5. Fare clic con il pulsante destro del mouse sulla ConnectPrintersWithShortNames voce del Registro di sistema e quindi fare clic su Modifica .
  6. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  7. Uscire dall'editor del Registro di sistema.

Status

Questo comportamento legato alla progettazione.

Informazioni

Questo aggiornamento rapido (hotfix) modificare il comportamento predefinito. Dopo avere applicato questo aggiornamento rapido (hotfix), le stampanti nel dominio di rete connessi a un server di stampa utilizzando i nomi univoci. Questi nomi sono meno i nomi che contengono i nomi FQDN.

Dopo avere applicato l'aggiornamento rapido, il nome di una stampante di rete potrebbe avere il seguente formato:
  • print server name\ shared printer name
  • shared printer namesul print server name
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684  (http://support.microsoft.com/kb/824684/ ) Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Chiavi: 
kbmt kbautohotfix kbfix kbexpertiseadvanced kbpubtypekc kbqfe kbhotfixserver KB937193 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 937193  (http://support.microsoft.com/kb/937193/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store