DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 938062 - Ultima modifica: venerdì 28 dicembre 2007 - Revisione: 2.1

Hotfix disponibile per il download
Visualizza e richiedi i download dell'hotfix
 

In questa pagina

Sintomi

In Windows Vista sull'icona di un'unità di rete mappata nell'area Cartelle di Esplora risorse viene visualizzata una "X" rossa. Nel riquadro dei dettagli invece per la stessa unità viene visualizzato un cavo verde. Dato che l'accesso all'unità di rete è possibile, ci si aspetta che l'icona visualizzata sia un cavo verde in entrambe le aree.

Questo problema può verificarsi in presenza delle seguenti condizioni:
  • L'unità di rete è stata mappata utilizzando credenziali utente diverse da quelle utilizzate per accedere a Windows Vista.
  • Non è stata selezionata l'opzione Memorizza password quando è stata mappata l'unità di rete.
  • Ci si è disconnessi dal computer e dopo aver effettuato nuovamente l'accesso, è stato fatto doppio clic sull'unità di rete e quindi sono state immesse le credenziali per riconnettersi all'unità.
Il problema non si verifica dopo il riavvio di Esplora risorse.

Cause

La causa del problema è attribuibile a un errore nel file Shell32.dll. Quando l'unità di rete mappata si collega al computer, l'icona dell'unità di rete viene aggiornata dal file Shell32.dll solo nel riquadro dei dettagli di Esplora risorse e non viene generato alcun evento per la modifica dell'icona nell'area Cartelle.

Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato da Microsoft. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo pertanto solo nei sistemi in cui si verifica questo specifico problema. È possibile che su questo hotfix vengano eseguiti ulteriori test. Se il problema in questione non costituisce una seria minaccia per il sistema, si consiglia di attendere il rilascio del prossimo service pack contenente questo hotfix.

Per risolvere il problema, inviare una richiesta al Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per inviare una richiesta in linea per ottenere l'hotfix, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Nota Se si verificano ulteriori problemi o se occorrono attività di risoluzione, può essere necessario creare una richiesta di assistenza separata. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Prerequisiti

Non è richiesto alcun prerequisito.

Richiesta di riavvio

È necessario riavviare il computer una volta applicato l'hotfix.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC (Universal Time Coordinate). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
Windows Vista, edizioni a 32 bit
Riduci questa tabellaEspandi questa tabella
Nome fileVersione fileDimensione fileDataOraPiattaforma
Update.mumNon disponibile1.99401/06/0711.46Non disponibile
X86_5531a733130786984d609cfe13c29b88_31bf3856ad364e35_6.0.6000.20610_none_0d98d3b7d2b3b161.manifestNon disponibile69501/06/0711.46Non disponibile
X86_microsoft-windows-shell32_31bf3856ad364e35_6.0.6000.20610_none_6ac1b7312dfb1b62.manifestNon disponibile975.77201/06/0711.49Non disponibile
Shell32-ppdlic.xrm-msNon disponibile3.15001/06/0702.23Non disponibile
Shell32.dll6.0.6000.2061011.315.20001/06/0702.27x86
Windows Vista, versioni a 64 bit
Riduci questa tabellaEspandi questa tabella
Nome fileVersione fileDimensione fileDataOraPiattaforma
Amd64_250219dca5e4be895407566dad867550_31bf3856ad364e35_6.0.6000.20610_none_275bc5cc6d04e2a8.manifestNon disponibile69901/06/0711.46Non disponibile
Amd64_faf524c008ac10a2194c12a9c16c86e4_31bf3856ad364e35_6.0.6000.20610_none_c8625eed2960e60b.manifestNon disponibile69901/06/0711.46Non disponibile
Amd64_microsoft-windows-shell32_31bf3856ad364e35_6.0.6000.20610_none_c6e052b4e6588c98.manifestNon disponibile977.91901/06/0711.53Non disponibile
Package_1_for_kb938062~31bf3856ad364e35~amd64~~6.0.1.0.mumNon disponibile1.78801/06/0711.46Non disponibile
Package_2_for_kb938062~31bf3856ad364e35~amd64~~6.0.1.0.mumNon disponibile2.00501/06/0711.46Non disponibile
Update.mumNon disponibile1.90901/06/0711.46Non disponibile
Wow64_microsoft-windows-shell32_31bf3856ad364e35_6.0.6000.20610_none_d134fd071ab94e93.manifestNon disponibile968.81901/06/0711.53Non disponibile
Shell32-ppdlic.xrm-msNon disponibile3.15001/06/0703.28Non disponibile
Shell32.dll6.0.6000.2061012.783.10401/06/0703.45x64
Shell32.dll6.0.6000.2061011.315.20001/06/0702.27x86
Questo hotfix aggiorna il file Shell32.dll affinché venga generata una notifica per la modifica dell'icona. Dopo l'applicazione di questo hotfix, l'icona dell'unità principale nel riquadro dei dettagli di Esplora risorse e l'icona nel riquadro Cartelle di Esplora risorse verranno aggiornate.

Workaround

Per risolvere il problema, riavviare Esplora risorse.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine del presente articolo.

Informazioni

Per ulteriori informazioni sulla terminologia utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684  (http://support.microsoft.com/kb/824684/ ) Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Le informazioni in questo articolo si applicano a
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Chiavi: 
kbvistasp1fix kbwinvistapostrtmfix kbexpertiseinter kbhotfixserver kbqfe KB938062
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store