DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 938803 - Ultima modifica: lunedì 11 maggio 2009 - Revisione: 2.1

Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di eseguirne una copia di backup e di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756  (http://support.microsoft.com/kb/322756/ ) HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP

INTRODUZIONE

In questo articolo viene descritto come disattivare file CAD con estensione dwg dopo l'installazione di Microsoft Office Visio 2003 Service Pack 3 (SP3) o di Microsoft Office Visio 2007 Service Pack 2 (SP2).

Informazioni

Avviso L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Dopo l'installazione di Visio 2003 SP3 o di Microsoft Office Visio 2007 SP2, è possibile disattivare l'utilizzo di file dwg in Visio 2003 o in Visio 2007. Tale operazione è consigliabile per migliorare la protezione dei file di Visio.

Quando si disattivano file con estensione dwg, si verifica il seguente comportamento:
  • Nella casella Tipo file nella finestra di dialogo Apri non viene visualizzato il formato Disegno di AutoCAD (*.dwg; *.dxf).
  • Il comando Disegno CAD è disattivato nel menu Inserisci.
  • Quando si apre un file di Visio che contiene un oggetto CAD, tale oggetto viene visualizzato come un contenitore vuoto. Il controllo ActiveX nell'oggetto CAD è disattivato.
  • Nella casella Tipo file nella finestra di dialogo Salva con nome non viene visualizzato il formato Disegno di AutoCAD (*.dwg; *.dxf).
  • Quando si sceglie Componenti aggiuntivi dal menu Strumenti, Converti disegni CAD è disattivato.
  • Quando si sceglie Componenti aggiuntivi dal menu Strumenti, Converti libreria CAD è disattivato.
Per disattivare i file con estensione dwg, attenersi alla procedura descritta di seguito:
  1. Uscire da Visio.
  2. Avviare l'editor del Registro di sistema. A questo scopo, utilizzare uno dei seguenti metodi:
    • In Windows Vista fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante Start
      , digitare regedit nella casella Inizia ricerca, quindi premere INVIO.

      Riduci l'immagineEspandi l'immagine
      Autorizzazione Controllo dell'account
					 utente
      Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Continua.
    • In Microsoft Windows XP fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  3. Individuare e fare clic sulla seguente chiave del Registro di sistema:
    • Visio 2003: HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Visio\Application
    • Visio 2007: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Visio\Application
  4. Dopo avere selezionato la chiave specificata al passaggio 3, scegliere Nuovo dal menu Modifica, quindi scegliere Valore DWORD.
  5. Digitare DisableDWG e premere INVIO.
  6. Fare clic con il pulsante destro del mouse su DisableDWG e scegliere Modifica.
  7. Nella casella Dati valore digitare 1, quindi scegliere OK.
  8. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti.

Le informazioni in questo articolo si applicano a:
  • Microsoft Office Visio 2003 Service Pack 3 alle seguenti piattaforme
    • Microsoft Office Visio Professional 2003
    • Microsoft Office Visio Standard 2003
  • 2007 Microsoft Office Suite Service Pack 2 alle seguenti piattaforme
    • Microsoft Office Visio Professional 2007
    • Microsoft Office Visio Standard 2007
Chiavi: 
kbregistry kbupdateissue kbexpertiseinter kbhowto KB938803
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store