DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 939941 - Ultima modifica: venerdì 16 maggio 2008 - Revisione: 3.1

Hotfix disponibile per il download
Visualizza e richiedi i download dell'hotfix
 
 
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322756  (http://support.microsoft.com/kb/322756/ ) Come eseguire il backup e il ripristino del Registro di sistema in Windows

In questa pagina

Sintomi

In Windows Internet Explorer 7 o in Microsoft Internet Explorer 6, quando si tenta di utilizzare metodo POST o il metodo GET per passare dati dei moduli in una pagina Web, è si potrebbe verifichi uno dei seguenti sintomi.

Sintomo 1

Il metodo POST o il metodo GET potrebbe codificare alcuni caratteri come riferimenti a caratteri numerici Unicode. Ad esempio, questi metodi possono codificare あ come % 26 % 2312354 % 3B.

Questo problema può verificarsi nelle pagine Web contenenti caratteri giapponesi. Inoltre, le pagine Web sono contrassegnate con un set di caratteri di windows-31j nelle intestazioni di HTTP.

Sintomo 2

Il metodo POST o il metodo GET non è possibile trasmettere dati di form al server Web. Inoltre, è possibile che venga visualizzato un messaggio di errore script analogo al seguente:
Riga: Line Number
Number di carattere:
Errore: Errore non specificato.
Codice: 0
URL: URL
Questo problema può verificarsi se i dati del modulo contengano caratteri solo Unicode all'inizio di un solo campo. Ad esempio, i dati di form potrebbero contenere uno dei seguenti tipi di caratteri solo Unicode all'inizio di un solo campo:
  • Una combinazione di caratteri ASCII e giapponese.
  • Il carattere U + C 301 (tilde 〜) con caratteri del cinese, giapponese o coreano.
  • Il carattere U + 3030 (tilde 〰) con caratteri del cinese, giapponese o coreano.

Cause

Questo problema si verifica perché Internet Explorer non correttamente utilizza la tabella codici per la lingua richiesta quando i dati del form contengano alcune combinazioni di caratteri.

Risoluzione

Informazioni sull'aggiornamento di protezione

Per risolvere questo problema, è necessario installare l'aggiornamento cumulativo della protezione più recente per Internet Explorer. Per installare gli aggiornamenti più recenti, visitare il seguente sito di Web di Microsoft:
http://windowsupdate.microsoft.com (http://windowsupdate.microsoft.com)
Per informazioni più tecniche sull'aggiornamento della protezione cumulativo più recente per Internet Explorer, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/technet/security/current.aspx (http://www.microsoft.com/technet/security/current.aspx)
Nota Questa correzione è stata innanzitutto inclusa nell'aggiornamento della protezione 947864 (MS08-024). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
947864  (http://support.microsoft.com/kb/947864/ ) MS08-024: Aggiornamento cumulativo della protezione per Internet Explorer

Informazioni sul Service pack

Per risolvere il problema, ottenere il service pack più recente per Windows Vista. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
935791  (http://support.microsoft.com/kb/935791/ ) Come ottenere il service pack più recente per Windows Vista

Informazioni sull'hotfix

Internet Explorer 7 in Windows Vista

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
Per applicare questo aggiornamento rapido (hotfix), è necessario Internet Explorer 7 installato in Windows Vista.
Necessità di riavvio
È necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows Vista, versioni x 86
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Update.mumNon applicabile1,95514 Agosto 200713: 43Non applicabile
X86_c6d00ed094683fc17863d9f000f3471f_31bf3856ad364e35_6.0.6000.20660_none_6a6c64b1e7fb11d5.manifestNon applicabile70414 Agosto 200713: 43Non applicabile
X86_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_6.0.6000.20660_none_11a58f533e513474.manifestNon applicabile928,49414 Agosto 200713: 43Non applicabile
Mshtml.dll7.0.6000.206603,592,19214 Agosto 200702: 22x 86
Mshtml.tlb7.0.6000.206601,383,42413-Ago-200723: 27Non applicabile

Windows Vista, versioni a 64 bit
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Amd64_adc064d3c3764f0db37954aa4e7dc73d_31bf3856ad364e35_6.0.6000.20660_none_0cf1d7b9cf353430.manifestNon applicabile70814 Agosto 200713: 43Non applicabile
Amd64_c6d00ed094683fc17863d9f000f3471f_31bf3856ad364e35_6.0.6000.20660_none_c68b0035a058830b.manifestNon applicabile70614 Agosto 200713: 43Non applicabile
Amd64_microsoft-windows - ie - htmlrendering_31bf3856ad364e35_6.0.6000.20660_none_6dc42ad6f6aea5aa.manifestNon applicabile928,55514 Agosto 200713: 47Non applicabile
Package_1_for_kb939941 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.1.0.mumNon applicabile1,80314 Agosto 200713: 43Non applicabile
Package_2_for_kb939941 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.1.0.mumNon applicabile1,96614 Agosto 200713: 43Non applicabile
Update.mumNon applicabile1,86914 Agosto 200713: 43Non applicabile
Mshtml.dll7.0.6000.206605,679,10414 Agosto 200704: 39x 64
Mshtml.tlb7.0.6000.206601,383,42413-Ago-200723: 38Non applicabile

Internet Explorer 7 in Windows Server 2003

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
Per applicare questo aggiornamento rapido (hotfix), è necessario soddisfare i requisiti seguenti:
  • È necessario Windows Server 2003 Service Pack 2 installato nel computer. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
    889100  (http://support.microsoft.com/kb/889100/ ) Come ottenere il service pack più recente per Windows Server 2003
  • È necessario Internet Explorer 7 in Windows Server 2003 Service Pack 2.
Necessità di riavvio
È necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows Server 2003 con Service Pack 2, versioni x 86
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mshtml.dll7.0.6000.206613,592,19222-Ago-200722: 12x 86

Windows Server 2003 con Service Pack 2, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Mshtml.dll7.0.6000.206615,679,10422-Ago-200720: 07x 64SP2Non applicabile
Wmshtml.dll7.0.6000.206613,592,19222-Ago-200720/08:x 86SP2WOW

Windows Server 2003 con Service Pack 2, versioni basate su Itanium
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Mshtml.dll7.0.6000.2066110,051,58422-Ago-200720/08:IA-64SP2Non applicabile
Wmshtml.dll7.0.6000.206613,592,19222-Ago-200720: 09x 86SP2WOW

Internet Explorer 7 e Internet Explorer 6 in Windows XP

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
Per applicare questo aggiornamento rapido (hotfix), è necessario Windows XP Service Pack 2 installato nel computer. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322389  (http://support.microsoft.com/kb/322389/ ) Come ottenere il service pack più recente per Windows XP
Necessità di riavvio
È necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows XP con Service Pack 2, le versioni x 86 per Internet Explorer 6
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mshtml.dll6.0.2900.31953,064,83214 Agosto 200716: 43x 86
Windows XP con Service Pack 2, le versioni x 86 per Internet Explorer 7
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mshtml.dll7.0.6000.206613,592,19223-Ago-200706: 50x 86

Informazioni di post-installazione

avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Dopo avere applicato questo aggiornamento rapido (hotfix), è necessario modificare il Registro di sistema per attivare l'hotfix. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .

    Nota In un computer basato su Windows Vista, fare clic sul
    Riduci l'immagineEspandi l'immagine
    the Start button
    di Start , digitare regedit nella casella Inizia ricerca e quindi premere INVIO .
  2. Individuare e selezionare la seguente sottochiave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Scegliere Nuovo dal menu Modifica , quindi chiave .
  4. Digitare FEATURE_INTL_FORM_RESULTS_ENCODING_KB939941 e quindi premere INVIO .
  5. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  6. Digitare iexplore.exe e quindi premere INVIO .
  7. Nel menu Modifica , fare clic su Modifica .
  8. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  9. Scegliere Nuovo dal menu Modifica , quindi chiave .
  10. Digitare FEATURE_WINDOWS31J_FALLBACK_KB939941 e quindi premere INVIO .
  11. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  12. Digitare iexplore.exe e quindi premere INVIO .
  13. Nel menu Modifica , fare clic su Modifica .
  14. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  15. Uscire dall'editor del Registro di sistema.

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a". Questo problema è stato innanzitutto corretto in Windows Vista Service Pack 1.

Informazioni

È possibile utilizzare il codice di esempio riportato di seguito per visualizzare i problemi descritti nel hoge dim section.
<%
  dim hoge
  Response.AddHeader "Cache-Control", "no-cache"
  Response.ContentType = "text/html; charset=windows-31J"
  hoge = Request.QueryString("p1")
%>
<html>
<body>
  <a href="testcase.asp">Reset page</a><br>
  <h4>Testcase: Submit Wave Dash</h4>
  <form name="form1">
  P1: <input type="text" name="p1" value="&#12316;"><br>
  <input type="submit" value="type=submit">
  <input type="button" value="type=button" onClick="javascript:form1.submit();">
  </form>
  <br>
  P1 = <%=hoge%> <br><br>
  <code>
     P1 = [Wave Dash]<br>
     Result: <br>
       Form Cannot be submitted (javascript error in javascript case)<br>
     Expected Result: <br>
       Form should be submitted<br>
  </code>
  </body>
</html>
Per ulteriori informazioni su come passare il form dati da una pagina a un'altra utilizzando GET e POST in pagine ASP, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
300104  (http://support.microsoft.com/kb/300104/ ) Come passare i dati del modulo da una pagina a un altro utilizzando GET e POST in pagine ASP
Per ulteriori informazioni sull'attributo METHOD e la proprietà del metodo , visitare il seguente sito Web:
http://msdn2.microsoft.com/en-us/library/ms534167.aspx (http://msdn2.microsoft.com/en-us/library/ms534167.aspx)

Le informazioni in questo articolo si applicano a:
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 in Windows Vista
  • Microsoft Internet Explorer 6.0 alle seguenti piattaforme
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
Chiavi: 
kbmt kbautohotfix kbvistasp1fix kbexpertiseinter kbpubtypekc kbqfe kbhotfixserver KB939941 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 939941  (http://support.microsoft.com/kb/939941/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store