DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 942995 - Ultima modifica: mercoledì 25 novembre 2009 - Revisione: 3.0

In questa pagina

Sintomi

Dopo aver installato un Service Pack o un aggiornamento per Microsoft Office 2007, viene richiesto in modo imprevisto di riavviare il computer.

Nota Dopo l'installazione del Service Pack 2 per la famiglia di prodotti Office 2007, è consigliabile riavviare il computer per assicurarsi che possano essere utilizzati i nuovi file.

Cause

Questo problema può verificarsi se il Service Pack o l'aggiornamento prevede la modifica di un file in uso da parte di un programma in esecuzione al momento dell'installazione del Service Pack o dell'aggiornamento. Talvolta il programma che utilizza il file non è un programma di Office. Può essere incluso il sistema operativo.

Questo problema può verificarsi in presenza di una o più delle seguenti condizioni:
  • Un dispositivo sincronizzato con Microsoft Outlook è collegato al computer client. Inoltre, è in esecuzione ActiveSync.
  • È in esecuzione un programma di Office.
  • È in esecuzione Office Communicator 2005 oppure Office Communicator 2007.
  • È in esecuzione il servizio Office Groove 2007 (GrooveMonitor.exe).
  • È in esecuzione il servizio Windows Desktop Search (Searchprotocolhost.exe).
  • È installato l'Input Method Editor (IME) per la lingua giapponese.
Nota Questo elenco non è esaustivo. Questo problema può verificarsi anche a causa di altri programmi.

Risoluzione

Prima di installare il Service Pack o l'aggiornamento, chiudere qualsiasi programma o servizio in esecuzione che possa interferire con l'installazione del Service Pack o dell'aggiornamento.

I metodi seguenti consentono di ottenere informazioni su come chiudere alcuni dei programmi e servizi che possono causare il problema.

Come uscire da ActiveSync

Per uscire da ActiveSync, è necessario terminare il processo Wcescomm.exe. Per terminare il processo Wcescomm.exe, vedere la sezione "Come terminare un processo di un programma in esecuzione in background".

Nota Quando si termina il processo, gli eventuali utenti o dispositivi connessi al servizio ActiveSync verranno disconnessi.

Come uscire da un programma di Office

Per uscire da un programma di Office, scegliere Esci dal menu File. Se il programma di Office non è visibile sullo schermo, premere ALT+TAB per renderlo attivo. In alternativa, fare clic sul pulsante del programma di Office sulla barra delle applicazioni.

Nota Un processo di un programma di Office può continuare a essere eseguito in background se un problema causa la chiusura anomala del programma. Se si sospetta che un processo di un programma di Office sia in esecuzione in background, terminare il processo. A questo scopo vedere la sezione "Come terminare un processo di un programma in esecuzione in background".

Come uscire da Communicator 2005 o Communicator 2007

Per uscire da Communicator 2005 o Communicator 2007, disconnettersi da Communicator, chiudere il programma e uscire. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Scegliere Disconnetti dal menu Connetti.
  2. Scegliere Chiudi dal menu Connetti.

    Nota Quando si chiude Communicator 2005 o Communicator 2007, il programma viene ridotto a icona nell'area di notifica.
  3. Fare clic con il pulsante destro del mouse sull'icona di Communicator 2005 o di Communicator 2007 nell'area di notifica e scegliere Esci.

Come terminare un processo di un programma in esecuzione in background

Importante La chiusura di un processo può provocare risultati indesiderati, quali l'instabilità del sistema e la perdita di dati. Quando si termina un processo, non è possibile salvarne lo stato o i dati prima di procedere alla chiusura.

Per terminare un processo di un programma in esecuzione in background, utilizzare uno dei metodi seguenti.

Metodo 1: Utilizzare Gestione attività

  1. Premere CTRL+ALT+CANC.
  2. Nella scheda Processi fare clic su nomefile_processo, quindi scegliere Termina processo.

    Nota In questo metodo nomefile_processo rappresenta il nome file del processo che si desidera terminare.

Metodo 2: Utilizzare il comando Taskkill

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd, quindi scegliere OK.
  2. Al prompt dei comandi digitare taskkill /im nomefile_processo, quindi premere INVIO.

    Note
    • In questo metodo nomefile_processo rappresenta il nome file del processo che si desidera terminare.
    • Per ulteriori informazioni sul comando Taskkill, digitare taskkill /? al prompt dei comandi, quindi premere INVIO.
  3. Al prompt dei comandi digitare exit per chiudere la finestra del prompt dei comandi.

Come impedire al computer di riavviarsi inaspettatamente quando si distribuisce un Service Pack o un aggiornamento per Office 2007

Gli amministratori che distribuiscono un Service Pack o un aggiornamento per Office possono utilizzare uno script per chiudere tutti i programmi o servizi che potrebbero interferire con l'installazione del Service Pack o dell'aggiornamento.

Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia di qualsiasi tipo, sia espressa che implicita, ivi incluse, senza limitazioni, le garanzie implicite di commerciabilità o idoneità per uno scopo particolare. In questo articolo si presuppone che l'utente conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug delle procedure. Gli esperti Microsoft sono autorizzati a fornire spiegazioni in merito alla funzionalità di una particolare routine, ma in nessun caso a modificare questi esempi per fornire funzionalità aggiuntive o a creare routine atte a soddisfare specifiche esigenze.

Per chiudere programmi o servizi mediante uno script, creare uno script simile al seguente.
; TechNet Sample 2005
; http://www.microsoft.com/technet/scriptcenter/resources/qanda/sept04/hey0927.mspx
; For more information about how to use scripts to manage processes, visit the following Microsoft Web site:
; http://www.microsoft.com/technet/scriptcenter/guide/sas_prc_overview.mspx
strComputer = "."
Set objWMIService = GetObject _
    ("winmgmts:\\" & strComputer & "\root\cimv2")
Set colProcessList = objWMIService.ExecQuery _
    ("Select * from Win32_Process Where Name = 'Communicator.exe'")
For Each objProcess in colProcessList
    objProcess.Terminate()
Next

Informazioni

In genere non è necessario riavviare il computer a seguito dell'installazione di un Service Pack o di un aggiornamento per Office 2007. Vi sono tuttavia casi in cui occorre riavviarlo.

Se è necessario riavviare il computer dopo aver installato un Service Pack o un aggiornamento per Office, le informazioni sul riavvio sono incluse nella documentazione fornita con il Service Pack o l'aggiornamento per Office.

Per determinare la causa della richiesta di riavvio, esaminare il contenuto del file registro dell'installazione. Per impostazione predefinita, questo file non viene creato. Per creare il file registro dell'installazione e trovare i processi che potrebbero essere la causa del problema, attenersi alla seguente procedura:
  1. Effettuare una delle seguenti operazioni a seconda della specifica situazione:
    • In Windows Vista fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante Start
      , digitare esegui, digitare il percorso e il nome file del Service Pack o dell'aggiornamento seguito da /log, nella casella Inizia ricerca e premere INVIO.

      Riduci l'immagineEspandi l'immagine
      Autorizzazione Controllo
					 all'account utente
      Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o scegliere Continua.
    • In Windows XP fare clic sul pulsante Start, scegliere Esegui, digitare il percorso e il nome file del Service Pack o dell'aggiornamento seguito da /log nella casella Apri, quindi scegliere OK.
    Digitare ad esempio quanto riportato di seguito nella casella Inizia ricerca o nella casella Apri:
    percorso\nome file /log:%temp%\Office2007SP1SetupLog.txt
    Note
    • Il segnaposto percorso rappresenta il percorso completo del Service Pack o dell'aggiornamento. Il segnaposto nome file rappresenta il nome del Service Pack o dell'aggiornamento.
    • Numerosi file di testo vengono salvati nella cartella Temp. Per il Service Pack 1 per Office 2007 il file registro pertinente viene salvato come MAINWWsp1.log.
  2. Aprire il file registro in un editor di testo, ad esempio il Blocco note.
  3. Cercare il testo seguente:
    è utilizzato
  4. Continuare la ricerca finché non vengono rilevate tutte le occorrenze del testo indicato nel passaggio 3.
Il testo del file registro sarà simile a quanto riportato di seguito:
MSI (s) (5C:3C) [16:06:34:629]: Prodotto: Microsoft Office Enterprise 2007. Il file C:\Programmi\File comuni\Microsoft Shared\OFFICE12\MSO.DLL è utilizzato dal processo seguente Nome: GROOVE, Id 388.
L'opzione della riga di comando /log è supportata da un pacchetto di installazione software, da un pacchetto di aggiornamento o da un pacchetto hotfix. Questi pacchetti devono essere creati mediante Microsoft Self-Extractor. L'opzione della riga di comando /log consente di attivare la registrazione dettagliata nel file registro dell'installazione.

Per ulteriori informazioni sulle opzioni della riga di comando supportate da Microsoft Self-Extractor, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
912203  (http://support.microsoft.com/kb/912203/ ) Descrizione delle opzioni della riga di comando supportate da un pacchetto di installazione software, da un pacchetto di aggiornamento o da un pacchetto hotfix creato con Microsoft Self-Extractor
Per ulteriori informazioni su questo problema in Outlook 2007, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
943590  (http://support.microsoft.com/kb/943590/ ) Visualizzazione del messaggio di errore “Impossibile accedere al file Outlook.ost, perché utilizzato da un’altra applicazione” durante il tentativo di avvio di Outlook 2007, dopo l'installazione del Service Pack 1 per la famiglia di prodotti Office 2007

Le informazioni in questo articolo si applicano a:
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Small Business 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Access 2007
  • Microsoft Office Excel 2007
  • Microsoft Office Groove 2007
  • Microsoft Office InfoPath 2007
  • Microsoft Office OneNote 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office SharePoint Designer 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Word 2007
Chiavi: 
kbupdateissue kbtshoot kbpubtypekc kbexpertisebeginner kbprb KB942995
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store