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Identificativo articolo: 951607 - Ultima modifica: mercoledì 28 luglio 2010 - Revisione: 1.0

 

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Sintomi

Su un Windows XP Service Pack 3 (SP3), o Windows Small Business Server 2003 Service Pack 1 (SP1), computer, si verificano i seguenti sintomi:
  • Quando si tenta di connettersi a un computer remoto tramite connessione Web Desktop remoto (TSWeb) ilConnettersipulsante è disattivato. Pagina TSWeb può contenere anche il seguente messaggio di avviso:
    Controllo ActiveX di connessione Web Desktop remoto non è installato. Impossibile stabilire una connessione senza una versione installata e funzionante del controllo.
    NotaQuando si tenta di installare il client di connessione desktop remoto 6.0, viene visualizzato un messaggio che informa che è già installato nel computer.
  • Quando si utilizza il sito area di lavoro Web remota (RWW) per connettersi a un computer remoto, si noterà che non è possibile scaricare il controllo ActiveX Connessione Desktop remoto. Oppure, viene visualizzato il seguente messaggio di errore:
    Nome server non valido.
    NotaWorkspace Web remota è una funzionalità disponibile in Microsoft Windows Small Business Server (Windows SBS).
  • Quando si utilizza il sito Web di accesso Web di Servizi Terminal (TSWA) per connettersi a un computer remoto o per avviare un'applicazione remota, viene visualizzato il seguente messaggio di errore:
    Sito Web this richiede il client di Servizi Terminal non sembra essere installato su questo sistema. Installare il client più recente e assicurarsi di avere a disposizione il più recente di Windows Update prima di continuare.
  • Quando si accede alla pagina del computer di accesso remoto utilizzando Windows Home Server, è possibile che venga visualizzato il seguente messaggio di errore:
    Componente aggiuntivo disattivato questa pagina Web richiede un componente aggiuntivo disattivato. Per attivare il componente aggiuntivo fare clic qui.
    , Inoltre, quando si tenta di connettersi a Windows Home Server o a un computer di casa, è possibile che venga visualizzato il seguente messaggio di errore:
    Questa funzionalità è necessario che della Windows Home Server https://my.homeserver.com indirizzo sito Web da aggiungere all'area siti attendibili in Internet Explorer. Per aggiungere Windows Home della finestra di dialogo Opzioni Internet sito Web indirizzo aprire Internet Explorer del server di, fare clic nella scheda protezione. Selezionare "Siti attendibili" e fare clic sul pulsante siti. Aggiungere il https://my.homeserver.com indirizzo sito Web con il pulsante Aggiungi, quindi premere Chiudi.
    NotaDopo aver aggiunto l'URL del server principale all'elenco dei siti attendibili, viene visualizzato lo stesso messaggio di errore ed è ancora Impossibile connettersi.
  • Quando si accede a Windows Home Server tramite il sito Web di accesso remoto, è possibile che venga visualizzato il seguente messaggio di errore:
    Componente aggiuntivo disattivato questa pagina Web richiede un componente aggiuntivo disattivato. Per attivare il componente aggiuntivo fare clic qui.
    , Inoltre, quando si tenta di connettersi alla home page di Windows Server, è possibile che venga visualizzato il seguente messaggio di errore:
    Per connettersi al server principale o il computer di casa in remoto, il componente aggiuntivo controllo Microsoft Terminal Services Client o un componente aggiuntivo di Microsoft RDP deve essere installato e abilitato per i browser web. Se hai rifiutato installare il componente aggiuntivo, aggiornare la pagina e installazione quando richiesto. In caso contrario, attivare il componente aggiuntivo utilizzando l'icona di Gestione componenti aggiuntivi della barra di stato del browser Web oppure fare riferimento alla documentazione del browser su come attivare il componente aggiuntivo.

Cause

Questo problema si verifica se il controllo ActiveX per il client Connessione Desktop remoto non è abilitato nel browser Web. Per impostazione predefinita, il controllo ActiveX viene disattivato dopo l'installazione di Windows XP Service Pack 3 (SP3) o Windows Small Business Server 2003 SP1.

Workaround

Per aggirare il problema, attenersi alla seguente procedura:
  1. Avviare Internet Explorer.
  2. Visitare il sito Web che ha causato il problema.
  3. Se si utilizza Windows Internet Explorer 7, attenersi alla seguente procedura:
    1. SulStrumentidal menuGestione componenti aggiuntivi, quindi fare clic suAttiva o disattiva componenti aggiuntivi. IlGestione componenti aggiuntiviverrà visualizzata la finestra di dialogo.
    2. Nell'elenco dei componenti aggiuntivi, cercare il controllo ActiveX Control Client Servizi Terminal di Microsoft o Microsoft RDP client controllo Control ActiveX. Se non è possibile trovare il controllo, vedere la procedura descritta in "Se il controllo non viene visualizzato nell'elenco dei componenti aggiuntivi" alla fine di questa sezione.
    3. Fare clic sul controllo, scegliereAttiva, quindi fare clic suOKper chiudere la finestra di dialogo Gestione componenti aggiuntivi.

    Se si utilizza Internet Explorer 6, attenersi alla seguente procedura:
    1. SulStrumentimenu, scegliereGestione componenti aggiuntivi. IlGestione componenti aggiuntiviverrà visualizzata la finestra di dialogo.
    2. Nell'elenco dei componenti aggiuntivi, cercare il controllo ActiveX Control Client Servizi Terminal di Microsoft o Microsoft RDP client controllo Control ActiveX. Se non è possibile trovare il controllo, vedere la procedura descritta in "Se il controllo non viene visualizzato nell'elenco dei componenti aggiuntivi" alla fine di questa sezione.
    3. Fare clic sul controllo, scegliereAttiva, quindi fare clic suOKper chiudere ilGestione componenti aggiuntivifinestra di dialogo.
  4. Aggiungi il sito per i siti attendibili in Internet Explorer.
  5. Riavviare Internet Explorer.
  6. Tentano di connettersi al computer remoto. Oppure provare ad avviare l'applicazione remota.

Se il controllo non viene visualizzato nell'elenco dei componenti aggiuntivi

Controllo talvolta il Microsoft Terminal Services Client controllo ActiveX non verrà visualizzato nell'elenco dei componenti aggiuntivi. Per noi correggere il problema, passare la "Correggere il problema per me"sezione. È piuttosto dovrebbe risolvere manualmente questo problema, passare la "Consenti correzione manuale "sezione.

Correggere il problema per me

Per risolvere il problema automaticamente, scegliere ilRisolvere il problemacollegamento . ScegliereEseguirenelDownload dei filefinestra di dialogo casella e seguire i passaggi della procedura guidata.

Risolvere il problema
Microsoft Fix it 50391

Notaquesta procedura guidata può essere solo in inglese, tuttavia, la correzione automatica funziona anche per altre versioni di Windows.

NotaSe non sono presenti computer che presenta il problema, è possibile salvare la correzione automatica in un'unità memoria flash o su un CD in modo da poter eseguire sul computer che presenta il problema.

Consenti correzione manuale

Per risolvere il problema manualmente se il controllo non viene visualizzato, è possibile provare la procedura seguente per tentare di visualizzare il controllo dalla reimpostazione di Internet Explorer in una configurazione predefinita.
  1. Avviare Internet Explorer.
  2. Fare clic suFile, quindi fare clic suImportazione ed esportazione.
  3. Seguire i passaggi della procedura guidata per esportare i Preferiti.
  4. Fare clic suStrumenti, quindi fare clic suOpzioni Internet.
  5. Fare clic suAvanzate, quindi fare clic suReimposta.

Dopo Internet Explorer è stata ripristinata una configurazione predefinita, tenta di connettersi al computer remoto oppure avviare l'applicazione remota. Se non funziona, seguire i passaggi della soluzione per attivare il controllo ActiveX Control Client Servizi Terminal di Microsoft. Se il controllo non è ancora elencato, è possibile modificare il Registro di sistema per rimuovere una chiave, se esiste.

ImportanteQuesto articolo contiene informazioni su come modificare il Registro di sistema. Assicurarsi di eseguire il backup del Registro di sistema prima di modificarlo. Assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

Remove the following registry keys, if they exist:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7584C670-2274-4EFB-B00B-D6AABA6D3850}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{971127BB-259F-48C2-BD75-5F97A3331551}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{9059F30F-4EB1-4BD2-9FDC-36F43A218F4A}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EB89FF4-7F78-4A0F-8B8D-2BF02E94E4B2}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EDCB26C-D24C-4e72-AF07-B576699AC0DE}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390F3D8-0439-4C05-91E3-CF5CB290C3D0}

Dopo aver rimosso le chiavi del Registro di sistema, uscire e riavviare Internet Explorer e provare a connettersi al computer remoto oppure avviare nuovamente l'applicazione remota.

Se il problema persiste, è possibile registrare il file mstscax.dll. A questo scopo, attenersi alla seguente procedura:
  1. Uscita Internet Explorer.
  2. Fare clic suAvviarefare clic suEseguiree il tipo oppure copiare e incollare il seguente testo diApricasella, quindi scegliereOK:
    %windir%\System32\regsvr32 mstscax.dll
  3. Al prompt di conferma, scegliereOK.
  4. Riavviare Internet Explorer e provare a connettersi al computer remoto oppure avviare l'applicazione remota.

Informazioni

In Windows XP Service Pack 2 (SP2), è necessario installare il file Msrdp.ocx per attivare il controllo ActiveX di Servizi Terminal. Windows XP Service Pack 3 (SP3) già include il controllo ActiveX e viene installato utilizzando il file Mstscax.dll. Per impostazione predefinita, questo controllo ActiveX è disattivato in Windows XP Service Pack 3 (SP3).

Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Service Pack 3
  • Windows Home Server
  • Windows Small Business Server 2008 Premium
  • Windows Small Business Server 2008 Standard
  • Windows Essential Business Server 2008 Standard
Chiavi: 
kbexpertiseinter kbtshoot kbprb kbmsifixme kbfixme kbmt KB951607 KbMtit
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Clicca qui per visualizzare la versione originale in inglese dell’articolo: 951607  (http://support.microsoft.com/kb/951607/en-us/ )
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