DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 958046 - Ultima modifica: sabato 23 novembre 2013 - Revisione: 2.0

 

In questa pagina

Sintomi

Quando si tenta di connettersi al sito Web Windows Update o Microsoft Update, viene visualizzato il seguente codice di errore:
0X80248007

Cause

Questo problema si verifica per uno dei seguenti motivi:
  • Windows Update o Microsoft Update determina che vi sono dati mancanti nell'archivio dati di Microsoft Windows Update.
  • Windows Update o Microsoft Update non è possibile individuare le condizioni di licenza Software Microsoft.

Risoluzione

Per risolvere il problema, utilizzare i metodi seguenti nell'ordine in cui sono presentate.

Metodo 1: Rinominare la cartella di download temporanea di Windows Update

Per rinominare la cartella di download temporanea di Windows Update, attenersi alla procedura appropriata per il sistema operativo.

Importante Dopo aver rinominato la cartella di download temporanea, gli aggiornamenti già scaricati, ma che non è stato ancora installato devono essere scaricati nuovamente da Windows Update o Microsoft Update.

In Windows XP, in Windows Server 2003 e in Windows 2000, attenersi alla seguente procedura:
  1. Avviare Blocco note. A tale scopo, fare clic su Starte quindi fare clic su Esegui.
  2. Immettere il seguente comando nella casella Apri , quindi premere di copia e Incolla (o tipo):
    Blocco note
  3. Copiare e incollare le seguenti righe di comando nella finestra Blocco note (o digitare):
    net stop wuauserv
    CD %systemroot%\SoftwareDistribution
    ren scaricare download. old
    net start wuauserv
  4. Dal menu File scegliere Salva con nomee quindi digitare Rename.bat.
  5. Fare clic su Salva come tipoe quindi fare clic su Tutti i file.
  6. Salvare il file Rename.bat sul desktop.
  7. Fare doppio clic sul file Rename.bat per rinominare la cartella di Download.
  8. Provare a installare nuovamente gli aggiornamenti.
  9. Se il problema viene risolto, eliminare il file Rename.bat creato nei passaggi precedenti.
Se il problema persiste, passare al metodo 2.

Nota. Una volta completata, è possibile scaricare e installare gli aggiornamenti, è possibile eliminare la cartella di download. old per recuperare spazio su disco.

In Windows Vista e in Windows Server 2008, attenersi alla seguente procedura:
  1. Fare clic su Start
    Riduci l'immagineEspandi l'immagine
     Pulsante Start
    , quindi digitare Blocco note Nella casella Inizia ricerca .
  2. Nell'elenco programmi , fare clic su blocco note.
  3. Copiare e incollare le seguenti righe di comando nella finestra Blocco note (o digitare):
    net stop wuauserv
    CD %systemroot%\SoftwareDistribution
    ren scaricare download. old
    net start wuauserv
  4. Dal menu File scegliere Salva con nomee quindi digitare Rename.bat.
  5. Fare clic su Salva come tipoe quindi fare clic su tutti i file (*. *).
  6. Salvare il file Rename.bat sul desktop.
  7. Il file Rename.bat e quindi fare clic su Esegui come amministratore.
    Riduci l'immagineEspandi l'immagine
    Autorizzazione di controllo dell'Account utente
    Se viene richiesta una password di amministratore o di confermare, digitare la password o fare clic su Continua. Consente di rinominare la cartella di Download.
  8. Provare a installare nuovamente gli aggiornamenti.
  9. Se il problema viene risolto, eliminare il file Rename.bat creato nei passaggi precedenti.
Se il problema persiste, passare al metodo 2.

Nota. Una volta completata, è possibile scaricare e installare gli aggiornamenti, è possibile eliminare la cartella di download. old per recuperare spazio su disco.

Metodo 2: rinominare la cartella SoftwareDistribution di Windows Update

Per rinominare la cartella SoftwareDistribution temporanea di Windows Update, attenersi alla procedura appropriata per il sistema operativo.

Importante Quando si esegue il metodo 2, sono interessate le operazioni seguenti:
  • Devono essere scaricati nuovamente gli aggiornamenti già scaricati, ma che non è stato ancora installato da Windows Update o Microsoft Update.
  • Eliminando la cartella SoftwareDistribution, si rimuoverà la cronologia di download.
Se attualmente possibile ricevere gli aggiornamenti da Microsoft Update e da Windows Update, sarà necessario selezionare nuovamente questa opzione da Windows Update. A tale scopo, attenersi alla seguente procedura:
  1. Visitare il seguente sito Web Windows Update:
    http://www.Update.microsoft.com/windowsupdate (http://www.update.microsoft.com/windowsupdate)
  2. Nella schermata iniziale di Windows Update , accanto a Ottenere oggi di Microsoft Update, fare clic su Vai.
  3. Seguire sullo schermo le istruzioni per configurare Microsoft Update per eseguire sul computer.
In Windows XP, in Windows Server 2003 e in Windows 2000, attenersi alla seguente procedura:
  1. Avviare Blocco note. A tale scopo, fare clic su Starte quindi fare clic su Esegui.
  2. Immettere il seguente comando nella casella Apri , quindi premere di copia e Incolla (o tipo):
    Blocco note
  3. Copiare e incollare le seguenti righe di comando nella finestra Blocco note (o digitare).
    net stop wuauserv
    CD % systemroot %
    ren SoftwareDistribution SoftwareDistribution. old
    net start wuauserv
  4. Dal menu File scegliere Salva con nomee quindi digitare Rename.bat.
  5. Fare clic su Salva come tipoe quindi fare clic su Tutti i file.
  6. Salvare il file Rename.bat sul desktop.
  7. Fare doppio clic sul file Rename.bat per rinominare la cartella SoftwareDistribution.
  8. Provare a installare nuovamente gli aggiornamenti.
  9. Se il problema viene risolto, eliminare il file Rename.bat creato nei passaggi precedenti.
Nota. Una volta completata, è possibile scaricare e installare gli aggiornamenti, è possibile eliminare la cartella SoftwareDistribution. old per recuperare spazio su disco.

In Windows Vista e in Windows Server 2008, attenersi alla seguente procedura:
  1. Fare clic su Start
    Riduci l'immagineEspandi l'immagine
     Pulsante Start
    , quindi digitare Blocco note Nella casella Inizia ricerca .
  2. Nell'elenco programmi , fare clic su blocco note.
  3. Copiare e incollare quindi i comandi seguenti nella finestra Blocco note (o digitare).
    net stop wuauserv
    CD % systemroot %
    ren SoftwareDistribution SoftwareDistribution. old
    net start wuauserv
  4. Dal menu File scegliere Salva con nomee quindi digitare Rename.bat.
  5. Fare clic su Salva come tipoe quindi fare clic su tutti i file (*. *).
  6. Salvare il file Rename.bat sul desktop.
  7. Il file Rename.bat e quindi fare clic su Esegui come amministratore.
    Riduci l'immagineEspandi l'immagine
    Autorizzazione di controllo dell'Account utente
    Se viene richiesta una password di amministratore o di confermare, digitare la password o fare clic su Continua. Consente di rinominare la cartella SoftwareDistribution.
  8. Provare a installare nuovamente gli aggiornamenti.
  9. Se il problema viene risolto, eliminare il file Rename.bat creato nei passaggi precedenti.
Nota. Una volta completata, è possibile scaricare e installare gli aggiornamenti, è possibile eliminare la cartella SoftwareDistribution. old per recuperare spazio su disco.

Le informazioni in questo articolo si applicano a:
  • Microsoft Update
  • Microsoft Windows Update
Chiavi: 
kbupdateissue kbexpertisebeginner kbtshoot kberrmsg kbprb kbmt KB958046 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 958046  (http://support.microsoft.com/kb/958046/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store