DetailPage-MSS-KB

Microsoft Knowledge Base

Identificativo articolo: 972999 - Ultima modifica: giovedì 6 agosto 2009 - Revisione: 1.0

Hotfix disponibile per il download
Visualizza e richiedi i download dell'hotfix
 
 

In questa pagina

Sintomi

In un computer che esegue Windows Vista o Windows Server 2008, non è possibile utilizzare Visualizzatore eventi per aprire un log eventi. Inoltre, viene visualizzato un messaggio di errore analogo al seguente:
Visualizzatore eventi: Impossibile aprire il registro eventi o visualizzazione personalizzata. Verificare che il servizio Registro eventi è in esecuzione o query è troppo lungo. Dati non validi (13).
Quando si verifica questo problema, se si esegue un'applicazione di clienti che utilizza il registro eventi di Windows application programming interface (API) per leggere il contenuto dei file di registro evento (evtx), l'applicazione non riesce e viene visualizzato il messaggio di errore ERROR_INVALID_DATA.

Nota Per impostazione predefinita, i file evtx si trovano nella directory seguente:
%SystemRoot%\System32\Winevt\Logs

Cause

Questo problema si verifica quando un file evtx è danneggiato. In un file evtx è presente una tabella di stringa contenente le stringhe di eventi in modo che stringhe duplicate possono essere salvate solo una volta. Altre stringhe di fare riferimento le stringhe archiviate nella tabella utilizzando l'indice della tabella. Nella tabella vengono aggiunti ogni volta che viene generato un nuovo evento, nuove stringhe. In alcuni casi, è Impossibile scrivere un evento nel file di log eventi. Tuttavia, la parte della stringa di tabella già viene aggiornato. In questo caso, il file di evtx è danneggiato.

Risoluzione

È un aggiornamento rapido per evitare questo problema. Dopo avere applicato questo aggiornamento rapido (hotfix), l'aggiornamento per la tabella di stringhe verrà eseguire il rollback se l'evento non viene scritto il file evtx. In questo modo, il file di evtx non è danneggiato. Tuttavia, questo aggiornamento rapido (hotfix) non può recuperare un file evtx danneggiato.

Se si installa questo aggiornamento rapido (hotfix) in un computer che dispone di un file evtx danneggiato, è necessario deselezionare e backup il log danneggiato utilizzando il comando Wevtutil . Ad esempio, per cancellare e backup del log nel file System.evtx, eseguire il comando seguente:
wevtutil cl sistema /bu: C:\system.evtx

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Per applicare questo aggiornamento rapido (hotfix), il computer necessario eseguire uno dei sistemi operativi seguenti:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Necessità di riavvio

È necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni del Registro di sistema

Non si dispone di apportare qualsiasi modifica al Registro di sistema.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.

Nota le informazioni file di Windows Vista

File MANIFEST (con estensione manifest) e MUM (con estensione mum) installati per ogni ambiente sono listed separately. MUM e MANIFEST dei file e i file di catalogo (CAT) di protezione associato, sono importanti per mantenere lo stato del componente aggiornato. I file di catalogo di protezione (attributi non in elenco) sono firmati mediante firma digitale Microsoft.
Per tutte le versioni di Windows Vista e Windows Server 2008 su-86 x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Wevtsvc.dll6.0.6000.21074990,20830-06-200912: 27x 86
Wevtsvc.dll6.0.6001.224591,014,78430-06-200912: 28x 86
Wevtsvc.dll6.0.6002.221601,017,85630-06-200912: 16x 86
Per tutte le versioni di Windows Vista e Windows Server 2008 su-64 x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Wevtsvc.dll6.0.6000.210741,450,49630-06-200913: 00x 64
Wevtsvc.dll6.0.6001.224591,490,94430-06-200912: 34x 64
Wevtsvc.dll6.0.6002.221601,491,96830-06-200912: 16x 64
Per tutte le versioni basate su Itanium di Windows Server 2008
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Wevtsvc.dll6.0.6001.224592,698,75230-06-200912: 26IA-64
Wevtsvc.dll6.0.6002.221602,702,33630-06-200912: 07IA-64

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sul servizio Registro eventi di Windows, visitare il sito di Web di Microsoft:
http://technet.microsoft.com/en-us/library/cc775047(WS.10).aspx (http://technet.microsoft.com/en-us/library/cc775047(WS.10).aspx)
Per ulteriori informazioni sugli eventi di Windows, visitare il sito di Web di Microsoft:
http://msdn.microsoft.com/en-us/library/aa964766(VS.85).aspx (http://msdn.microsoft.com/en-us/library/aa964766(VS.85).aspx)
Per ulteriori informazioni su come utilizzare il comando Wevtutil , visitare il sito di Web di Microsoft:
http://technet.microsoft.com/en-us/library/cc732848(WS.10).aspx (http://technet.microsoft.com/en-us/library/cc732848(WS.10).aspx)
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684   (http://support.microsoft.com/kb/824684/ ) Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Le informazioni in questo articolo si applicano a:
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Chiavi: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB972999 KbMtit
Traduzione automatica articoliTraduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell’articolo: 972999  (http://support.microsoft.com/kb/972999/en-us/ )
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Condividi
Altre opzioni per il supporto
Forum del supporto di Microsoft Community
Contattaci direttamente
Ricerca di un partner certificato Microsoft
Microsoft Store