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Identificativo articolo: 978900 - Ultima modifica: mercoledì 10 marzo 2010 - Revisione: 1.0

 

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Sommario

Quando si installa un agente di protezione Microsoft System Center Data Protection Manager 2007 su un server di destinazione, è possibile che venga visualizzato un errore dell'agente riuscita. (ID: 370) seguita da un altro errore ID. In questo articolo viene descritto come risolvere i problemi relativi agli errori di installazione dell'agente in base al secondo id di errore viene visualizzato.

Sintomi

Quando si installa l'agente di protezione di Microsoft System Center Data Protection Manager (DPM) 2007 su un server di destinazione, è possibile che venga visualizzato il seguente messaggio di errore:
ID: 370
Agente non riuscita.
Quindi, viene visualizzato uno dei seguenti ID errore:
  • ID errore: 7:
    Impossibile connettersi al database di servizi di dominio Active Directory. Assicurarsi che il server DPM è un membro di un dominio e che un controller di dominio è in esecuzione. Verificare inoltre che vi sia connettività di rete tra il server DPM e il controller di dominio
    ID: 7
    Dettagli: L'attributo specificato per il servizio directory o un valore non esiste (0x8007200A)
  • ID errore: 277:
    Non è in grado di connettersi a Gestione controllo servizi su FQDN_Server_Name. (ID: 277)

    1) Tale FQDN_Server_Name assicurarsi che sia in linea e disponibile in modalità remota dal server DPM.
    2) Se un firewall è attivato in FQDN_Server_Name, assicurarsi che non stia bloccando richieste dal server DPM.
  • ID errore: 302:
    L'operazione dell'agente protezione dati non riuscita perché non è in grado di accedere l'agente protezione dati sul server % FQDN_of_Production_Server %. Il server % FQDN_of_Production_Server % potrebbe essere in esecuzione DPM o l'agente protezione dati Data Protection Manager potrebbe essere stato installato da un altro computer DPM. (ID: 302)
  • ID errore: 313: DPM 2007 possono distribuire gli agenti ai server membri in un dominio Windows Server 2003. Tuttavia, non è possibile distribuire un agente per qualsiasi altro controller di dominio. Installazione raggiunge il 90 % e si verifica un errore con questo errore:
    Installare agente protezione dati su computername non riuscita. Errore 313: L'operazione dell'agente non riuscita perché si è verificato un errore durante l'esecuzione del programma di installazione su computername. Dettagli errore: errore irreversibile durante l'installazione di [0 x 80070643].
  • ID errore: 326:
    L'operazione dell'agente protezione dati non riuscita perché è stato negato l'accesso al server DPM Servername. (ID: 326)
  • ID errore: 337:
    ID errore Data Protection Manager: 337

    Non è possibile installare l'agente protezione dati su targetserver perché è stato negato l'accesso al computer.

Cause

Questi errori si verificano per i seguenti motivi:
  • ID errore: 7: questo errore si verifica quando il server di destinazione si trova in un'altra unità organizzativa in Active Directory e gli utenti autenticati non hanno accesso in lettura a questa unità organizzativa. Di conseguenza, l'account del servizio Data Protection Manager non è possibile trovare il server in Active Directory.
  • ID errore: 277: questo errore si verifica quando l'accesso di rete DTC è disattivato.
  • ID errore: 302 e ID errore: 337: questi errori si verificano quando il nome principale servizio (SPN) per il server non sono coerenti in Active Directory. L'installazione dell'agente può utilizzare informazioni non corrette per completare l'installazione e la connessione. Questo problema può causare numerosi problemi.
  • ID errore: 313: questo errore si verifica quando l'installazione guidata dell'agente DPM non dispone di autorizzazioni sufficienti per la scrittura dei file in una directory o di una sottochiave del Registro di sistema. È inoltre possibile che venga visualizzato questo errore durante un'installazione agente DPM non riuscita su questo o altri controller di dominio all'interno del dominio.
  • ID errore: 326: questo errore si verifica quando viene visualizzata una finestra di dialogo nel server di destinazione in cui si sta installando un agente DPM. Questa finestra di dialogo solo è visibile dalla console del server. Questa finestra di dialogo richiede interazione manuale per riconoscere e chiudere la finestra di dialogo. Questa finestra di dialogo solo è visibile dalla console del server. Finché non viene chiusa la finestra di dialogo, non è possibile distribuire l'agente DPM a questo server.

Risoluzione

Per risolvere il problema, utilizzare la risoluzione per l'ID di errore specifico che viene visualizzato.

Risoluzione per ID errore: 7

Per risolvere questo errore, modificare il gruppo Authenticated Users in modo che ha letto autorizzazioni per l'unità organizzativa server di destinazione è un membro di. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Sul controller di dominio, aprire MMC di Active Directory Users and Computers.
  2. Fare clic con il pulsante destro del mouse sull'unità organizzativa che contiene il server di destinazione e quindi scegliere proprietà.
  3. Nella scheda protezione aggiungere il gruppo Authenticated Users e assegnare loro autorizzazioni di lettura.
  4. Ridistribuire l'agente protezione dati DPM sul server protetto.

Risoluzione per ID errore: 277

Per risolvere il problema, attenersi alla procedura descritta nell'articolo della Microsoft Knowledge Base 817064 e ridistribuire l'agente DPM per entrambi i nodi del cluster.
817064  (http://support.microsoft.com/kb/817064/ ) Come attivare l'accesso DTC alla rete in Windows Server 2003

Risoluzione per ID errore: 302 e ID errore: 337

Per risolvere il problema, eseguire lo strumento SetSPN e nomi principali di servizio per il server non è in grado di push l'agente di controllo.

NotaPer ulteriori informazioni su come ottenere la versione più recente dello strumento SetSPN, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
970536  (http://support.microsoft.com/kb/970536/ ) Aggiornamento per lo strumento Setspn.exe supporto per Windows Server 2003
  1. Accedere come amministratore di dominio.
  2. Al prompt dei comandi, digitare il comando seguente, quindi premere INVIO:
    setspn -L Servername
    Nota In questo comando, il segnaposto Servername rappresenta il server di destinazione non è possibile distribuire l'agente di DPM.

    L'output risultante dovrebbe essere analogo al seguente:
    ~~~~~~~~~~~~~~~~~~~~~~~~~
    Registered ServicePrincipalNames for CN=TARGETSERVER,OU=Member 
    Servers,DC=<Servername>,DC=com:
    SMTPSVC/targetserver.<Servername>
    NtFrs-88f5d2bd-b646-11d2-a6d3-00c04fc9b232/targetserver.<Servername>
    HOST/targetserver.www.<Incorrect_Servername>/Incorrect_Servername
    HOST/targetserver.www.<Incorrect_Servername>
    exchangeMDB/targetserver.www.<Incorrect_Servername>
    SMTPSVC/targetserver.www.<Incorrect_Servername>
    HOST/targetserver.www.<Incorrect_Servername> /www.<Incorrect_Servername>
    exchangeRFR/targetserver.www.<Incorrect_Servername>
    exchangeRFR/targetserver.<Servername>
    exchangeMDB/targetserver.<Servername>
    exchangeRFR/TARGETSERVER
    exchangeMDB/TARGETSERVER
    SMTPSVC/TARGETSERVER
    HOST/TARGETSERVER
    ~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    Si noti che tutti i "HOST /" SPN voci elencate nell'output di indicano che il server primario DNS è impostato su Incorrect_Servername, Servername. Quando l'agente viene distribuito, il server DPM è la risoluzione del nome TARGETSERVER. SERVERNAME e questo è ciò che viene utilizzato per creare il SPN viene richiesto al momento dell'agente di distribuzione. Tuttavia, poiché il SPN registrato per targetserver per www. Incorrect_Servername, il tentativo di connessione Kerberos non riesce e tenta di stabilire una connessione anonima. È possibile che i risultati in un evento che ID 6033 registrato nel server di Exchange.
  3. Verificare che non esistano SPN non duplicati del server di destinazione. Al prompt dei comandi, digitare il comando seguente, quindi premere INVIO:
    setspn -X
    Esaminare l'output di eventuali duplicati di SPN desiderato per il server di destinazione.
  4. Per assicurarsi che l'host SPN sono registrati correttamente, digitare i comandi riportati di seguito al prompt dei comandi. Premere INVIO dopo ciascun comando.
    setspn - a HOST / targetserver. Servername targetserver
    Setspn - a HOST/targetserver targetserver
  5. Replicare le modifiche in tutto Active Directory.
  6. Ridistribuire l'agente protezione dati DPM per i server interessati.
Per ulteriori informazioni sull'utilità SetSPN, visitare il seguente sito Microsoft TechNet Web:
Setspn Overview (http://technet.microsoft.com/en-us/library/cc773257(WS.10).aspx)

Risoluzione per ID errore: 313

Per risolvere il problema, utilizzare uno dei metodi descritti di seguito.

Metodo 1

Per risolvere il problema di autorizzazioni, esaminare il file di registro dell'installazione Msdpm che si trova sul computer client nella seguente cartella:
%windir%\temp\msdpm*.log
Determinare la sottochiave del Registro di sistema o cartella non può essere utilizzato e forniscono quindi Administrators del computer client dell'autorizzazione di scrittura a tali gruppi.

Metodo 2

Se si è verificato un precedente tentativo non riuscito per installare l'agente al controller di dominio o a un altro controller di dominio, verificare ed eliminare le voci nel contenitore utenti dello strumento Active Directory Users and Computers analoghi ai seguenti:
  • DPMRADCOMTrustedMachinesCNF:28f84c90 - fa10 - 4ff7 7d945440e08b - b4fa -
  • DPMRADmTrustedMachinesCNF:28f84c90 - fa10 - 4ff7 7d945440e08b - b4fa -
Quanto sono duplicati dei gruppi DPMRADCOMTrustedMachines e DPMRADmTrustedMachines, è possibile eliminare queste voci. È possibile identificare con facilità mediante il CNF: testo del GUID che viene aggiunto a ogni voce. Dopo aver eliminato queste voci, eseguire repadmin.exe per forzare la replica delle modifiche apportate ad Active Directory per gli altri controller di dominio oppure è possibile concedere tempo sufficiente Active Directory replichino le modifiche ai controller di dominio.

Risoluzione per ID errore: 326

Per risolvere il problema, accedere a una sessione della console sul server di destinazione e quindi manualmente confermare la finestra di dialogo dopo tentativi per installare l'agente DPM.

Le informazioni in questo articolo si applicano a:
  • Microsoft System Center Data Protection Manager 2007
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Clicca qui per visualizzare la versione originale in inglese dell’articolo: 978900  (http://support.microsoft.com/kb/978900/en-us/ )
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