DetailPage-MSS-KB

기술 자료

기술 자료: 164486 - 마지막 검토: 2006년 11월 1일 수요일 - 수정: 1.2

 
중요: 이 문서에는 레지스트리 편집에 대한 정보가 들어 있습니다. 레지스트리를 편집하기 전에 문제가 발생할 경우 복원 방법을 알고 있어야 합니다. 이렇게 하는 방법에 대한 자세한 내용은 "레지스트리 복원" 도움말 항목을 볼 Regedit.exe 또는 "레지스트리 키 복원" 도움말 항목을 참조하십시오.

현상

서드 파티 회사의 다음 레지스트리 키를 편집하여 Windows NT에 제공되는 Gina.dll 파일을 바꿀 수 있습니다.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon Value = GinaDLL REG_SZ

참조된 파일이 없거나 손상된 레지스트리., Winlogon 시작하려면 실패하고 파란 화면에 오류 메시지가 발생합니다.

참고: 타사 Gina.dll 파일을 찾을 수 없는 경우 Windows NT 3.51 Msgina.dll을 로드합니다.

원인

Windows NT 4.0 Gina.dll 또는 해당 대체 없으면 로드하지 않도록 설계되었습니다.

해결 방법

이 문제를 해결하려면 Windows NT에 포함되어 있는 버전이 없거나 손상된 Gina.dll을 대체하십시오.

경고: 레지스트리 편집기를 잘못 사용하여 운영 체제를 다시 설치해야 하는 심각한 문제가 발생할 수 있습니다. Microsoft는 레지스트리 편집기를 잘못 사용하여 발생하는 문제를 해결할 수 있음을 보증하지 않습니다. 레지스트리 편집기를 따른 위험 부담은 사용자의 책임입니다.

레지스트리를 편집하는 방법에 대한 자세한 내용은 "키와 값 변경" 도움말 항목을 볼 레지스트리 편집기 (Regedit.exe) 또는 "레지스트리 정보 추가 및 삭제" 및 "레지스트리 데이터 편집" 도움말 항목을 참조하십시오. 편집하기 전에 레지스트리를 백업해야 합니다 유의하십시오.

Windows NT FAT 파티션에 설치된 경우 %SystemRoot%\System32\Config 디렉터리에 플로피 디스크 및 Windows NT를 실행하는 다른 컴퓨터로 가져올 지시에 따라 이러한 소프트웨어 파일을 복사:
  1. 레지스트리 편집기 (Regedt32.exe)를 시작하십시오.
  2. HKEY_LOCAL_MACHINE 창으로 이동하십시오.
  3. HKEY_LOCAL_MACHINE 키 항목을 선택하십시오.
  4. 레지스트리 메뉴에서 하이브 읽어들이기를 누릅니다.
  5. 찾아보기 및 실패한 Windows NT 설치 경로를, 예를 들어, Winnt 선택하십시오.
  6. System32\Config 디렉터리로 이동하여 소프트웨어 파일을 선택하십시오.

    참고: 소프트웨어 확장명이 없는 정확한 파일입니다.
  7. 확인을 누른 테스트의 키 이름을 입력하십시오.
  8. 새 테스트 키를 두 번 클릭하고 이 경로를 따릅니다.
    Microsoft\Windows NT\Current Version\Winlogon
  9. Ginadll:REG_SZ:MSGINA.DLL 항목 수정
  10. 레지스트리 메뉴에서 하이브 언로드를 누릅니다.
  11. 원래 Windows NT 설치 프로그램으로 다시 시작하십시오.

추가 정보

해당 버전의 Gina.dll 테스트하려면 다른 회사 FAT 볼륨을 사용하는 것이 좋습니다. 새 Gina.dll 파일의 대체를 용이하게 합니다.

본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
키워드: 
kbmt kbprb KB164486 KbMtko
기계 번역된 문서기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.
공유
추가 지원 옵션
Microsoft Community 지원 포럼
직접 문의하기
Microsoft Certified Partner 찾기
Microsoft Store