DetailPage-MSS-KB

기술 자료

기술 자료: 266668 - 마지막 검토: 2011년 5월 13일 금요일 - 수정: 4.0

현상

프로그램을 설치 및 제거할 때 제어판의 프로그램 추가/제거 도구가 설치된 프로그램을 잘못 표시할 수 있습니다. 현재 설치된 프로그램 상자에 단일 텍스트 문자열만 나와 있거나 프로그램 항목 앞에 길이가 긴 빈 공백만 표시될 수 있습니다. 아무런 프로그램도 나열되지 않는 경우도 있을 수 있습니다. 또한 다음 오류 메시지 중 하나가 나타날 수 있습니다.

메시지 1
예기치 않은 오류가 발생했습니다. 클래스가 등록되지 않았습니다.
res://appwiz.cpl/listbox.htc
줄: 225
메시지 2
개체가 이 속성 또는 메서드를 지원하지 않습니다. res://appwiz.cpl/default.hta
줄: 75

원인

이 문제는 프로그램의 설치 제거 관리자가 Windows와 프로그램 추가/제거 도구에서 사용하는 레지스트리 항목을 잘못 제거한 경우에 발생할 수 있습니다.

해결 방법

중요 이 절, 방법 또는 작업에는 레지스트리를 수정하는 방법에 대한 단계가 포함되어 있습니다. 그러나 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수도 있으므로 다음 단계를 주의하여 수행해야 합니다. 추가 보호 조치로 레지스트리를 수정하기 전에 해당 레지스트리를 백업하는 것이 좋습니다. 이렇게 하면 문제가 발생하는 경우 레지스트리를 복원할 수 있습니다. 레지스트리 백업 및 복원 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
322756  (http://support.microsoft.com/kb/322756/ko/ ) Windows에서 레지스트리를 백업 및 복원하는 방법


Microsoft에서 사용자를 위해 이 문제점을 해결할 수 있도록 하려면 "해결 지원" 절로 이동하십시오. 이 문제를 직접 해결하려면 "직접 해결" 절로 이동하십시오.

해결 지원



이 문제를 자동으로 해결하려면 Fix it 단추나 링크를 클릭합니다. 그런 다음 파일 다운로드 대화 상자에서 실행을 클릭하고 Fix it 마법사의 단계를 따릅니다.


문제 자동 해결
Microsoft Fix it 50542

참고
  • 프로그램 추가/제거 도구가 Fix it 솔루션을 실행한 후에도 제대로 작동되지 않으면 전체 업그레이드를 수행하십시오. 전체 업그레이드 수행 방법에 대한 자세한 내용은 "추가 정보" 절을 참조하십시오.
  • 이 마법사는 영어로만 제공될 수 있습니다. 그러나 다른 언어 버전의 Windows에서도 자동 해결 기능을 사용할 수 있습니다.
  • 현재 문제가 있는 컴퓨터에서 작업하고 있지 않은 경우 Fix it 솔루션을 플래시 드라이브 또는 CD에 저장한 후 문제가 있는 컴퓨터에서 실행하십시오.

그런 다음 "문제가 해결되었습니까?" 절로 이동하십시오.



직접 해결

이 문제를 해결하려면 다음과 같이 하십시오.
  1. 시작, 실행을 차례로 클릭한 다음 CMD를 입력합니다.
  2. 명령 프롬프트에서 REGSVR32 APPWIZ.CPL을 입력합니다.
  3. 이 명령이 실패하면 아래에 나와 있는 레지스트리 항목을 찾습니다. 이 문제를 해결하려면 레지스트리에서 다음 키와 값이 있는지 확인합니다. 없는 키나 값은 다시 만듭니다. 이들 키에서는 시스템 드라이브 문자를 사용하므로 해당 컴퓨터의 구성과 일치하도록 항목을 조정해야 할 수도 있습니다.
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}]
      "ADODB.Recordset"
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32]
      "C:\Program Files\Common Files\System\ado\msado15.dll"
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32]
      "ThreadingModel"="Apartment"
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\ProgID] "ADODB.Recordset.2.5"
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\VersionIndependentProgID]
      "ADODB.Recordset"
    • HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}
      "Microsoft OLE DB Row Position Library"
    • HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\InprocServer32
      "C:\Program Files\Common Files\System\Ole DB\oledb32.dll" "ThreadingModel"="Both"
    • HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\ProgID
      "RowPosition.RowPosition.1"
    • HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\VersionIndependentProgID
      "RowPosition.RowPosition"
    • [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32]
      "%SystemRoot%\System32\appwiz.cpl"
  4. 컴퓨터에 적용할 때 아래의 절차 중 하나에 나와 있는 단계를 수행한 다음 이 문제가 해결되었는지 테스트합니다. 문제가 해결되었으면 나머지 단계는 건너뜁니다. 문제가 해결되지 않았으면 5단계로 진행합니다.
    • Internet Explorer 6.0에서 이 문제를 해결하려면 다음과 같이 Internet Explorer 6.0을 복구합니다.
      1. 시작을 클릭한 다음 실행을 클릭합니다.
      2. 열기 상자에 아래의 명령을 붙여 넣은 다음 확인을 클릭합니다.
        rundll32 setupwbv.dll,IE6Maintenance "C:\Program Files\Internet Explorer\Setup\SETUP.EXE" /g "C:\WINDOWS\IE Uninstall Log.Txt
        이 명령은 대소문자를 구분하므로 이 문서의 명령을 복사한 다음 열기 상자에 붙여 넣는 것이 좋습니다.
    • Internet Explorer 5.0이나 5.5에서 이 문제를 해결하려면 다음과 같이 Internet Explorer 5.0이나 5.5를 복구합니다.
      1. 시작을 클릭한 다음 실행을 클릭합니다.
      2. 열기 상자에 아래의 명령을 붙여 넣은 다음 확인을 클릭합니다.
        rundll32 setupwbv.dll,IE5Maintenance "C:\Program Files\Internet Explorer\Setup\SETUP.EXE" /g "C:\WINDOWS\IE Uninstall Log.Txt
        이 명령은 대소문자를 구분하므로 이 문서의 명령을 복사한 다음 열기 상자에 붙여 넣는 것이 좋습니다.
  5. 다음과 같이 전체 업그레이드를 수행합니다.

    참고 전체 업그레이드를 수행하기 전에 데이터를 백업해야 합니다. 전체 업그레이드를 수행하는 경우의 위험에 대한 자세한 내용은 "추가 정보" 절을 참조하십시오.
    1. Windows 2000 설치 CD-ROM의 \I386 디렉터리에서 Winnt32.exe를 실행합니다.
    2. Windows 2000 설치 화면이 나타나면 Windows 2000으로 업그레이드를 클릭합니다.
    3. 설치를 완료합니다.
프로그램 추가/제거 도구가 계속 제대로 작동하지 않으면서 아무런 내용도 표시하지 않는 경우나 이후 버전의 Internet Explorer로 업그레이드하지 않고 이 문제를 수정하려는 경우 다음 레지스트리 키를 검사하여 항목이 포함되어 있는지 확인합니다.
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Management\ARPCache
참고 앞에서 설명한 레지스트리 키가 비어 있으면 프로그램 추가/제거 도구에도 아무런 내용이 표시되지 않을 수 있습니다.

명령줄 REGSVR32 [path\filename]을 사용하여 다음 파일을 각각 등록합니다.
%systemroot%\System32\Appwiz.cpl
%systemroot%\System32\Mshtml.dll
%systemroot%\System32\Jscript.dll
%systemroot%\System32\Msi.dll
Program Files\Common Files\System\Ole DB\Oledb32.dll
Program Files\Common Files\System\Ado\Msado15.dll
%systemroot%\System32\Msdart32.dll [등록 불가능]
%systemroot%\System32\Mshtmled.dll
%systemroot%\System32\Mswstr10.dll [등록 불가능]
프로그램 추가/제거 도구가 불완전한 정보를 표시하거나 빈 상태로 표시되면 파일 날짜를 확인하십시오. 가능한 경우 다음 파일을 등록하십시오.
%systemroot%\System32\Gdi32.dll [등록 불가능]
%systemroot%\System32\User32.dll [등록 불가능]
%systemroot%\System32\Msvcrt.dll [등록 불가능]
%systemroot%\System32\Ole32.dll
%systemroot%\System32\Shlwapi.dll [등록 불가능]
%systemroot%\System32\Imm32.dll [등록 불가능]
%systemroot%\System32\Indicdll.dll [등록 불가능]
%systemroot%\System32\Urlmon.dll
%systemroot%\System32\Version.dll [등록 불가능]
%systemroot%\System32\Lz32.dll [등록 불가능]
%systemroot%\System32\Comctl32.dll [등록 불가능]
%systemroot%\System32\Clbcatq.dll
%systemroot%\System32\Oleaut32.dll
%systemroot%\System32\Mlang.dll
%systemroot%\System32\Shell32.dll
%systemroot%\System32\Shdoclc.dll [등록 불가능]
%systemroot%\System32\NetapI32.dll [등록 불가능]
%systemroot%\System32\Secur32.dll [등록 불가능]
%systemroot%\System32\Netrap.dll [등록 불가능]
%systemroot%\System32\Samlib.dll [등록 불가능]
%systemroot%\System32\Ws2_32.dll [등록 불가능]
%systemroot%\System32\Ws2help.dll [등록 불가능]
%systemroot%\System32\Wldap32.dll [등록 불가능]
%systemroot%\System32\Dnsapi.dll [등록 불가능]
%systemroot%\System32\Wsock32.dll [등록 불가능]
%systemroot%\System32\Plugin.ocx
%systemroot%\System32\Wininet.dll [등록 불가능]
%systemroot%\System32\Crypt32.dll [등록 불가능]
%systemroot%\System32\Msasn1.dll [등록 불가능]
%systemroot%\System32\Msls31.dll [등록 불가능]
%systemroot%\System32\Imgutil.dll
%systemroot%\System32\Cscui.dll
%systemroot%\System32\Cscdll.dll [등록 불가능]
프로그램 추가/제거 도구가 대화 상자 사용자 인터페이스를 그릴 수 있지만 설치되어 있는 프로그램 관련 내용을 표시하지 않을 경우 레지스트리에서 다음 키가 있는지 확인하십시오.
HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32
이 레지스트리 키가 없으면 텍스트 파일에 다음 텍스트를 복사하고 파일을 .reg 확장명으로 저장한 다음 영향을 받는 컴퓨터에서 해당 파일을 두 번 클릭하여 적절한 항목을 반환하십시오.

Windows 레지스트리 편집기 버전 5.00의 경우:
[HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,61,00,70,00,70,00,77,00,69,00,7a,00,2e,00,63,00,70,00,6c,00,00,00
"ThreadingModel"="Apartment"

현재 상태

Microsoft는 이 문제가 "적용 대상" 절에 나열된, Microsoft 제품에서 발생하는 문제임을 확인했습니다. 아래의 목록에는 프로그램 추가/제거에서 사용하는 레지스트리 키가 모두 나와 있습니다. 이들 키는 Appwiz.cpl을 등록하여 설정해야 하지만 여기에서는 성공적으로 등록되었는지 확인하기 위한 상호 참조용으로 제공됩니다.
  • [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}]
    @="%DESC_ShellAppMgr%"
  • [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32]
    @="SystemRoot%\System32\appwiz.cpl" (REG_EXPAND_SZ)
    "ThreadingModel"="Apartment"
  • [HKEY_CLASSES_ROOT\CLSID\{0B124F8C-91F0-11D1-B8B5-006008059382}]
    @="Installed Apps Enumerator"
  • [HKEY_CLASSES_ROOT\CLSID\{0B124F8F-91F0-11D1-B8B5-006008059382}\InProcServer32]
    @="SystemRoot%\System32\appwiz.cpl" (REG_EXPAND_SZ)
    "ThreadingModel"="Apartment"

    참고 이 키는 Microsoft Windows XP에서만 사용할 수 있습니다.
  • [HKEY_CLASSES_ROOT\CLSID\{CFCCC7A0-A282-11D1-9082-006008059382}]
    @="Darwin App Publisher"
  • [HKEY_CLASSES_ROOT\CLSID\{CFCCC7A0-A282-11D1-9082-006008059382}\InProcServer32]
    @="SystemRoot%\System32\appwiz.cpl" (REG_EXPAND_SZ)
    "ThreadingModel"="Apartment"
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
    "{352EC2B7-8B9A-11D1-B8AE-006008059382}"="Shell Application Manager"
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
    "{0B124F8F-91F0-11D1-B8B5-006008059382}"="Installed Apps Enumerator"

    참고 이 키는 Microsoft Windows XP에서만 사용할 수 있습니다.
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\App Management\Publishers\Darwin App Publisher]
    @="{CFCCC7A0-A282-11D1-9082-006008059382}"
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
    "{CFCCC7A0-A282-11D1-9082-006008059382}"="Darwin App Publisher"
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\InProcCPLs]
    "appwiz.cpl"=""

    ARP가 실행될 때 사용되는 레지스트리 항목

  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppInstallPath
    INF 파일을 읽습니다. 코드에서 INF 파일 이름을 읽습니다. 사용되는 INF 구역은 "AppInstallList"입니다.
  • HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer\Terminal Server\EnableAdminRemote
    ARP가 실행 중일 때 1로 설정하고 ARP가 실행 중이라고 TS에 알립니다.
    ARP가 종료되면 0으로 설정합니다.
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Management\Publishers 응용 프로그램 게시자를 열거합니다.
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Wx86\cmdline
    wx86이 설정되었는지 확인하기 위해 읽습니다.
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\NewShortcutHandlers
    "new-link" 처리기 목록을 열거하여 얻습니다. 이러한 처리기는 시작 메뉴, 바탕 화면 및 기타 항목과 같은 기존 항목에 대한 링크를 추가할 수 있는 처리기입니다.
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Shutdown\ForceReboot
    설치 프로그램을 실행한 후 다시 시작해야 하는지 확인하기 위해 읽습니다.
    값이 있는 경우는 must-reboot == true라는 의미입니다.
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\MS-DOSOptions

추가 정보

자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
265829  (http://support.microsoft.com/kb/265829/ko/ ) Windows 2000에 Internet Explorer 5.5 또는 Internet Explorer 6을 설치한 후 프로그램 추가/제거 도구가 작동하지 않을 수 있음
315341  (http://support.microsoft.com/kb/315341/ko/ ) Windows XP에서 전체 업그레이드(다시 설치)를 수행하는 방법
292175  (http://support.microsoft.com/kb/292175/ko/ ) Windows 2000에서 적절한 업그레이드를 수행하는 방법

문제가 해결되었습니까?

  • 문제가 해결되었는지 확인합니다. 문제가 해결되었다면 이 절에서 설명한 작업이 끝난 것이지만 문제가 해결되지 않은 경우에는 기술 지원 서비스에 문의 (http://support.microsoft.com/contactus) 할 수 있습니다.
  • 의견을 보내 주셔서 감사합니다. 의견을 보내거나 이 해결 방법에 대한 문제점을 보고하려면 "Fix it for me (http://blogs.technet.com/fixit4me/) " 블로그에 의견을 남겨 주시거나 전자 메일 (mailto:fixit4me@microsoft.com?Subject=KB) 을 보내 주십시오.

본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
키워드: 
kb3rdparty kbprb kbmsifixme kbfixme KB266668
공유
추가 지원 옵션
Microsoft Community 지원 포럼
직접 문의하기
Microsoft Certified Partner 찾기
Microsoft Store