DetailPage-MSS-KB

기술 자료

기술 자료: 298427 - 마지막 검토: 2006년 8월 14일 월요일 - 수정: 2.1

이 문서는 이전에 다음 ID로 출판되었음: KR298427

현상

Microsoft Windows 98 또는 Microsoft Windows Millennium에서 Windows XP로 컴퓨터를 업그레이드한 후에 이전에 시작 프로세스 중 로드되던 프로그램이 알림 영역(시스템 트레이)에 나타나지 않을 수 있으며 컴퓨터를 시작할 때 자동으로 시작되지 않습니다.

원인

이 문제는 Windows XP가 제거되지 않는 "제대로 작동하는 것으로 알려진 프로그램"을 제외하고 시작 메뉴와 레지스트리의 Run 키에서 모든 프로그램 파일(모든 .lnk 및 .exe 파일)을 제거하기 때문에 발생할 수 있습니다. 설치 프로그램이 완료되고 사용자가 처음 컴퓨터에 로그온한 후에 이러한 문제가 나타날 수 있습니다. 파일과 값은 숨겨진 폴더와 레지스트리 키로 이동됩니다. 그런 다음 Microsoft 시스템 구성 유틸리티(Msconfig.exe)가 시작 탭 정보로 채워집니다.

해결 방법

이 문제를 해결하려면 레지스트리와 시작 폴더의 프로그램에 값을 다시 설치합니다.
  1. 시작, 실행을 차례로 누르고 msconfig를 입력한 다음 확인을 누릅니다.
  2. 시작 탭을 누릅니다.
  3. 시작프로그램 항목 복원 옵션을 누릅니다.
  4. 복원하려는 프로그램을 선택한 다음 확인을 누릅니다.
  5. 컴퓨터를 다시 시작합니다.
참고: 이 옵션은 Windows XP 설치 프로그램에서 시작 프로세스 중 로드되지 않도록 프로그램을 해제하지 않은 경우에는 사용할 수 없습니다.

현재 상태

이것은 의도적으로 설계된 동작입니다.

추가 정보

"설치하는 동안 시작프로그램 항목 제거됨"에 나열된 모든 프로그램을 설정한 경우 다음에 시스템 구성 유틸리티가 시작될 때 시작프로그램 항목 복원 옵션을 사용할 수 없으며 해당 프로그램이 시작 탭으로 마이그레이션됩니다.

참고: 이러한 프로그램은 대부분 Windows XP로 컴퓨터를 시작할 때 문제를 일으킬 수 있습니다. 프로그램을 복원한 후에 Windows XP 시작에 문제가 있을 경우 시스템 구성 유틸리티를 사용하여 시작 탭에서 이러한 프로그램을 해제할 수 있습니다.

프로그램을 복원한 후 Windows로 컴퓨터를 다시 시작할 수 없으면 다음과 같이 하십시오.
  1. 컴퓨터를 다시 시작하고 F8 키를 눌러 Windows 고급 옵션 메뉴를 표시합니다.
  2. 안전 모드를 누릅니다.
  3. Windows XP Home Edition의 경우 관리자로 안전 모드에서 실행하여 화면의 지시에 따라 Windows XP로 컴퓨터를 시작합니다.
  4. 시작, 실행을 차례로 누르고 msconfig를 입력한 다음 확인을 누릅니다.
  5. 시작 탭을 누른 다음 추가한 프로그램의 선택을 취소합니다.
  6. 확인을 누른 다음 화면의 지시에 따라 표준 모드로 다시 시작합니다.
  7. 표준 모드에서 시스템 구성 유틸리티를 시작한 다음 프로그램을 한 번에 하나씩 추가하여 정상적으로 컴퓨터를 다시 시작하는 데 방해가 되는 프로그램을 확인합니다.
시스템 구성 유틸리티에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
281995  (http://support.microsoft.com/kb/281995/ ) Windows Millennium Edition에서 Msconfig 유틸리티를 사용하여 문제를 해결하는 방법
시작프로그램 항목 복원 옵션에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
300886  (http://support.microsoft.com/kb/300886/ ) Windows XP로 업그레이드할 때 사용되는 "시작프로그램 항목 복원" 옵션에 대한 설명




Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹 (http://support.microsoft.com/newsgroups/default.aspx) 에 참여하시기 바랍니다.

본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
키워드: 
kbenv kbprb KB298427
공유
추가 지원 옵션
Microsoft Community 지원 포럼
직접 문의하기
Microsoft Certified Partner 찾기
Microsoft Store