DetailPage-MSS-KB

기술 자료

기술 자료: 321733 - 마지막 검토: 2011년 10월 9일 일요일 - 수정: 12.0

사용 가능한 핫픽스 다운로드
핫픽스 보기 및 다운로드 요청하기
 
중요 이 문서에서는 레지스트리 수정 방법을 설명합니다. 레지스트리를 수정하기 전에 해당 레지스트리를 백업하고 문제가 발생할 경우 이를 복원하는 방법을 알고 있어야 합니다. 레지스트리 백업, 복원 및 편집 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
256986  (http://support.microsoft.com/kb/256986/ ) 고급 사용자를 위한 Windows 레지스트리 정보
알림
"현상" 절에서 설명하는 문제는 Windows의 다른 버전에서 발생할 수 있으며 해당 문제는 다른 Microsoft 기술 자료 문서에 설명되어 있습니다. 유사한 문제를 해결하려면 "유사한 문제 및 해결 방법" 절을 참조하십시오.

이 페이지에서

현상

클라이언트가 네트워크를 통해 서버에 파일을 쓰는 동안 다음과 같은 오류 메시지가 나타날 수 있습니다.
{지연된 쓰기 실패}
파일 x에 대한 모든 데이터를 저장하지 못했습니다.
데이터가 손실되었습니다.
사용자 컴퓨터의 하드웨어 또는 네트워크 연결 오류 때문에 발생했습니다. 이 파일을 다른 곳에 저장해 보십시오.
클라이언트에 이 문서에서 설명하는 문제가 발생하는지 확인하려면 이벤트 로그를 확인하십시오. 이 문제가 발생하는 경우 이벤트 로그에는 원본이 MrxSMB인 이벤트 ID 50이 포함되어 있습니다. 이벤트에는 오류 메시지와 동일한 텍스트가 포함되어 있지만 데이터 구역에 오류 상태도 포함되어 있습니다. 이벤트를 두 번 누른 다음 데이터 형식으로 워드를 누릅니다. 마지막 워드 부분에 상태가 나와 있습니다. 상태 코드가 c0000022(STATUS_ACCESS_DENIED로 해석)인 경우 이 문서에서 설명하는 핫픽스를 적용하십시오.

원인

이 문제는 클라이언트 리디렉터가 SMB 서명을 적절히 계산하지 않기 때문에 발생합니다.

참고 지연된 쓰기 오류 메시지가 나타나는 컴퓨터인 클라이언트 컴퓨터에 패치를 적용하십시오.

해결 방법

Windows 2000

서비스 팩 정보

이 문제를 해결하려면 Microsoft Windows 2000의 최신 서비스 팩을 구하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
260910  (http://support.microsoft.com/kb/260910/ ) 최신 Windows 2000 서비스 팩을 구하는 방법

핫픽스 정보

현재 지원되는 핫픽스를 Microsoft에서 구할 수 있지만 이 문서에서 설명하는 문제를 해결하기 위한 것일 뿐이므로 이러한 특정 문제가 발생하는 시스템에만 이 핫픽스를 적용해야 합니다. 이 핫픽스는 나중에 추가 테스트가 필요할 수도 있습니다. 따라서 이 문제의 영향이 심각하지 않으면 이 핫픽스가 포함된 다음 Windows 2000 Server 서비스 팩이 나올 때까지 기다리는 것이 좋습니다.

이 문제를 즉시 해결하려면 Microsoft 고객기술지원부에 문의하여 이 핫픽스를 구하십시오. Microsoft 고객기술지원부의 전체 전화 번호 목록과 지원 비용에 대한 정보를 보려면 다음 Microsoft 웹 사이트를 방문하십시오.
기술지원 서비스 안내 (http://support.microsoft.com/default.aspx?scid=fh;KO;serviceoverview)
참고 특정 업데이트로 문제를 해결할 수 있다고 Microsoft 기술지원 전문가가 판단할 경우 지원 요청에 따른 일반적 비용이 취소될 수도 있습니다. 해당 업데이트로 해결할 수 없는 추가 질문과 문제에 대해서는 지원 비용이 청구됩니다.

전제 조건

이 핫픽스를 적용하려면 Windows 2000 Server 서비스 팩 1이 설치되어 있어야 합니다.

다시 시작 요구 사항

이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작할 필요가 없습니다.

핫픽스 대체 정보

이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보

이 핫픽스의 영어 버전은 아래와 같거나 그 이상의 파일 특성을 갖습니다. 이 파일의 날짜와 시간은 UTC(Coordinated Universal Time)로 나열되며 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 보려면 제어판날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.
표 축소표 확대
날짜시간버전크기파일 이름
2002-05-0811:105.0.2195.5754371,344Mrxsmb.sys
2002-04-0416:475.0.2195.5535131,984Rdbss.sys

Windows XP

서비스 팩 정보

이 문제를 해결하려면 Windows XP용 최신 서비스 팩을 구하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
322389  (http://support.microsoft.com/kb/322389/ ) 최신 Windows XP 서비스 팩을 구하는 방법

전제 조건

이 핫픽스를 적용하려면 Windows XP 서비스 팩 1이 설치되어 있어야 합니다.

다시 시작 요구 사항

이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작할 필요가 없습니다.

핫픽스 대체 정보

이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보

이 핫픽스의 영어 버전은 아래와 같거나 그 이상의 파일 특성을 갖습니다. 이 파일의 날짜와 시간은 UTC(Coordinated Universal Time)로 나열되며 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 보려면 제어판날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.
표 축소표 확대
날짜시간버전크기파일 이름
2003-03-0614:335.1.2600.1181154,880Rdbss.sys
2003-03-0614:335.1.2600.1181401,792Mrxsmb.sys

해결 과정

경고 레지스트리 편집기를 잘못 사용하면 심각한 문제가 발생할 수 있으며 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 레지스트리 편집기를 잘못 사용하여 발생하는 문제에 대해 해결을 보증하지 않습니다. 레지스트리 편집기 사용에 따른 모든 책임은 사용자에게 있습니다.
이 문제를 해결하려면 서버에서 SMB 서명 기능을 해제하십시오.
  1. 레지스트리 편집기를 시작합니다.
  2. 레지스트리에서 다음 키 아래의 enablesecuritysignature 값을 찾아 누릅니다.
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanmanserver\Parameters
  3. 편집 메뉴에서 수정을 누릅니다.
  4. 값 데이터: 상자에 0을 입력한 다음 확인을 누릅니다.
  5. 레지스트리 편집기를 종료합니다.
  6. 서버 서비스를 중지한 다음 다시 시작하거나 컴퓨터를 다시 시작합니다.

현재 상태

Windows 2000

Microsoft는 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열한 제품에서 이 문제를 확인했습니다. 이 문제는 Microsoft Windows 2000 서비스 팩 4에서 처음 해결되었습니다.

Windows XP

이 문제는 Windows XP 서비스 팩 2에서 처음 해결되었습니다.

추가 정보

Windows 2000 Datacenter Server용 핫픽스를 구하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
265173  (http://support.microsoft.com/kb/265173/ ) Datacenter 프로그램 및 Windows 2000 Datacenter Server 제품
한 번만 부팅하여 핫픽스를 여러 개 설치하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
296861  (http://support.microsoft.com/kb/296861/ ) 한 번만 다시 부팅하여 여러 Windows 업데이트 또는 핫픽스를 설치하는 방법

유사한 문제 및 해결 방법

유사한 문제와 해결 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
330174  (http://support.microsoft.com/kb/330174/ ) Windows XP에서 파일을 관리할 때 "지연된 쓰기 실패" 오류 메시지가 나타난다
818788  (http://support.microsoft.com/kb/818788/ ) USB 2.0 저장 장치를 분리하면 "{지연된 쓰기 실패}" 오류 메시지가 나타난다
831594  (http://support.microsoft.com/kb/831594/ ) 파일을 저장하거나 OneNote 2007 또는 OneNote 2003을 종료하려고 하면 "지연된 쓰기 실패" 오류 메시지가 나타난다
843515  (http://support.microsoft.com/kb/843515/ ) 원격 Windows Server 2003 기반 컴퓨터에서 파일 작업을 수행하려고 하면 네트워크 연결이 원래대로 설정될 수 있다
870894  (http://support.microsoft.com/kb/870894/ ) Windows XP 서비스 팩 2 또는 Windows XP Tablet PC Edition 2005에서 "지연된 쓰기 실패" 오류 메시지가 나타난다
885464  (http://support.microsoft.com/kb/885464/ ) Windows XP에서 데이터를 쓰려고 하면 SBP-2 드라이브가 응답하지 않는다
885688  (http://support.microsoft.com/kb/885688/ ) Windows Server 2003에서 Windows 클러스터를 사용할 경우 이벤트 ID 57, 이벤트 ID 55 및 이벤트 ID 50이 기록될 수 있다
890352  (http://support.microsoft.com/kb/890352/ ) Windows Server 2003 기반 컴퓨터에서 프로그램이 볼륨 탑재 지점에 데이터를 쓰려고 하면 프로그램이 응답하지 않을 수 있고 이벤트 50 및 이벤트 26이 기록된다
891194  (http://support.microsoft.com/kb/891194/ ) Windows Server 2003 SP1에서 터미널 서버를 사용하도록 설정된 서버에서 로그오프하면 이벤트 ID: 26이 발생한다
912593  (http://support.microsoft.com/kb/912593/ ) Windows Server 2003 서비스 팩 1(SP1) 또는 Windows x64 Edition을 실행하는 컴퓨터에서 HP SecurePath를 사용하면 이벤트 ID 50, 26 또는 57이 기록된다
925269  (http://support.microsoft.com/kb/925269/ ) Windows XP 기반 컴퓨터에서 SD 카드와 같은 이동식 저장 장치의 연결을 끊으면 "Windows 지연된 쓰기 실패" 오류 메시지가 나타난다
927912  (http://support.microsoft.com/kb/927912/ ) Windows XP, Windows 2000 또는 Windows Server 2003에서 NTFS 볼륨에 있는 큰 파일을 압축하려고 하면 시스템 로그에 "지연된 쓰기 실패" 오류 메시지 및 이벤트가 기록된다
이러한 Microsoft 기술 자료 문서에서 설명하는 방법으로 문제가 해결되지 않거나 “현상” 절에서 설명하는 것과 다른 현상이 나타나는 경우 Microsoft 기술 자료에서 자세한 내용을 검색해 보십시오. Microsoft 기술 자료를 검색하려면 다음과 같이 하십시오.
  1. 다음 Microsoft 웹 사이트를 방문합니다.
    http://support.microsoft.com (http://support.microsoft.com)
  2. 검색 텍스트 상자에 표시된 오류 메시지의 텍스트나 문제에 대한 설명을 입력한 다음 Enter 키를 누릅니다.




Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹 (http://support.microsoft.com/newsgroups/default.aspx) 에 참여하시기 바랍니다.

본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
키워드: 
kbresolve kbHotfixServer kbqfe kbwin2ksp4fix kboswin2000fix kbbug kbfix kbwin2000presp4fix KB321733
공유
추가 지원 옵션
Microsoft Community 지원 포럼
직접 문의하기
Microsoft Certified Partner 찾기
Microsoft Store
소기업이 아닙니까?
다음에서 팔로우하십시오.