DetailPage-MSS-KB

기술 자료

기술 자료: 324491 - 마지막 검토: 2006년 4월 17일 월요일 - 수정: 12.0

사용 가능한 핫픽스 다운로드
핫픽스 보기 및 다운로드 요청하기
 
중요 이 문서에서는 레지스트리 수정 방법을 설명합니다. 레지스트리를 수정하기 전에 해당 레지스트리를 백업하고 문제 발생 시 이를 복원하는 방법을 이해해야 합니다. 레지스트리 백업, 복원 및 편집 방법은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
256986  (http://support.microsoft.com/kb/256986/ ) Microsoft Windows 레지스트리 설명

이 페이지에서

현상

Microsoft Excel 통합 문서를 네트워크 서버에 저장하려고 하는 경우 서버가 Macintosh용 서비스 같은 매개 서비스를 실행 중이거나, 통합 문서가 열려 있는 동안 네트워크 연결에 지연이 있으면 다음 메시지가 나타날 수 있습니다.
마지막으로 저장한 이후 다른 사용자가 (filename.xls) 파일을 변경했을 수 있습니다. 무엇을 하시겠습니까?
  • 복사본 저장
  • 변경 내용 덮어쓰기
복사본 저장을 기본적으로 선택합니다.

원인

이 메시지는 네트워크 연결이 끊어진 경우 다른 사람의 변경 내용을 덮어쓰는 것을 방지하기 위해 Microsoft Excel 2002에 새로 소개된 기능입니다.

네트워크 드라이브에서 파일을 연 다음 컴퓨터의 네트워크 연결이 끊어진 경우 사용자 모르게 두 번째 사람이 같은 파일을 열고 변경하고 저장한 다음 닫을 수 있습니다.

그런 다음 사용자가 파일을 저장하려고 하면 Excel이 메모리에 있는 파일의 타임 스탬프와 네트워크 드라이브에 있는 파일의 타임 스탬프를 비교합니다. 타임 스탬프가 일치하지 않으면 Excel은 앞에서 설명한 메시지를 표시합니다.

이 메시지가 사용자에게 잘못 나타날 수 있는 조건은 두 가지가 있습니다.
  • 매개 서비스를 실행하는 네트워크 서버에 파일을 저장하면 Excel이 타임 스탬프를 얻은 후에 컴퓨터가 파일에 추가 정보를 쓸 수 있습니다. 예를 들어, Macintosh용 서비스를 실행하는 컴퓨터는 추가 Macintosh 관련 정보를 각 파일에 쓰며, 이 작업은 Excel이 타임 스탬프를 얻은 후에 발생할 수 있습니다.
  • 쓰기 권한이 있는 파일을 연 경우 Excel은 파일에 소유자 정보를 쓰고 마지막으로 수정한 타임 스탬프에 변경 내용을 적용합니다. Excel은 이 쓰기 작업이 성공적으로 완료된 후에 타임 스탬프 정보를 수집하고 통합 문서의 나머지 부분을 읽습니다. 그러나 네트워크에 지연이 있는 경우 Excel이 타임 스탬프를 요청할 때 파일이 로컬 파일 캐시로부터 완전히 업데이트되지 못할 수 있습니다. 결과적으로 서버는 마지막 편집 전에 설정된 시간 값을 반환할 수 있으며 저장된 시간을 확인할 때 Excel이 기대하는 시간과 일치하지 않게 됩니다. 이 문제는 파일이 NetAPP(Network Appliance) 저장 장치나 WAN(Wide Area Network)에 있을 경우 더 자주 발생합니다.
파일을 저장하려고 하면 Excel은 열고 저장하는 작업 사이의 타임 스탬프 차이를 발견하고 그에 따라 적절한 메시지를 표시합니다.

해결 방법

참고 경고 메시지의 근본 원인을 확실히 알지 못한다면 다음 레지스트리 키를 배포하지 마십시오. 경고 메시지가 나타나는 원인을 모르고 이 레지스트리 키를 배포하면 잠재적으로 네트워크나 서버에 더 큰 문제가 발생할 수 있습니다.

경고 레지스트리 편집기를 잘못 사용하면 심각한 문제가 발생할 수 있으며 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 레지스트리 편집기를 잘못 사용함으로써 발생하는 문제에 대해 해결을 보증하지 않습니다. 레지스트리 편집기의 사용에 따른 모든 책임은 사용자에게 있습니다.

Excel 2003

Excel 2003에서 이 문제를 해결하려면 다음과 같이 하십시오.
  1. 시작, 실행을 차례로 누르고 regedit를 입력한 다음 Enter 키를 누릅니다.
  2. 다음 키를 찾아 누릅니다.
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\11.0\Excel\Options
  3. 편집 메뉴에서 새로 만들기를 가리킨 다음 DWORD 값을 누릅니다.
  4. 이름으로 QFE_Saskatchewan을 입력한 다음 Enter 키를 누릅니다.
  5. QFE_Saskatchewan 항목을 마우스 오른쪽 단추로 누른 다음 수정을 누릅니다.
  6. 상자에 2를 입력합니다. 이 값을 입력하면 Excel이 타임 스탬프를 얻기 전에 항상 파일 캐시를 플러시합니다(이렇게 하면 대부분의 경우 문제가 해결됨). 아니면 Excel이 타임 스탬프 확인을 해제하고 모든 경우에 대화 상자를 표시하지 않도록 하려면 1을 입력합니다.

    참고 타임 스탬프 확인을 해제하지 않는 것이 좋습니다.
  7. 확인을 눌러 설정을 저장합니다.

Excel 2002

이 문제는 현재 서비스 팩에 포함된 핫픽스에서 처음 수정되었습니다. 최신 Office XP 서비스 팩을 설치한 경우 핫픽스를 설치할 필요가 없습니다.

서비스 팩 정보

이 문제는 Office XP 서비스 팩 3에서 수정되었습니다.
이 문제를 해결하려면 Microsoft Office XP의 최신 서비스 팩을 구하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
307841  (http://support.microsoft.com/kb/307841/ ) OFFXP: 최신 Office XP 서비스 팩을 구하는 방법

수정 프로그램 설정

이 디자인 변경을 설정하려면 다음과 같이 하십시오.
  1. 시작, 실행을 차례로 누르고 열기 상자에 regedit를 입력한 다음 Enter 키를 누릅니다.
  2. 다음 키를 찾아 누릅니다.
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\10.0\Excel\Options
  3. 편집 메뉴에서 새로 만들기를 가리킨 다음 DWORD 값을 누릅니다.
  4. 이름으로 QFE_Saskatchewan을 입력한 다음 Enter 키를 누릅니다.
  5. QFE_Saskatchewan 항목을 마우스 오른쪽 단추로 누른 다음 수정을 누릅니다.
  6. Excel이 타임 스탬프를 얻기 전에 항상 파일 캐시를 플러시하도록 하려면 상자에 2를 입력하고(이렇게 하면 대부분의 경우 문제가 해결됨), Excel이 타임 스탬프 확인을 해제하고 모든 경우에 대화 상자를 표시하지 않도록 하려면 1을 입력합니다.

    참고 타임 스탬프 확인을 해제하지 않는 것이 좋습니다.
  7. 확인을 눌러 설정을 저장합니다.
  8. Excel을 다시 시작하여 해당 사용자에 대해 설정을 적용합니다.

핫픽스 정보

핫픽스를 구하는 방법

이 문제는 2003년 6월 7일자 Excel 2002 서비스 팩 2 이후 핫픽스 패키지에서 해결되었습니다.
자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
822347  (http://support.microsoft.com/kb/822347/ ) 2003년 6월 7일자 Excel 2002 서비스 팩 2 이후 핫픽스 패키지에 대한설명

해결 과정

이 문제를 해결하려면 다음 방법 중 하나를 사용하십시오.
  • 도구 메뉴에서 통합 문서 공유를 눌러 Excel 통합 문서를 공유합니다. 공유 사용 권한을 사용하여 파일에 대한 액세스를 제한할 수 있습니다. 공유된 통합 문서는 여러 사용자의 편집을 추적하며 타임 스탬프 확인이 필요하지 않습니다.
  • LAN의 Microsoft Windows 2000 또는 Microsoft Windows Server 2003에 파일을 저장하고 Macintosh용 서비스 같이 예기치 않게 파일을 수정할 수 있는 서비스를 해제하십시오.
  • 사용자가 파일에 액세스하거나 파일을 사용하는 유일한 사람이라고 확신하는 경우에만 대화 상자에서 변경 내용 덮어쓰기를 누르십시오.

현재 상태

Microsoft는 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열한 제품에서 이 문제를 확인했습니다. 이 문제는 Office XP 서비스 팩 3에서 처음 수정되었습니다.

참고 핫픽스를 사용하려면 Office XP 서비스 팩 3을 설치한 후 "해결 방법" 절에 설명되어 있는 레지스트리 키를 추가해야 합니다.



Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹 (http://support.microsoft.com/newsgroups/default.aspx) 에 참여하시기 바랍니다.

본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
키워드: 
kberrmsg kbbug kbnofix kbqfe kbhotfixserver KB324491
공유
추가 지원 옵션
Microsoft Community 지원 포럼
직접 문의하기
Microsoft Certified Partner 찾기
Microsoft Store
소기업이 아닙니까?
다음에서 팔로우하십시오.