DetailPage-MSS-KB

기술 자료

기술 자료: 946344 - 마지막 검토: 2008년 2월 22일 금요일 - 수정: 1.4

 

이 페이지에서

현상

영문자와 숫자가 조합된 PIN 코드가 설정된 Bluetooth 장치가 있다면:
  • Visual Studio 2008 Microsoft VBA 프로젝트를 빌드할 수 있습니다.
  • Visual Basic 프로젝트를 한 파일에 여러 XML 주석이 포함되어 있습니다.
  • 파일 또는 웹 참조를 데이터 집합에 대해 디자이너가 생성한 파일일 수 있습니다.
이 시나리오에서는 IDE에서 다음과 같은 성능 문제가 발생할 수 있습니다.
  • IDE는 솔루션을 빌드하고 솔루션을 다시 오랜 시간이 걸립니다.
  • 디버깅을 시작하려면 F5 키를 눌러 느린 응답 시간이 발생할 수 있습니다.
  • 느린 응답 시간을 코드 편집기에서 발생합니다.
  • IntelliSense 느린 응답 시간이 발생할 수 있습니다.

원인

이 문제는 Visual Studio 2008 컴파일러가 XML 문서를 포함하는 큰 파일을 처리하는 방법 때문에 발생합니다.

해결 방법

핫픽스 정보



Microsoft에서 제공하는 핫픽스를 사용할 수 있습니다. 그러나 이 핫픽스는 이 문서에서 설명된 문제만 해결할 수 있습니다. 이 문서에 설명된 특정 문제가 발생한 시스템에만 이 핫픽스를 적용하십시오. 추후에 이 핫픽스를 테스트할 수 있습니다. 따라서 이 문제로 심각하게 영향을 받은 경우를 제외하곤 이 핫픽스가 포함된 다음 소프트웨어 업데이트까지 기다리는 것이 좋습니다.

이 핫픽스를 MSDN 코드 갤러리 다운로드하려면 다음 Microsoft 웹 사이트를 방문하십시오.
http://code.msdn.microsoft.com/KB946344 (http://code.msdn.microsoft.com/KB946344)

참고 MSDN 코드 갤러리 핫픽스를 사용할 수 있는 언어가 표시됩니다. 나열된 사용자 언어가 표시되지 않으면 해당 언어로 코드 갤러리 리소스 페이지를 사용할 수 없습니다 때문입니다.

참고 추가적인 문제가 발생할 경우 또는 모든 문제 해결에 필요한 경우 별도의 서비스 요청을 만들어야 할 수도 있습니다. 핫픽스에 적용되지 않는 추가 지원 질문과 문제에는 일반 지원 비용이 적용됩니다. Microsoft 고객 서비스 지원 전화 번호 전체 목록 또는 별도의 서비스 요청을 만들려면 다음 Microsoft 웹 사이트로 이동하십시오:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fcontactus%2f%3fws%3dsupport)


이 핫픽스의 영어 버전은 다음 표에 나열된 파일 특성(또는 그 이후의 파일 특성)이 있습니다. 이러한 파일의 시간과 날짜는 UTC (협정 세계시) 로 나열됩니다. 파일 정보에서는 현지 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 알려면 제어판의 날짜 및 시간 항목에서 표준 시간대 탭을 사용하십시오.
표 축소표 확대
파일 이름파일 버전파일 크기날짜시간
Avvspkdh.dll9.0.21022.4334,8162008-Jan-2903: 17
Mcee.dll9.0.21022.43367,6082008-Jan-2903: 17
Mpishim.exe9.0.21022.4326,1122008-Jan-2903: 17
Msvb7.dll9.0.21022.434,069,8802008-Jan-2903: 17
Msvsmon.exe9.0.21022.433,004,4162008-Jan-2903: 17

해결 과정

이 문제를 해결하려면 다음 방법 중 하나를 사용하십시오.

XML 주석 생성 방법 1: 없음

프로젝트에 대한 XML 주석이 생성을 해제하려면 다음 절차 중 하나를 사용하십시오.

Visual Studio 2008

  1. 솔루션 탐색기에서 ProjectName 을 마우스 오른쪽 단추로 클릭한 다음 속성 을 클릭하십시오.
  2. 컴파일 탭을 클릭하여 XML 문서 파일 생성 확인란 선택을 취소합니다.
  3. 파일 메뉴에서 모두 저장 을 클릭하십시오.

Visual Basic 2008 Express Edition

  1. 프로젝트의 백업을 만듭니다.
  2. 해당 프로젝트의 .vbproj 파일을 메모장에서 엽니다.
  3. 찾은 다음 모든 <documentationfile>삭제하십시오.vbproj 파일의 요소.

    참고 일반적으로, .vbproj 파일의 두 요소를 삭제할 수 있습니다.

방법 2: XML 주석 제거

XML 주석을 제거하려면 디자이너에서 생성한 파일에 대해 다음과 같이 하십시오.
  1. 편집 메뉴에서 찾기 및 바꾸기 를 가리킨 다음 빠른 바꾸기 를 클릭하십시오.
  2. 찾을 내용 상자에 '' '.
  3. 바꿀 내용 상자에 '', 모두 바꾸기 를 클릭합니다.
참고 다음 작업 중 하나를 수행할 경우 위의 이 단계를 반복해야 합니다.
  • 이 코드 파일을 생성한 디자이너 파일을 저장합니다.
  • 웹 참조를 새로 고칩니다.
  • 파일을 마우스 오른쪽 단추로 클릭한 다음 사용자 지정 도구 실행 을 클릭합니다.

방법 3: XML 주석이 있는 파일을 저장하는 데 별도의 프로젝트 만들기

디자이너에서 생성한 파일을 저장할 새 클래스 라이브러리 프로젝트를 만듭니다. 다음 절차에서는 이 작업을 수행하는 예입니다.
  1. 데이터 집합을 포함하거나 웹 참조가 들어 있는 파일을 저장할 새 클래스 라이브러리 프로젝트를 만듭니다.
  2. 원래 VBA 프로젝트에 새 클래스 라이브러리 프로젝트에 대한 참조를 추가하십시오.
  3. 방법 1을 사용하여 XML 문서 파일 사용 안 함.
참고 Visual Basic 코드 import 문을 추가해야 할 수도 있습니다.

현재 상태

Microsoft는 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열된 Microsoft 제품에서 이 문제를 확인했습니다.

추가 정보

추가 정보는 다음 문서 번호를 클릭하여 Microsoft 기술 자료에서 확인하십시오:
824684  (http://support.microsoft.com/kb/824684/ ) Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명
프로젝트에 대한 XML 문서를 생성하는 방법에 대한 자세한 내용은 다음 MSDN) Microsoft 개발자 네트워크 (웹 사이트를 방문하십시오.
http://msdn2.microsoft.com/en-us/library/x4sa0ak0(VS.90).aspx (http://msdn2.microsoft.com/en-us/library/x4sa0ak0(VS.90).aspx)

본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Visual Studio 2008 Professional Edition
  • Microsoft Visual Studio 2008 Academic Edition
  • Microsoft Visual Studio 2008 Standard Edition
  • Microsoft Visual Basic 2008 Express Edition
  • Microsoft Visual Studio 2008 Team Suite
  • Microsoft Visual Studio 2008 Team Edition for Database Professionals
  • Microsoft Visual Studio 2008 Team Edition for Software Architects
  • Microsoft Visual Studio 2008 Team Edition for Software Developers
  • Microsoft Visual Studio 2008 Team Edition for Software Testers
키워드: 
kbmt kbpubtypekc kbqfe KB946344 KbMtko
기계 번역된 문서기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.
공유
추가 지원 옵션
Microsoft Community 지원 포럼
직접 문의하기
Microsoft Certified Partner 찾기
Microsoft Store
소기업이 아닙니까?
다음에서 팔로우하십시오.