DetailPage-MSS-KB

기술 자료

기술 자료: 948187 - 마지막 검토: 2008년 4월 15일 화요일 - 수정: 1.3

이 페이지에서

현상

Windows Vista를 실행하는 컴퓨터에 Windows Vista 서비스 팩 1(SP1)을 설치한 후 다음 현상 중 하나 이상이 발생합니다.
  • 장치 드라이버가 설치되지 않고 장치 관리자에서 장치 드라이버 옆에 느낌표(!)가 나타납니다.
  • 장치 드라이버에서 장치 드라이버가 제대로 설치된 것으로 나타납니다. 그러나 하드웨어 장치가 제대로 작동하지 않습니다.

원인

이 문제는 Window Vista SP1에서 장치 안정성을 높이기 위해 시스템 파일과 일부 장치 드라이버를 업데이트하기 때문에 발생합니다. Window Vista SP1을 설치하면 서비스 팩 설치 프로세스에서 설치가 끝날 때 일부 장치 드라이버를 다시 설치할 수 있습니다.

참고 Windows Vista SP1을 설치하기 전에 하드웨어의 최신 드라이버를 설치하는 것이 좋습니다. 이렇게 하면 “현상” 절에 나와 있는 문제를 방지할 수 있습니다.

해결 방법

이 문제를 해결하려면 다음 방법을 아래에 나타난 순서대로 사용하십시오.

방법 1: 장치 관리자에 장치 드라이버가 표시되는지 확인

이렇게 하려면 다음과 같이 하십시오.
  1. 시작
    그림 축소그림 확대
    시작 단추
    을 누르고 검색 시작 상자에 장치 관리자를 입력한 다음 Enter 키를 누릅니다.
  2. 장치 관리자에서 장치의 장치 드라이버를 찾을 수 없으면 장치 옆에 느낌표가 나타납니다. 느낌표가 나타나지 않지만 장치가 제대로 작동하지 않으면 방법 2로 이동하십시오.
  3. 장치 관리자에서 장치 드라이버 옆에 느낌표가 나타나면 Windows Update를 사용하여 장치 드라이버를 검색할 수 있습니다. 이렇게 하려면 다음과 같이 하십시오.
    1. 시작
      그림 축소그림 확대
      시작 단추
      , 모든 프로그램, Windows Update를 차례로 누릅니다.

      관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 확인합니다.
    2. 업데이트 확인을 누릅니다.
    3. 업데이트된 드라이버를 사용할 수 있는지 확인하려면 사용 가능한 업데이트 보기를 누릅니다.

      업데이트를 사용할 수 있으면 설치할 드라이버를 누른 다음 설치를 누릅니다. 관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 확인합니다.
Windows Update에서 필요한 장치 드라이버를 찾을 수 없으면 장치 제조업체에 문의하여 Windows Vista용 최신 장치 드라이버를 다운로드합니다. 이렇게 하는 방법에 대한 자세한 내용은 "추가 정보" 절을 참조하십시오.

방법 2: 장치 드라이버를 제거한 다음 다시 설치

장치 관리자에서 장치 드라이버가 올바르게 설치된 것으로 나타나지만 장치가 제대로 작동하지 않으면 장치 드라이버를 수동으로 제거한 다음 다시 설치합니다. 이렇게 하려면 다음과 같이 하십시오.
  1. 시작
    그림 축소그림 확대
    시작 단추
    을 누르고 검색 시작 상자에 장치 관리자를 입력한 다음 Enter 키를 누릅니다.
  2. 장치 관리자 대화 상자에서 작동하지 않는 하드웨어 장치를 찾습니다.
  3. 장치를 마우스 오른쪽 단추로 누르고 속성을 누릅니다.
  4. 드라이버 탭을 누릅니다.
  5. 제거를 누릅니다.
  6. 이 장치의 드라이버 소프트웨어를 삭제합니다. 확인란의 선택이 취소되어 있는지 확인한 다음 확인을 누릅니다.
  7. 장치 관리자 대화 상자에서 동작 메뉴를 누른 다음 하드웨어 변경 사항 검색을 누릅니다.

    하드웨어 장치가 설치되고 있고 제거된 장치가 이제 장치 관리자에 있다는 메시지가 나타납니다.
  8. 하드웨어 장치 드라이버가 설치되어 있지 않으면 Windows Update를 사용하여 업데이트된 장치 드라이버를 검색합니다. 이렇게 하려면 다음과 같이 하십시오.
    1. 시작
      그림 축소그림 확대
      시작 단추
      , 모든 프로그램, Windows Update를 차례로 누릅니다.

      관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 확인합니다.
    2. 업데이트 확인을 누릅니다.
    3. 업데이트된 드라이버를 사용할 수 있는지 확인하려면 사용 가능한 업데이트 보기를 누릅니다.

      업데이트를 사용할 수 있으면 설치할 드라이버를 누른 다음 설치를 누릅니다. 관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 확인합니다.
Windows Update에서 필요한 장치 드라이버를 찾을 수 없으면 장치 제조업체에 문의하여 Windows Vista용 최신 장치 드라이버를 다운로드합니다. 이렇게 하는 방법에 대한 자세한 내용은 "추가 정보" 절을 참조하십시오.

추가 정보

하드웨어 및 소프트웨어 공급업체에 연락하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
65416  (http://support.microsoft.com/kb/65416/ ) A-K로 시작하는 하드웨어 및 소프트웨어 공급업체 연락처 목록

60781  (http://support.microsoft.com/kb/60781/ ) L-P로 시작하는 하드웨어 및 소프트웨어 공급업체 연락처 목록

60782  (http://support.microsoft.com/kb/60782/ ) Q-Z로 시작하는 하드웨어 및 소프트웨어 공급업체 연락처 목록
이 문서에 포함된 다른 공급업체의 연락처 정보는 기술 지원을 받는 데 도움을 주기 위한 것입니다. 이 연락처 정보는 예고 없이 변경될 수 있습니다. Microsoft는 이러한 다른 공급업체 연락처 정보의 정확성을 보증하지 않습니다.

Windows Vista 서비스 팩 1을 설치한 후 발생할 수 있는 오디오 문제를 해결하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
948481  (http://support.microsoft.com/kb/948481/ ) Windows Vista 서비스 팩 1을 설치한 후 소리 문제가 발생한다

본 문서의 정보는 다음의 제품에 적용됩니다.
  • Windows Vista Service Pack 1
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Starter
키워드: 
kbexpertisebeginner kbtshoot kbprb KB948187
공유
추가 지원 옵션
Microsoft Community 지원 포럼
직접 문의하기
Microsoft Certified Partner 찾기
Microsoft Store
소기업이 아닙니까?
다음에서 팔로우하십시오.