DetailPage-MSS-KB

Knowledge Base

Artikel ID: 106167 - Laatste beoordeling: zondag 11 september 2011 - Wijziging: 3.0

 

Symptomen

Wanneer u gedeelde items op een Windows NT server openen vanaf een Windows NT-client u kunt het volgende fout bericht:
Er is onvoldoende server opslag ruimte beschikbaar om deze opdracht te verwerken.
De volgende gebeurtenissen kunnen ook worden vastgelegd:

Gebeurtenis-ID: 2011

Gebeurtenis-ID: 2011
Bron: Srv
De server configuratieparameter 'irpstacksize' is te klein voor de server een lokaal apparaat te gebruiken. Verhoog de waarde van deze parameter.

Gebeurtenis-ID: 0

Gebeurtenis-ID: 0
Bron: SRV
Beschrijving: Beschrijving voor gebeurtenis-ID kan niet worden gevonden. Deze bevat de teken reeks \device\LanManServer invoegen

Oorzaak

Dit probleem kan optreden als de registervermelding IRPStackSize op de server is te laag ingesteld.

Oplossing

BelangrijkDeze sectie, methode of taak bevat stappen voor het wijzigen van het register. Echter, kunnen ernstige problemen optreden als u het register onjuist bewerkt. Zorg ervoor dat u deze zorgvuldig uitvoert stappen. Voor extra bescherming, back-up van het register voordat u aanbrengt wijzigingen. Vervolgens kunt u het register herstellen als er een probleem optreedt. Voor meer informatie over back-up en terugzetten van het register, klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Back-up en terugzetten van het register in Windows


Verhoog de waarde van de registervermelding IRPStackSize dit probleem op te lossen. Hiertoe gaat u als volgt te werk:
  1. Klik opStart, klik opUitvoeren, typeRegedit, en klik vervolgens opOK.
  2. Zoek en klik op de volgende registersubsleutel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    Als de post IRPStackSize in deze subsleutel aanwezig is, gaat u als volgt te werk:
    1. Klik opBewerken, wijsNieuwe, en klik vervolgens opDWORD-waarde.
    2. TypeIRPStackSize, en druk vervolgens op ENTER.

      OpmerkingTypeIRPStackSizeprecies zoals deze wordt weer gegeven. De waarde is hoofdlettergevoelig.
  3. Klik opIRPStackSize, klik opBewerken, en klik vervolgens opWijzigen.
  4. In deGegevenswaardeeen hogere waarde op en klik opOK.

    OpmerkingWaarden kunnen variëren van 0x1 tot 0xC. Deze waarden komen overeen met 1 tot en met 12 in decimale notatie.
Als het probleem zich blijft voordoen nadat u de vorige procedure hebt voltooid, kunt u de waarde van IRPStackSize meer verhogen.

Meer informatie

Als de registervermelding IRPStackSize aanwezig is, gebruikt de computer een standaard waarde 0x4. Afhankelijk van de configuratie van de hardware van de computer kan deze standaard waarde niet groot genoeg is voor de SRV-service beheren gedeeld mappen op een aantal van de fysieke schijven. Wanneer een Windows voor Workgroups-client probeert toegang te krijgen tot deze gedeelde mappen, verschijnt het volgende bericht:
Pad niet gevonden.
Als u deze fout melding, geleidelijk verhogen de waarde van IRPStackSize om de laagste waarde waarmee u de probleem. Met een waarde die groter is dan nodig kan afval van systeembronnen. Andere factoren kunnen ook leiden tot dit foutbericht. Als het probleem zich blijft voordoen nadat u alle geldige waarden voor IRPStackSize, hebt gebruikt IRPStackSize terugzetten op de oorspronkelijke waarde, en vervolgens zoeken naar een andere verklaring voor de fout.

Als u dit fout bericht en Microsoft Windows NT 4. 0 wordt uitgevoerd, raadpleegt u het volgende artikel in de Microsoft Knowledge Base:
198386  (http://support.microsoft.com/kb/198386/ ) Wijzigingen in IRP-stackgrootte in Lanman-server

De informatie in dit artikel is van toepassing op:
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Server 3.51
Trefwoorden: 
kbnetwork kbprb kbmt KB106167 KbMtnl
Machine-translated ArticleMachine-translated Article
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:106167  (http://support.microsoft.com/kb/106167/en-us/ )
Delen
Extra ondersteuningsopties
Microsoft Community Support-forums
Neem rechtstreeks contact met ons op
Een door Microsoft gecertificeerde partner zoeken
Microsoft Store