DetailPage-MSS-KB

Knowledge Base

Artikel ID: 885353 - Laatste beoordeling: dinsdag 27 september 2011 - Wijziging: 3.0

Deze hotfix is als download beschikbaar
Download deze hotfix nu
 
 

Op deze pagina

Symptomen

Wanneer Microsoft Windows Media Player 9 Series voor Windows via geverifieerde proxy verbinding met een gegevensstroom maakt, wordt de Windows Media Player-client referenties gevraagd. Dit probleem kan optreden wanneer Windows Media Player 9 Series voor Windows logboekgegevens naar de server verzendt. Dit probleem kan optreden als een van de volgende voorwaarden voldaan is:
  • Windows Media Player treffers einde van stream.
  • Windows Media Player of de gebruiker zoekt of in het bestand wordt overgeslagen.
  • Windows Media Player of de gebruiker handmatig stopt de stream of de stroom wordt onderbroken.

Oorzaak

Afhankelijk van het type van streaming met Windows Media Player 9 Series voor Windows gebruikt proberen deze de logboeken indienen via HTTP-protocol. Windows Media Player 9 Series voor Windows probeert standaard HTTP 1.1 gebruiken. Echter, soms Windows Media Player 9 Series voor Windows niet via HTTP 1.0. Afhankelijk van de proxy-specifieke implementaties van de HTTP 1.0-specificatie, kan Windows Media Player 9 Series voor Windows naar referenties gevraagd.

Oplossing

Een ondersteunde hotfix is nu beschikbaar bij Microsoft. Het is echter bedoeld om alleen het probleem dat in dit artikel wordt beschreven. Gelden alleen voor systemen waarop dit specifieke probleem. Deze hotfix wellicht extra worden getest. Als u geen ernstige problemen ondervindt, is het daarom raadzaam te wachten op de volgende versie waarin deze hotfix is opgenomen.

Dit probleem onmiddellijk contact op met Microsoft Customer Support Services om de hotfix te verkrijgen. Bezoek de volgende Microsoft-website voor een volledige lijst met telefoonnummers van Microsoft Customer Support Services en informatie over ondersteuningskosten:
http://support.Microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
OpmerkingIn speciale gevallen kunnen kosten die normaal verbonden worden geannuleerd als een medewerker van Microsoft bepaalt dat een specifieke update de oplossing van uw probleem. De gebruikelijke ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking voor de specifieke update in kwestie komen.

Windows Media Player 9 Series voor Windows XP

Het volgende bestand is gedownload van het Microsoft Downloadcentrum:
Deze afbeelding samenvouwenDeze afbeelding uitklappen
Downloaden
Het pakket WindowsXP-KB885353-v4-x 86-enu.exe nu downloaden. (http://download.microsoft.com/download/9/4/4/9443cfc5-d7f8-4ec6-ba58-5705e890ff77/WindowsXP-KB885353-v4-x86-enu.exe)

Windows MediaPlayer 9-serie voor Microsoft Windows 2000 en Microsoft Windows Server 2003

Het volgende bestand is gedownload van het Microsoft Downloadcentrum:
Deze afbeelding samenvouwenDeze afbeelding uitklappen
Downloaden
Het pakket WindowsMedia9-KB885353-v5-x 86-INTL.exe nu downloaden. (http://download.microsoft.com/download/E/A/2/EA284623-613A-4DD0-BF08-3EDD3E13FBCA/WindowsMedia9-KB885353-v5-x86-INTL.exe)

Windows MediaPlayer 9-serie voor Microsoft Windows Server 2003, Japans

Het volgende bestand is gedownload van het Microsoft Downloadcentrum:

Deze afbeelding samenvouwenDeze afbeelding uitklappen
Downloaden
Het pakket WindowsMedia9-KB885353-x 86-JPN.exe nu downloaden. (http://download.microsoft.com/download/8/4/3/843F8926-D783-4879-9F7F-27CD4145ECB1/WindowsMedia9-KB885353-x86-JPN.exe)

Windows MediaPlayer 10

Het volgende bestand is gedownload van het Microsoft Downloadcentrum:
Deze afbeelding samenvouwenDeze afbeelding uitklappen
Downloaden
Het pakket WindowsMedia10-KB885353-x 86-ENU.exe nu downloaden. (http://download.microsoft.com/download/0/7/b/07bedf3a-39db-4fcf-ab95-85b57f90ac7d/WindowsMedia10-KB885353-x86-ENU.exe) Voor meer informatie over het downloaden van Microsoft-ondersteuningsbestanden klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) Microsoft-ondersteuningsbestanden via online services downloaden
Microsoft heeft dit bestand op virussen. Microsoft gebruikt de meest actuele software voor virusdetectie die beschikbaar was op de datum waarop het bestand werd gepost. Het bestand is opgeslagen op beveiligde servers die onbevoegde wijzigingen aan het bestand voorkomen.

De Engelse versie van deze hotfix heeft de bestandskenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Het verschil tussen UTC en lokale tijd, gebruikt u deTijdzonetabblad in deDatum en tijditem in het Configuratiescherm.
 Date         Time   Version      Size       File name 
-------------------------------------------------------------- 
 11-Oct-2004  13:15  9.0.0.3260   1,053,184  Wmnetmgr.dll (Windows Media Player 9 Series, all operating systems) 
 01-Mar-2005  11:19  10.0.0.3904  1,027,584  Wmnetmgr.dll (Windows Media Player 10)

Status

Microsoft heeft bevestigd dat dit is een fout in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Meer informatie

WaarschuwingDit artikel bevat informatie over het bewerken van de naamruimte. Controleer voordat u de naamruimte bewerken, of u een back-up herstellen kunt als er een probleem optreedt. Als u de naamruimte onjuist bewerkt, kan ernstige problemen dat u opnieuw een product de naamruimte gebruikt. Microsoft kan niet garanderen dat problemen die optreden als u de naamruimte onjuist bewerkt kunnen worden opgelost. Bewerk de naamruimte voor uw eigen risico.

Uitschakelen van deze correctie als volgt:
  1. Voor Windows Media Player 9 Series, zoek de volgende map waarin de client naamruimte bevindt:

    C:\Documents and Settings\%username%\Local Settings\Application Data\Microsoft\Windows Media\9.0

    Zoek de volgende map waarin de client naamruimte bevindt voor Windows Media Player 10:

    C:\Documents and Settings\%username%\Local Settings\Application Data\Microsoft\Windows Media\10.0
  2. Open het bestand Wmsdkns.xml in een teksteditor zoals Kladblok.
  3. Zoek deNetwerkbronknooppunt in de naamruimte.
  4. Zoek deObject archiefknooppunt onder hetNetwerkbronknooppunt.
  5. Zoek deWMS Http netwerk bronknooppunt onder hetObject archiefknooppunt.
  6. Zoek deEigenschappenknooppunt onder hetWMS Http netwerk bronknooppunt.
  7. Toevoegen van het volgende voorbeeld onder deEigenschappenknooppunt.
    <node name="SendPostProxyKeepAlive" opcode="create" type="int32" value="0x0" />

De naamruimtewaarde van deze kan een van de volgende waarden hebben:
  • 0x0-De correctie uitschakelen
  • 0x1-Oplossing (standaard) inschakelen

In het volgende voorbeeld is een andere weergave van de waarde die u in het bestand Wmsdkns.xml instellen kunt.
<node name="Network Source" opcode="create">
    ...
    <node name="Object Store" opcode="create">
        ...
        <node name="WMS Http Network Source" opcode="create">
            ...
            <node name="Properties" opcode="create">
                ...
                <node name="SendPostProxyKeepAlive" opcode="create" type="int32" value="0x0" />
            </node> <!--  Properties -->
            ...
        </node> <!--  WMS Http Network Source -->
        ...
    </node> <!--  Object Store -->
    ...
</node><!--  Network Source -->

De informatie in dit artikel is van toepassing op:
  • Microsoft Windows Media Player 9 Series
  • Windows Media 9 Series Software Development Kit
  • Microsoft Windows Media Player 10
Trefwoorden: 
kbtshoot kbfix kbqfe kbhotfixserver kbmt KB885353 KbMtnl
Machine-translated ArticleMachine-translated Article
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:885353  (http://support.microsoft.com/kb/885353/en-us/ )
Delen
Extra ondersteuningsopties
Microsoft Community Support-forums
Neem rechtstreeks contact met ons op
Een door Microsoft gecertificeerde partner zoeken
Microsoft Store