DetailPage-MSS-KB

Knowledge Base

Artikel ID: 887569 - Laatste beoordeling: donderdag 17 maart 2011 - Wijziging: 2.0

Deze hotfix is als download beschikbaar
Download deze hotfix nu
 
 

Op deze pagina

Symptomen

Het volgende probleem kan optreden wanneer een programma de versie van Microsoft Windows XP Service Pack 2 (SP2) van het bestand Atl.dll naar host ActiveX-besturingselementen. Wanneer een programma met deze versie van Atl.dll bestand aanvragen toegang tot de eigenschap omgevingslicht lettertype in een hosttoepassing Active Template Library (ATL) kan de aanvraag een null-aanwijzer terug naar de IFontDisp-interface.

Wanneer de aanwijzer null geretourneerd, kan een toegangsfout optreden omdat de meeste ActiveX-besturingselementen niet een null-aanwijzer herkent. Het programma reageert niet meer. Of ActiveX-besturingselementen niet goed.

Oorzaak

Dit probleem treedt op vanwege een regressie in de versie van het bestand Atl.dll van Windows XP SP2.

Het besturingselement maakt een aanroep van deIAxWinAmbientDispatch::get_Fontmethode. Deze aanroep vervolgens deATL!ATL::CAxHostWindow::get_Fontde methode wordt aangeroepen. De aanroep van deATL!ATL::CAxHostWindow::get_Fontmethode resultaat een S_OK HRESULT. De IFontDisp-interface wordt echter een null-aanwijzer geretourneerd. Programma's meestal aannemen dat een geldige aanwijzer geretourneerd als de interface een HRESULT S_OK resultaat. Het besturingselement herkent echter geen null-pointer die de IFontDisp-interface wordt geretourneerd. Hierdoor ondervindt u problemen die worden beschreven in de sectie 'Symptomen'.

Oplossing

Informatie over hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter bedoeld om alleen het probleem dat in dit artikel wordt beschreven. Deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet wellicht extra worden getest. Als u geen ernstige problemen ondervindt, is het daarom raadzaam te wachten op de volgende update waarin deze hotfix is opgenomen.

Als u de hotfix downloaden, is er een sectie 'Hotfix downloaden beschikbaar' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, contact op met Microsoft Customer Service and Support om de hotfix te verkrijgen.

OpmerkingAls er nog andere problemen optreden of als er oplossingen vereist is, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking voor deze specifieke hotfix komen. Bezoek de volgende Microsoft-website voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of een afzonderlijk serviceverzoek maken:
http://support.Microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
OpmerkingHet formulier 'Hotfix gedownload' geeft de talen waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is omdat een hotfix voor die taal beschikbaar.De Engelse versie van deze hotfix heeft de bestandskenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Het verschil tussen UTC en lokale tijd, gebruikt u deTijdzonetabblad in het onderdeel Datum en tijd in het Configuratiescherm.
Date         Time   Version            Size    File name
---------------------------------------------------------
11-Jan-2005  23:25  3.5.2284.1         58,880  Atl.dll

Status

Microsoft heeft bevestigd dat dit probleem in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op' is.

Meer informatie

Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
824684  (http://support.microsoft.com/kb/824684/ ) Beschrijving van de standaardterminologie die wordt gebruikt om software-updates voor Microsoft te beschrijven
Trefwoorden: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp3fix kbfix kbbug kbmt KB887569 KbMtnl
Machine-translated ArticleMachine-translated Article
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:887569  (http://support.microsoft.com/kb/887569/en-us/ )
Delen
Extra ondersteuningsopties
Microsoft Community Support-forums
Neem rechtstreeks contact met ons op
Een door Microsoft gecertificeerde partner zoeken
Microsoft Store