DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 131431 - Última revisão: quarta-feira, 15 de novembro de 2006 - Revisão: 1.1

 
Importante: Este artigo contém informações sobre a edição do Registro. Antes de você editar o registro, primeiro você deve fazer uma cópia de backup dos arquivos do Registro (System.dat e User.dat). Ambos são arquivos ocultos na pasta do Windows.

Nesta página

Sintomas

Quando você inicia o Windows 95, você pode receber uma das seguintes mensagens de erro:
Não há memória suficiente para carregar o registro.
- ou -
O Windows encontrou um erro ao acessar o registro do sistema. Você deve restaurar o registro agora e reinicie o computador.

Se você ignorar este erro e desligar o sistema, você poderá perder dados.

Restaurar o Registro substitui o registro com defeito uma cópia de backup boa conhecida. No entanto, essa cópia de backup pode não conter todas as informações recentemente adicionadas ao seu sistema.
Se você clicar no botão Restaurar do backup e reiniciar , você receberá a mensagem de erro novamente quando o Windows 95 for reiniciado.

Causa

Essas mensagens de erro podem ocorrer se o registro for danificado.

Resolução

Aviso : se você usar o Editor do Registro incorretamente, poderá causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.

Execute as etapas descritas em cada método abaixo (conforme apropriado) para restaurar um registro danificado.

Usando o Editor do modo real do registro

O uso Editor do registro em modo real para exportar, em seguida, importar, o arquivo de registro. Para fazer isso, execute estas etapas:
  1. Reinicie o computador. Quando você vir a mensagem "Iniciando o Windows 95", pressione a tecla F8 e selecione modo de segurança somente prompt de comando no menu Iniciar .
  2. Digite a seguinte linha para exportar o registro
    regedit/l: path1 /e path2 system.txt
    onde path1 é o caminho para o arquivo System.dat e path2 é o caminho para o arquivo de destino. Por exemplo, se o Windows 95 estiver instalado na pasta Windows na unidade C, digite a seguinte linha:
    regedit /l:c:\windows\system.dat /e c:\system.txt
  3. Digite as seguintes linhas e pressione ENTER após cada linha:
    cd\windows
    attrib -s-h-r system.dat
  4. Digite a seguinte linha para renomear o arquivo do registro atual:
    ren system.dat system.old
  5. Digite a seguinte linha para importar a parte System.dat do Registro:
    regedit/l: path1 /c path2 system.txt
    onde path1 é o caminho para o arquivo System.dat e path2 é o caminho que contém o arquivo para importar. Por exemplo, se o Windows 95 estiver instalado na pasta Windows na unidade C e você deseja importar o arquivo System.txt da pasta raiz da unidade C, digite:
    regedit /l:c:\windows\system.dat /c c:\system.txt
    Observação : se você receber um "não é possível abrir o registro" ou "Erro ao acessar o registro" mensagem de erro ao tentar importar a parte System.dat do Registro, consulte o seguinte artigo na Base de dados de Conhecimento da Microsoft para obter mais informações sobre a mensagem de erro:
    132064  (http://support.microsoft.com/kb/132064/EN-US/ ) Regedit pode não conseguir importar o registro com chaves grandes
  6. Reinicie o Windows 95.
Se o erro persistir, execute estas etapas:
  1. Reinicie o computador. Quando você vir a mensagem "Iniciando o Windows 95", pressione a tecla F8 e selecione modo de segurança somente prompt de comando no menu Iniciar .
  2. Digite a seguinte linha para exportar parte do Registro User.dat
    regedit/r: path1 /e path2 user.txt
    onde path1 é o caminho para o arquivo User.dat e path1 é o caminho para o arquivo de destino. Por exemplo, se o Windows 95 estiver instalado na pasta Windows na unidade C, digite a seguinte linha:
    regedit /r:c:\windows\user.dat /e c:\user.txt
  3. Digite as seguintes linhas e, em seguida, pressione ENTER após cada linha:
    cd\windows
    attrib -s-h-r user.dat
  4. Digite a seguinte linha para renomear o arquivo User.dat:
    ren user.dat user.old
  5. Digite a seguinte linha para importar parte do Registro User.dat:
    regedit/r: path1 /c path2 user.txt
    onde path1 é o caminho para o arquivo User.dat e path1 é o caminho que contém o arquivo para importar. Por exemplo, se o Windows 95 estiver instalado na pasta Windows na unidade C e você deseja importar o arquivo User.txt da pasta raiz da unidade C, digite:
    regedit /r:c:\windows\user.dat /c c:\user.txt
    Observação : se você receber um "não é possível abrir o registro" ou "Erro ao acessar o registro" mensagem de erro ao tentar importar a parte System.dat do Registro, consulte o seguinte artigo na Base de dados de Conhecimento da Microsoft para obter mais informações sobre a mensagem de erro:
    132064  (http://support.microsoft.com/kb/132064/EN-US/ ) Regedit pode não conseguir importar o registro com chaves grandes
  6. Reinicie o Windows 95.
Para obter informações adicionais sobre como usar o Editor do registro no modo real, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
131352  (http://support.microsoft.com/kb/131352/EN-US/ ) Usando o Editor do registro em modo real
Se o erro continuar a ocorrer após você seguir as etapas nesta seção, consulte a próxima seção.

Usando System.da0

Restaurar o registro ao estado que você iniciou Windows 95 com êxito pela última vez. Para fazer isso, execute estas etapas:
  1. Reinicie o computador. Quando você vir a mensagem "Iniciando o Windows 95", pressione a tecla F8 e selecione modo de segurança somente prompt de comando no menu Iniciar .
  2. Digite o seguinte comando para mover para a pasta do Windows
    cd \ windows
    onde o windows é a pasta Windows 95. Por exemplo, se o Windows 95 estiver instalado na pasta do Windows, digite a seguinte linha:
    \windows do CD
  3. Digite a seguinte linha:
    attrib -s-h-r system.dat
  4. Digite a seguinte linha:
    ren system.dat system.bad
  5. Reinicie o computador. O Windows 95 usa o arquivo System.da0 quando ele não é possível localizar o arquivo System.dat. Se esse arquivo funciona, o Windows 95 o renomeia para System.dat.
Se o erro continuar a ocorrer após você seguir as etapas nesta seção, consulte a próxima seção.

Usando System.1st

Restaurar o registro ao seu estado quando você iniciou pela primeira vez Windows 95 com êxito. Para fazer isso, execute estas etapas:
  1. Reinicie o computador. Quando você vir a mensagem "Iniciando o Windows 95", pressione a tecla F8 e selecione modo de segurança somente prompt de comando no menu Iniciar .
  2. Digite o seguinte comando para mover para a pasta do Windows
    cd \ windows
    onde o windows é a pasta Windows 95. Por exemplo, se o Windows 95 estiver instalado na pasta do Windows, digite a seguinte linha:
    \windows do CD
  3. Digite a seguinte linha:
    attrib -s-h-r system.dat
  4. Digite a seguinte linha:
    ren system.dat system.xxx
  5. Digite a seguinte linha:
    cd \
  6. Digite a seguinte linha:
    attrib -s-h-r system.1st
  7. Digite a seguinte linha
    cópia system.1st c:\ windows \system.dat
    onde o windows é sua pasta Windows 95.
  8. Digite a seguinte linha:
    attrib + s + h + r system.1st
  9. Reinicie o computador.
Se o erro continuar a ocorrer após você seguir as etapas nesta seção, consulte a próxima seção.

Observação : você pode descobrir que as fontes TrueType estão falta da pasta Fonts ou em programas depois de seguir as etapas acima. Para obter informações adicionais sobre como resolver esse comportamento, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
133732  (http://support.microsoft.com/kb/133732/EN-US/ ) Faltam fontes TrueType em fontes de pastas ou programas

Reinstalar o Windows 95

Recrie os arquivos do Registro reinstalando o Windows 95.

Para fazer isso, execute as seguintes etapas.

Observação : se você não puder acessar a unidade de CD-ROM no prompt de comando, consulte documentação da unidade de CD-ROM ou o fabricante para obter assistência com carregar drivers de modo real para a unidade de CD-ROM.
  1. Reinicie o computador. Quando você vir a mensagem "Iniciando o Windows 95", pressione a tecla F8 e, em seguida, selecione Somente Prompt de comando no menu Iniciar .
  2. Digite a seguinte linha e pressione ENTER para remover todos os perfis de usuário:
    ren c:\windows\profiles c:\windows\oldprofiles
  3. Renomeie os arquivos do registro existentes, digitando as seguintes linhas. Pressione ENTER após cada linha:
    \windows do CD
    attrib -s-h-r system.dat
    ren system.dat system.xxx
    attrib -s-h-r user.dat
    ren user.dat user.xxx
    attrib -s-h-r system.da0
    ren system.da0 system.yyy
    attrib -s-h-r user.da0
    ren user.da0 user.yyy
    cd \
    attrib -s-h-r system.1st
    ren system.1st system.zzz
  4. Execute o programa de instalação do Windows 95.
Observação : talvez seja necessário reinstalar programas, especialmente aquelas que gravar no registro, depois de restaurar o backup ou use System.1st para substituir o registro.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 95
Palavras-chave: 
kbmt kbenv kberrmsg kbfaq kbinfo kbtshoot KB131431 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 131431  (http://support.microsoft.com/kb/131431/en-us/ )
Retired KB ArticleAviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store