DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 148942 - Última revisão: quinta-feira, 22 de março de 2007 - Revisão: 7.0

Nesta página

Sumário

O objetivo deste artigo é fornecer as informações necessárias para capturar o tráfego de rede, de uma rede local, usando o Monitor de rede da Microsoft. O texto desse arquivo provém diretamente do arquivo de ajuda do Monitor de rede e deve ser consultado para obter instruções mais detalhadas.

Mais Informações

O Monitor de Rede é uma ferramenta de diagnóstico de rede que monitora as redes locais e fornece uma exibição gráfica das estatísticas da rede. Os administradores de rede podem usar essas estatísticas para realizar tarefas rotineiras para solução de problemas, como localizar um servidor inoperante ou que esteja recebendo um número desproporcional de solicitações de trabalho. Enquanto coleta as informações do fluxo de dados da rede, o Monitor de Rede exibe os seguintes tipos de informações:
  • O endereço de origem do computador que envia um quadro para rede. (Esse endereço é um número hexadecimal único - ou com base em 16 - que identifica esse computador na rede.)
  • O endereço de destino do computador que recebe o quadro.
  • Os protocolos usados para enviar o quadro.
  • Os dados, ou uma parte da mensagem sendo enviada.
O processo pelo qual o Monitor de Rede coleta essas informações é chamado de captura. Por padrão, o Monitor de Rede reúne estatísticas de todos os quadros, que detecta na rede, em um buffer de captura, que é uma área de armazenamento reservada na memória. Para capturar estatísticas em apenas um subgrupo de quadros específicos, você pode defini-los desenvolvendo um filtro de captura. Ao concluir a captura das informações, é possível projetar um filtro de exibição para especificar o quanto dessas informações capturadas serão exibidas na janela de exibição de quadros do Monitor de Rede.

Para usar o Monitor de Rede, o computador deve ter uma placa de captura que ofereça suporte ao modo promíscuo. Se você estiver usando o Monitor de Rede em um computador remoto, a estação de trabalho local não precisará de uma placa de rede que oferece suporte ao modo promíscuo, mas o computador remoto precisará.

Para capturar pelas redes ou para preservar recursos locais, use o Agente do monitor da rede para capturar as informações usando um computador remoto com Windows NT. Ao capturar remotamente, o Agente do monitor da rede reúne as estatísticas do computador remoto e as envia para o computador local, onde são exibidas em uma janela do Monitor de Rede local.

Uma vez que os dados foram capturados local ou remotamente, eles poderão ser salvos em um arquivo de texto ou de captura, e poderão ser abertos e examinados posteriormente.

Observação A funcionalidade de núcleo do Monitor de Rede, descrita na Ajuda, tem suporte do Atendimento Microsoft. As tarefas que dependem da rede, como a interpretação de dados capturados da rede, não recebem suporte. O Agente do monitor da rede recebe suporte para o Windows NT, mas não o recebe para as estações de trabalho do Windows 3.1 e do Windows para Workgroups.

Criando uma lista de endereços

Para usar pares de endereços em um filtro da Captura, é necessário primeiro criar um banco de dados de endereços. Uma vez que esse banco de dados estiver construído, você poderá usar os endereços listados nele para especificar os pares de endereços em um filtro de captura.

Para criar uma lista de endereços, execute as seguintes etapas:
  1. No menu Capturar, selecione Iniciar. Opcionalmente, abra um arquivo .cap na janela do Visualizador de quadros.
  2. Ao concluir a captura, selecione Parar e visualizar no menu Capturar para exibir a janela do Visualizador de quadros.
  3. No menu Exibir, selecione Localizar todos os nomes. O Monitor de Rede processa os quadros e os adiciona ao banco de dados de endereços.
  4. Feche a janela do Visualizador de eventos e exiba a janela de Captura.
  5. No menu Capturar, selecione Filtro para exibir a caixa de diálogo Filtro de captura.
  6. Na caixa de diálogo Filtro de captura, clique duas vezes na linha Pares de endereços. Ou escolha Endereço na caixa de grupo Adicionar.
O Monitor de Rede exibe o banco de dados de endereço criado. É possível usar os nomes desse banco de dados para especificar pares de endereços no Filtro de captura.

Capturando dados entre dois computadores

Para monitorar tráfego entre dois computadores, siga estas etapas:
  1. No menu Capturar, selecione Filtro para exibir a caixa de diálogo Filtro de captura.
  2. Clique duas vezes na linha QUALQUER<->QUALQUER para exibir a caixa de diálogo Expressão de endereço.
  3. Na janela à esquerda da caixa de diálogo Expressão de endereço, selecione o endereço de um computador.
  4. Na janela à direita da caixa de diálogo Expressão de endereço, selecione o endereço de um computador.
Depois, clique no botão Avançar na parte superior da janela para obter mais instruções.
  1. Na janela de Direção da caixa de diálogo, escolha um dos símbolos:
    • Escolha o símbolo <--> para monitorar o tráfego que passa nas duas direções, entre os endereços que você selecionou.
    • Escolha o símbolo --> para monitorar somente o tráfego que passa do endereço selecionado na janela da esquerda para o endereço que passa na janela da direita.
  2. Clique em OK.
  3. Na caixa de diálogo Filtro de captura, clique em OK.
  4. No menu Captura, clique em Iniciar.

Salvando dados capturados

Use o comando Salvar como para salvar estatísticas da captura para um arquivo de captura ou para salvar alterações em arquivos de captura modificados. Posteriormente, para visualizar os quadros salvos no arquivo, é possível abrir esse arquivo e exibir as estatísticas na janela do visualizador de quadros do Monitor de Rede.

Para salvar os quadros capturados em um arquivo de captura ou de texto:
  1. Execute um dos seguintes procedimentos:
    • Na Barra de ferramentas, clique no botão Salvar arquivo .
      -ou-
    • No menu Arquivo, clique em Salvar como.
  2. Execute um dos seguintes procedimentos:
    • Para salvar o arquivo na unidade e diretório atual, na caixa Nome do arquivo, especifique um nome de arquivo e uma extensão. Se você estiver salvando um arquivo que você modificou, não será possível salvá-lo com seu nome original no mesmo diretório.
    • Para salvar o arquivo em um compartilhamento de rede no qual você não está conectado, clique no botão Rede e use a caixa de diálogo Mapear unidade de rede para estabelecer a conexão.
    • Para salvar o arquivo em uma unidade ou diretório diferente, faça o seguinte:
      1. Na caixa Unidade, clique em uma letra de unidade.
      2. Na caixa Diretório, selecione um novo diretório.
      3. Digite o nome do arquivo.
  3. Para salvar somente as estatísticas que atendam às especificações do filtro de exibição atual, escolha Filtrado.

    Essa opção estará disponível somente se você estiver salvando os dados pela janela do Visualizador de quadros.
  4. Para salvar um intervalo de quadros determinado, digite os números dos quadros inicial e final nas caixas De e Para.
  5. Clique em OK.
Observação Quando uma faixa de quadros é salva em um arquivo de captura, os números associados com os quadros são alterados; em um arquivo de captura, números de quadro sempre começam com o algarismo 1, independentemente do número associado ao quadro original. Da mesma maneira, se você aplicar um filtro de exibição e salvar os quadros filtrados, os números dos quadros no arquivo de captura irão começar com 1. Se, entretanto, você usar a opção Imprimir em arquivo na caixa de diálogo Imprimir, os números dos quadros originais associados aos quadros são preservados.

Configurações do tamanho do buffer

O tamanho do buffer padrão é 1 MB. Para aumentar o tamanho do buffer e não perder informações, siga estas etapas:
  1. Clique em Capturar e em Configurações do buffer.
  2. Aumente o valor da definição Tamanho do buffer (MB) e clique em OK.

Rastreando em um ambiente WAN

Algumas vezes, pode lhe ser solicitada a captura de tráfego de rede entre dois computadores específicos separados por um ou mais roteadores. Nesses casos, o profissional de suporte pode querer todo o tráfego de rede entre o primeiro computador e seu roteador mais próximo, e todo o tráfego de rede entre o segundo roteador e seu roteador mais próximo. Na maioria das vezes, isso é feito para verificar se os pacotes de rede estão sendo perdidos ou corrompidos em algum lugar entre os roteadores. Para tornar esses rastreamentos consistentes e ser capaz de lê-los simultaneamente, os relógios dos sistemas devem estar sincronizados entre os dois computadores antes de fazer o rastreamento. Execute as etapas a seguir para sincronizar o horário entre os dois computadores:
  1. Escolha o computador com o qual irá sincronizar o horário.
  2. No outro computador, digite o comando
    net time \\Nome_do_computador /set /yes
    no qual Nome_do_computador é o nome do computador da etapa 1.
  3. Verifique se os computadores possuem o mesmo horário digitando TIME em cada um.
  4. Prossiga com o rastreamento.

Localizando endereços de controle de acesso de mídia

Se o computador a ser monitorado estiver executando:
  • Um cliente de rede com base no MS-DOS, execute o MSD nesse computador.
  • O Windows para Workgroups 3.11 (executando TCP/IP), digite IPCONFIG /ALL na linha de comando.
  • O Windows 95, execute WINIPCFG pela linha de comando na estação de trabalho local.
  • O MacOS, abra o painel de controle Appletalk. Selecione User Mode no menu Edit, altere o modo para Advanced. O painel de controle Appletalk revela agora o botão Info. Clique nesse botão para obter o endereço MAC
  • O Windows NT, no console local, use uma das seguintes opções:
    • NET CONFIG SERVER pela linha de comando
    • IPCONFIG /ALL pela linha de comando
    • IPXROUTE config pela linha de comando
    • arp -a pela linha de comando
    • Getmac.exe pelo Windows NT Resource Kit
    • WinMSD
  • O Windows NT, remotamente, executa o Getmac.exe pelo Windows NT Resource Kit

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft SNA Server 2.1
  • Microsoft SNA Server 3.0
  • Microsoft LAN Manager to Windows NT Advanced Server Upgrade
  • Microsoft Systems Management Server 1.0 Standard Edition
  • Microsoft Systems Management Server 1.1 Standard Edition
  • Microsoft Systems Management Server 1.2 Standard Edition
  • Microsoft LAN Manager 2.2c
  • Microsoft TCP/IP para Windows para Workgroups 3.11
  • Microsoft TCP/IP para Windows para Workgroups 3.11a
  • Microsoft TCP/IP para Windows para Workgroups 3.11b
  • Microsoft Windows for Workgroups 3.11
  • Microsoft Internet Information Server 1.0
  • Microsoft Host Integration Server 2000 Standard Edition
Palavras-chave: 
kbhowto KB148942
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store