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ID do artigo: 164486 - Última revisão: quarta-feira, 1 de novembro de 2006 - Revisão: 1.2

 
Importante: Este artigo contém informações sobre a edição do Registro. Antes de editar o registro, verifique se que você sabe como restaurá-lo se ocorrer um problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurando o registro" no Regedit.exe ou o tópico da Ajuda "Restaurando uma chave do Registro" no Regedt32.exe.

Sintomas

Empresas de terceiros podem substituir o arquivo GINA.dll que vem com o Windows NT, editando a seguinte chave do Registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon Value = GinaDLL REG_SZ

Se o arquivo referenciado no registro está ausente ou corrompido, Winlogon não for iniciado e uma mensagem de erro de tela azul ocorre.

Observação: o Windows NT 3.51 carrega Msgina.dll se o arquivo GINA.dll de terceiros não for encontrado.

Causa

Windows NT 4.0 foi projetado para não carregar se GINA.dll (ou sua substituição) não estiver presente.

Resolução

Para resolver esse problema, substitua GINA.dll ausente ou corrompido com a versão que acompanha o Windows NT.

Aviso: Usar o Editor do Registro incorretamente pode causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que problemas resultantes do uso incorreto do Editor do Registro possam ser resolvidos. Use o Editor do registro por sua própria conta e risco.

Para obter informações sobre como editar o registro, consulte o tópico da Ajuda "Alterando chaves e valores" no Editor do Registro (Regedit.exe) ou tópicos de Ajuda "Adicionar e excluir informações no Registro" e "Editar dados de registro" no Regedt32.exe. Observe que você deve fazer backup do registro antes de editá-lo.

Se o Windows NT é instalado em uma partição FAT, copie o arquivo software que está localizado no diretório %SystemRoot%\System32\Config para um disquete e levá-la para outro computador que esteja executando o Windows NT, siga estas instruções:
  1. Inicie o Editor do Registro (Regedt32.exe).
  2. Vá para a janela HKEY_LOCAL_MACHINE.
  3. Selecione a entrada de chave HKEY_LOCAL_MACHINE.
  4. No menu Registro, clique em Carregar seção.
  5. Procurar e selecionar o falha Windows NT caminho de instalação, por exemplo, Winnt.
  6. Vá para o diretório System32\Config e selecione o arquivo de software.

    Observação: Arquivo software sem extensão é o correto.
  7. Clique em OK e digite um nome de chave de teste.
  8. Clique duas vezes a nova chave de teste e execute esse caminho:
    Microsoft\Windows NT\Current Version\Winlogon
  9. Modificar a entrada Ginadll:REG_SZ:MSGINA.DLL
  10. No menu Registro, clique em Descarregar seção.
  11. Reiniciar na instalação original do Windows NT.

Mais Informações

A Microsoft recomenda que empresas de terceiros usam volumes FAT para testar suas versões do GINA.dll. Isso facilita a substituição do novo arquivo GINA.dll.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
Palavras-chave: 
kbmt kbprb KB164486 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 164486  (http://support.microsoft.com/kb/164486/en-us/ )
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