DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 2262911 - Última revisão: sexta-feira, 29 de novembro de 2013 - Revisão: 7.0

Sintomas

Após a instalação da atualização 982167 ou 982168, talvez uma mensagem de erro de exceção semelhante à seguinte seja exibida quando você executar aplicativos com base no Windows Communication Foundation:
Não foi possível carregar o tipo 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'

Causa

A atualização 982167 e a atualização 982168 atualizam a camada de recurso do .NET Framework 2.0 no .NET Framework 3.5 SP1 para apresentar o novo tipo "System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy". Esse novo tipo é usado pelo novo recurso correspondente no Windows Communication Foundation.

O erro ocorre porque a camada de recursos da Biblioteca de Cliente de Rede do .NET Framework 2.0 SP2 não é atualizada quando a camada de recursos do Windows Communication Foundation é atualizada para usar o novo tipo. A camada de recursos subjacente da Biblioteca de Cliente de Rede do .NET Framework 2.0 SP2 não oferece suporte a esse novo tipo, e esse erro é acionado.

Esse cenário pode ocorrer por vários motivos, incluindo determinados problemas de falha de instalação relacionados a serviços de ramificação dupla. Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
960043  (http://support.microsoft.com/kb/960043/pt-br/ ) Serviços de ramificação dupla para o .NET Framework 2.0 Service Pack 2, o .NET Framework 3.0 Service Pack 2 e o .NET Framework 3.5 Service Pack 1

Como Contornar

Como solução alternativa para esse problema, siga estas etapas:
  1. Instale o hotfix 975954. Para fazer download das atualizações MSI, visite a seguinte página da Web do MSDN:
    http://code.msdn.microsoft.com/KB975954/Release/ProjectReleases.aspx?ReleaseId=3839 (http://code.msdn.microsoft.com/KB975954/Release/ProjectReleases.aspx?ReleaseId=3839)
  2. Execute um reparo do produto. Podemos reparar o produto automaticamente ou você pode fazê-lo por conta própria.

    Corrigir para mim

    Para executar um reparo no produto automaticamente, clique no link  Corrigir este problema. Em seguida, clique em Executar na caixa de diálogo Download de Arquivo e siga as etapas descritas neste assistente.
    Recolher esta imagemExpandir esta imagem
    Corrigir este problema (http://go.microsoft.com/?linkid=9737836)
    Microsoft Fix it 50468
    Recolher esta imagemExpandir esta imagem

    Observação Este assistente está disponível temporariamente apenas em inglês. No entanto, a correção automática também funciona para outras versões de idioma do Windows.

    Observação Se o computador que você está usando não apresentar o problema, você poderá salvar a correção automática em uma unidade flash ou em um CD para que possa executá-la no computador com o problema.

    Desejo corrigir sozinho

    Para reparar o produto por conta própria, digite o comando a seguir em um prompt de comandos com privilégios elevados:
    msiexec /f {C09FB3CD-3D0C-3F2D-899A-6A1D67F2073F}

    Isso faz com que todos os recursos do produto do .NET Framework 2.0 SP2 reavaliem o seu estado de instalação.
    Isso resolve o problema e permite que a atualização 982167 ou 982168 aplique sua respectiva carga.
Observação Se as etapas 1 e 2 não funcionarem, tente desinstalar a atualização que você instalou antes de perceber o erro e reinstale-a em seguida.

Situação

A Microsoft confirmou que esse problema ocorre nos produtos que estão listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre como executar um comando com privilégios elevados, visite a seguinte página da Web da Microsoft:
http://windows.microsoft.com/pt-BR/windows7/Command-Prompt-frequently-asked-questions (http://windows.microsoft.com/pt-BR/windows7/Command-Prompt-frequently-asked-questions)
Para obter mais informações sobre as opções de linha de comando com suporte no Windows Installer, visite a seguinte página do MSDN:
http://msdn.microsoft.com/pt-br/library/aa367988(VS.85).aspx (http://msdn.microsoft.com/pt-br/library/aa367988(VS.85).aspx)
Para obter mais informações sobre o Windows Installer, visite a seguinte página da Web do MSDN:
http://msdn.microsoft.com/pt-br/library/aa367449(VS.85).aspx (http://msdn.microsoft.com/pt-br/library/aa367449(VS.85).aspx)

A informação contida neste artigo aplica-se a:
  • Microsoft .NET Framework 3.5 Service Pack 1
  • Microsoft .NET Framework 2.0 Service Pack 2
  • Microsoft Windows Server 2003 Service Pack 2 nas seguintes plataformas
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Service Pack 2 nas seguintes plataformas
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Palavras-chave: 
kbbug kbexpertiseinter kbinfo kbsecurity kbmsifixme kbfixme KB2262911
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store