DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 280504 - Última revisão: quinta-feira, 15 de março de 2012 - Revisão: 4.0

Nesta página

Sumário

Vários motivos podem causar problemas ao iniciar o Microsoft Excel. Este artigo discute como identificar a causa do problema de inicialização e apresenta soluções possíveis para corrigi-lo. Este artigo também contém links para outros artigos da Base de Dados de Conhecimento Microsoft que discutem problemas de inicialização mais detalhadamente.

Observação É importante acompanhar qualquer nova instalação de software ou atualizações realizadas imediatamente antes da ocorrência do problema, pois elas podem estar diretamente relacionadas. Essas informações são úteis se este artigo não resolver o problema e você precisar contatar o Suporte Técnico da Microsoft.

Mais Informações

Quando você iniciar o Microsoft Excel, podem ocorrer problemas devido a qualquer um dos seguintes motivos:
  • Atalho corrompido para o programa Excel
  • Arquivo problemático na pasta de inicialização ou no local alternativo do arquivo de inicialização do Excel
  • Conflito com outro programa
  • Versão incorreta de um arquivo básico do Microsoft Office
  • Arquivo da barra de ferramentas do Excel (*.xlb) ou arquivo .pip do Excel corrompido
  • Suplementos corrompidos no menu Ferramentas
  • Chaves de Registro corrompidas
  • Outros problemas ao abrir arquivos do Excel
Se você receber uma mensagem de erro quando iniciar o Microsoft Excel, pesquise a mensagem exata na Base de Dados de Conhecimento Microsoft no seguinte site da Microsoft:
http://support.microsoft.com/search/?ln=pt-br (http://support.microsoft.com/search/?ln=pt-br)
Se você não receber nenhuma mensagem de erro ou se não encontrar informações específicas na Base de Dados de Conhecimento Microsoft sobre a mensagem de erro, use as informações a seguir para solucionar o problema de inicialização do Excel.

Primeiro, considere o escopo do problema. O problema ocorra quando você inicia o Excel clicando em um arquivo de pasta de trabalho ou ele ocorre quando você executa o Excel a partir do menu Iniciar?

Se o problema somente ocorrer quando você abrir um arquivo do Excel, consulte a seção "Outros problemas ao abrir arquivos do Excel". Caso contrário, vá para a próxima seção.

Atalho corrompido para o programa Excel

Se o problema ocorrer apenas quando você inicia o programa Excel, execute as seguintes etapas:
  1. Clique em Iniciar, aponte para Pesquisar e clique em Todos os Arquivos e Pastas.
  2. Na caixa Procurar pastas ou arquivos denominados, digite Excel.exe.
  3. Na lista Examinar, clique em Meu Computador e em Pesquisar Agora.
  4. Depois que o arquivo Excel.exe for encontrado, clique duas vezes nele para iniciar o Microsoft Excel.

    Observação A localização comum do arquivo Excel.exe depende da versão instalada.

    Microsoft Office Excel 2003

    C:\Program Files\Microsoft Office\Office11

    Microsoft Excel 2002

    C:\Program Files\Microsoft Office\Office10

    Microsoft Excel 2000

    C:\Program Files\Microsoft Office\Office

    Microsoft Office Excel 2007

    C:\Program Files\Microsoft Office\Office12

    Microsoft Office Excel 2010

    C:\Program Files\Microsoft Office\Office14


Se o Excel iniciar como esperado, o problema pode ter ocorrido devido a um atalho corrompido para o programa. Para resolver esse problema, crie um novo atalho para o programa Excel que possa ser usado para iniciar o Excel.

Se o Excel não iniciar como esperado, execute as etapas para executar o Excel no modo de segurança.

Para que possamos criar o atalho para você, vá para a seção "Corrigir para mim".

Corrigir para mim



Para corrigir esse problema automaticamente, clique no botão ou link Fix it. Clique em Executar na caixa de diálogo Download de Arquivo e siga as etapas descritas no Assistente de correção.


Corrigir este problema
Microsoft Fix it 50268


Observação Esse assistente pode estar apenas em inglês, mas a correção automática também funciona para versões do Windows em outros idiomas.

Observação Se o computador que você está usando não apresentar o problema, será possível salvar a correção automática em uma unidade flash ou em um CD para executá-la posteriormente no computador com esse problema.

Em seguida, vá para a seção "O problema foi corrigido?".


Isso corrigiu o problema?

Verifique se o problemas está corrigido. Se o problema foi corrigido, você concluiu esta seção. Se o problema não for corrigido, você pode contatar o suporte (http://support.microsoft.com/contactus/?ln=pt-br#tab0) .

Iniciar o Excel no modo de segurança

Para que possamos iniciar o Excel no modo de segurança para você, vá para a seção "Iniciar para mim". Se você preferir iniciar o Excel sozinho, vá para a seção "Desejo iniciar sozinho".

Iniciar para mim



Para iniciar o Excel no modo de segurança automaticamente, clique no botão ou no link Corrigir. Clique em Executar na caixa de diálogo Download de Arquivo e siga as etapas descritas no Assistente de correção.


Corrigir este problema
Microsoft Fix it 50270


Observação Esse assistente pode estar apenas em inglês, mas a correção automática também funciona para versões do Windows em outros idiomas.

Observação Se o computador que você está usando não apresentar o problema, será possível salvar a correção automática em uma unidade flash ou em um CD para executá-la posteriormente no computador com esse problema.

Em seguida, vá para a seção "O problema foi corrigido?".



Desejo iniciar sozinho

  1. Clique em Iniciar e em Executar.
  2. Clique em Procurar e localize a pasta em que o Microsoft Excel está instalado, conforme especificado anteriormente neste artigo.
  3. Depois de localizar o arquivo Excel.exe, clique no arquivo para selecioná-lo e em Abrir.
  4. No final do caminho da caixa Abrir, digite um espaço e /s para que a linha inteira fique similar a isto:
    "C:\Arquivos de Programas\Microsoft Office\Office\Excel.exe" /s


Isso corrigiu o problema?

Verifique se o Excel foi iniciado no modo de segurança. Se o Excel tiver sido iniciado no modo de segurança, esta seção foi concluída. Se o Excel não foi iniciado no modo de segurança, contate o suporte (http://support.microsoft.com/contactus/?ln=pt-br#tab0) . Se o Excel iniciar como esperado, consulte a seção "Outras soluções de problemas" posteriormente neste artigo para obter mais informações.

Se o Excel ainda não iniciar como esperado, pode haver um conflito com outro programa. Tente reiniciar o Windows no modo de segurança e execute as etapas anteriores novamente para executar o Excel no modo de segurança.

Para obter mais informações sobre como iniciar o Windows no Modo de segurança, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
156126  (http://support.microsoft.com/kb/156126/pt-br/ ) Solução de problemas do Windows 95 usando o modo de segurança
192926  (http://support.microsoft.com/kb/192926/pt-br/ ) Como realizar uma solução de problemas de inicialização simples no Windows 98
267288  (http://support.microsoft.com/kb/267288/pt-br/ ) Como executar uma inicialização simples no Windows Millennium Edition (Me)
266169  (http://support.microsoft.com/kb/266169/pt-br/ ) Como solucionar problemas com o modo de espera, com o modo de hibernação e com o encerramento do computador no Windows 2000
281770  (http://support.microsoft.com/kb/281770/pt-br/ ) Como realizar uma solução de problemas de inicialização simples no Windows 2000

O Excel não inicia no modo de segurança e o Windows está o modo de segurança

Se o Excel não iniciar quando você usar a opção /s e o Windows estiver executando no modo de segurança, remova o Microsoft Office (ou o Microsoft Excel autônomo) usando o ícone Adicionar/Remover Programas no Painel de Controle. Consulte a documentação do Windows para obter mais informações.

Essa etapa pode ser necessária porque quando você executa o Windows e o Excel no modo de segurança, o Excel fica no estado mais básico exigido para iniciar o programa. Isso significa que nenhum outro programa ou arquivo está envolvido no processo de inicialização do Excel. Sendo assim, o problema deve ser devido a um arquivo corrompido do Office que o Excel usa para iniciar. Se você remover e reinstalar o Office (ou o Excel autônomo), isso deverá solucionar o problema.

Para obter mais informações sobre um problema relacionado a arquivos incompatíveis do Office 2000, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
217440  (http://support.microsoft.com/kb/217440/pt-br/ ) Você recebe mensagens de erro quando inicia programas do Office 2000
Se esse artigo não ajudar ou se reiniciar o Windows no modo de segurança resolver o problema de inicialização do Excel, consulte a seção "Outras soluções de problemas" para obter mais informações.

Outras soluções de problemas

O Excel inicia quando você usa a opção /s

Se o Microsoft Excel iniciar como esperado quando você usar a opção /s, "Modo de Segurança" aparecerá na barra de título do Excel. Isso indica que o Microsoft Excel está executando como se fosse a primeira vez após a instalação inicial.

Agora que você iniciou o Excel, use um processo de eliminação para prosseguir pelas áreas a seguir ignoradas pelo Excel no modo de segurança até que o problema seja corrigido.

Pastas de inicialização do Excel

Um dos motivos mais comuns que causam problemas quando você inicia o Excel é que o Excel está carregando um arquivo com problemas a partir de uma de suas diversas pastas de inicialização.

Observação A pasta XLStart também pode estar em outros perfis. Ela também pode estar redirecionada em um servidor em algumas instâncias.

240150  (http://support.microsoft.com/kb/240150/pt-br/ ) Como usar as pastas de inicialização do Excel no Excel 2000
291218  (http://support.microsoft.com/kb/291218/pt-br/ ) Como usar as pastas de inicialização do Excel no Excel 2002
822107  (http://support.microsoft.com/kb/822107/pt-br/ ) Como usar pastas de inicialização no Excel


Arquivo da barra de ferramentas do Excel


Ocasionalmente, o arquivo da barra de ferramentas do Excel pode ser corrompido. Se isso ocorrer, podem ocorrer problemas ao iniciar o Excel. Nessa situação, localize o arquivo da barra de ferramentas e o renomeie. Depois de renomear o arquivo da barra de ferramentas, o Excel recriará um novo arquivo da barra de ferramentas da próxima vez que você iniciar o Excel.

Por exemplo, se o nome do arquivo da barra de ferramentas for JonasUsuario8.xlb, renomeie o arquivo para JonasUsuario8.antigo. Em seguida, inicie o Excel e observe que o Excel cria um novo arquivo JonasUsuario8.xlb no mesmo local que o arquivo da barra de ferramentas original.

Para obter mais informações sobre o arquivo da barra de ferramentas do Excel e como identificá-lo, clique nos números abaixo para ler os artigos da Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
291074  (http://support.microsoft.com/kb/291074/pt-br/ ) Barras de ferramentas e botões da barra de ferramentas padrão vistos e não as personalizações no Excel
Para obter mais informações sobre outro problema da barra de ferramentas ao iniciar o Excel, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
215366  (http://support.microsoft.com/kb/215366/pt-br/ ) Falha de página ao iniciar o Excel dom o comando de menu Quebra de Página
Arquivo Excel.pip

O Excel lembra os menus e comandos usados e exibe esses menus mais recentemente usados primeiro. O Excel oculta os comandos não utilizados nos menus expansíveis. O Excel armazena esses dados de utilização junto com as configurações de animação do menu em um arquivo chamado Excel.pip.

Esse arquivo pode ser corrompido. Se isso ocorrer, podem ocorrer problemas ao iniciar o Excel. Nessa situação, localize o arquivo Excel.pip e o renomeie. Depois de renomear o arquivo, o Excel recriará um novo arquivo .pip da próxima vez que você iniciar o Excel. Use o recurso de pesquisa do Windows para localizar o arquivo Excel.pip.

O Excel inicia quando o Windows está no modo de segurança

Se o problema de inicialização do Excel não ocorrer mais quando o Windows estiver no modo de segurança, algum outro programa está causando o problema no processo de inicialização do Excel.

Use um processo de eliminação para determinar exatamente o programa que está causando o problema. Se não souber como fazer isso, contate o fornecedor do Windows para obter mais informações sobre como eliminar cada programa individual carregado na inicialização do Windows.

Para obter informações adicionais sobre como solucionar o problema de inicialização do Windows, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento da Microsoft:
281965  (http://support.microsoft.com/kb/281965/pt-br/ ) Como solucionar um problema usando o utilitário Msconfig com o Windows 98
281995  (http://support.microsoft.com/kb/281995/pt-br/ ) Como solucionar um problema usando o utilitário Msconfig no Windows Millennium Edition
281770  (http://support.microsoft.com/kb/281770/pt-br/ ) Como realizar uma solução de problemas de inicialização simples no Windows 2000
310353  (http://support.microsoft.com/kb/310353/pt-br/ ) Como configurar o Windows XP para iniciar no estado "inicialização simples"

Suplementos corrompidos no menu Ferramentas

No menu Ferramentas, clique em Suplementos. Clique para desmarcar as caixas de seleção referentes aos suplementos selecionados e em OK.

Excluir as chaves do Registro dos suplementos COM

É possível instalar suplementos COM em qualquer local. Programas que interagem com o Excel instalam suplementos COM. Para resolver problemas que podem ocorrer com o Excel, exclua as chaves do Registro dos suplementos COM e reinicie o Excel.

Para que possamos excluir as chaves do Registro dos suplementos COM para você, vá para a seção "Excluir para mim". Se você preferir excluir as chaves do Registro dos suplementos COM sozinho, vá para a seção "Desejo excluir sozinho".

Excluir para mim



Para excluir as chaves do Registro dos suplementos COM automaticamente, clique no botão ou no link Corrigir. Clique em Executar na caixa de diálogo Download de Arquivo e siga as etapas descritas no Assistente de correção.


Corrigir este problema
Microsoft Fix it 50269


Para adicionar as chaves do Registro dos suplementos COM automaticamente, clique no botão ou no link Corrigir. Clique em Executar na caixa de diálogo Download de Arquivo e siga as etapas descritas no Assistente de correção.


Corrigir este problema
Microsoft Fix it 50272

Observação Esta solução Corrigir funciona em todos os idiomas. No entanto, em alguns idiomas, o texto do assistente pode estar em inglês.

Observação Se o computador que você está usando não apresentar o problema, salve a solução de correção em uma unidade flash ou em um CD para executá-la no computador com o problema.

Em seguida, vá para a seção "O problema foi corrigido?".



Quero excluir sozinho

Importante Esta seção, este método ou esta tarefa contém etapas que descrevem como modificar o Registro. No entanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Sendo assim, siga as etapas cuidadosamente. Por precaução, faça um backup do Registro antes de modificá-lo. Dessa forma, se ocorrer algum problema, você poderá restaurar o Registro. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:
322756  (http://support.microsoft.com/kb/322756/pt-br/ ) Como fazer backup e restaurar o Registro no Windows
Para excluir manualmente as chaves do Registro dos suplementos COM, siga estas etapas:
  1. Feche todos os programas do Office.
  2. Clique em Iniciar, clique em Executar, digite regedit e clique em OK.
  3. Localize a seguinte subchave do Registro:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\AddIns
  4. Clique em Suplementos e em Exportar no menu Arquivo.
  5. Nomeie o arquivo como "XLaddinHKCU.reg" e salve-o na área de trabalho.
  6. Selecione a subchave Suplementos, clique em Excluir no menu Editar e clique em Sim.
  7. Localize a seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Excel\Addins

    Observação: Se estiver usando um Office de 64 bits (somente 2010)
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Excel\Addins
  8. Clique em Suplementos e em Exportar no menu Arquivo.
  9. Nomeie o arquivo como "XLaddinHKLM.reg" e salve-o na área de trabalho.
  10. Selecione a subchave Suplementos, clique em Excluir no menu Editar e clique em Sim.
  11. Saia do Editor do Registro.
  12. Inicie o Excel.
Se o problema foi resolvido, um programa de suplemento COM estava causando o problema. Você pode examinar as chaves do Registro em Suplementos no Editor do Registro para determinar o fabricante do suplemento. Em seguida, você pode contatar o fabricante para obter atualizações.

Isso corrigiu o problema?

Verifique se o problema está corrigido. Se o problema foi corrigido, você concluiu esta seção. Se o problema não foi corrigido, contate o suporte (http://support.microsoft.com/contactus/?ln=pt-br#tab0) .

Chaves de Registro corrompidas

Saia do Excel e renomeie as chaves do Registro a seguir. Por exemplo, renomeie excel como excel.antigo. Quando você iniciar o Excel novamente, ele acionará um reparo para definir as configurações com os padrões.

Você pode remover algumas chaves do Registro para redefinir configurações de usuário personalizadas para os seus programas do Microsoft Office.


Para podermos redefinir as configurações de usuário personalizadas para você, vá para a seção "Redefinir para mim". Se você preferir redefinir as configurações de usuário personalizadas sozinho, vá para a seção "Desejo redefinir sozinho".

Redefinir para mim



Para redefinir as configurações de usuário personalizadas automaticamente, clique no botão ou no link Corrigir. Clique em Executar na caixa de diálogo Download de Arquivo e siga as etapas descritas no Assistente de correção.
Recolher esta tabelaExpandir esta tabela
Remover todas as chaves do Registro personalizadas do ExcelSubstituir as chaves do Registro personalizadas do Excel anteriormente removidas
Corrigir este problema
Microsoft Fix it 50274
Corrigir este problema
Microsoft Fix it 50275

Observação Esse assistente pode estar apenas em inglês, mas a correção automática também funciona para versões do Windows em outros idiomas.

Observação Se o computador que você está usando não apresentar o problema, será possível salvar a correção automática em uma unidade flash ou em um CD para executá-la posteriormente no computador com esse problema.

Em seguida, vá para a seção "O problema foi corrigido?".



Desejo redefinir sozinho

Importante Esta seção, este método ou esta tarefa contém etapas que descrevem como modificar o Registro. No entanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Sendo assim, siga as etapas cuidadosamente. Por precaução, faça um backup do Registro antes de modificá-lo. Dessa forma, se ocorrer algum problema, você poderá restaurar o Registro. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:
322756  (http://support.microsoft.com/kb/322756/pt-br/ ) Como fazer backup e restaurar o Registro no Windows
Observação A remoção das chaves do Registro a seguir podem redefinir as configurações de usuário personalizadas para os seus programas do Microsoft Office.

Excel 2003

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel
HKEY_LOCAL_MACHINE\Software\Microsoft\Office\11.0\Excel

Excel 2002

HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Excel
HKEY_LOCAL_MACHINE\Software\Microsoft\Office\10.0\Excel

Excel 2000

HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Excel
HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Excel
Quando você reinicia o Excel, uma operação de reparo é acionada para definir as configurações com os padrões.

Excel 2007

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Excel HKEY_LOCAL_MACHINE\Software\Microsoft\Office\12.0\Excel
 

Excel 2010

HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel HKEY_LOCAL_MACHINE\Software\Microsoft\Office\14.0\Excel 

Se esse procedimento não resolver o problema, você poderá restaurar as configurações originais. Para fazer isso, execute as seguintes etapas:
  1. Saia do Excel.
  2. Exclua as chaves do Registro do Excel recentemente criadas.
  3. Renomeie as chaves "Excel.antigo" como "Excel".

Isso corrigiu o problema?

Verifique se o problema está corrigido. Se o problema foi corrigido, você concluiu esta seção. Se o problema não for corrigido, você pode contate o suporte (http://support.microsoft.com/contactus/?ln=pt-br#tab0) .

Outros problemas ao abrir arquivos do Excel

Se houver problemas no Excel somente quando você abrir arquivos específicos do Excel, use uma abordagem diferente para solucionar o problema. Pode ser necessário executar procedimentos desde a desabilitação de macros até a recriação da pasta de trabalho.

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento da Microsoft (alguns artigos podem estar inglês):
820741  (http://support.microsoft.com/kb/820741/ ) Como recuperar dados de pastas de trabalho corrompidas no Excel 2002 e no Excel 2003 (Pode estar em inglês)
179871  (http://support.microsoft.com/kb/179871/pt-br/ ) Métodos de recuperação de dados de pastas de trabalho do Excel 2000 danificadas
213951  (http://support.microsoft.com/kb/213951/pt-br/ ) Como solucionar a origem do problema quando você salva arquivos no Excel 2000 e eles são corrompidos

Referências


Agradecemos ao MVP Jan Karel Pieterse (https://mvp.support.microsoft.com/profile=18E4F087-9E1D-481C-9A93-512C78964B5F) pela contribuição às soluções Corrigir contidas neste artigo.

Para obter informações adicionais sobre pastas de inicialização, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft:
822107  (http://support.microsoft.com/kb/822107/pt-br/ ) Como usar pastas de inicialização no Excel 2003
291218  (http://support.microsoft.com/kb/291218/pt-br/ ) Como usar as pastas de inicialização do Excel no Excel 2002
240150  (http://support.microsoft.com/kb/240150/pt-br/ ) Como usar as pastas de inicialização do Excel no Excel 2000
Para obter informações adicionais sobre o Modo de Segurança do Excel 2002, clique em Ajuda do Microsoft Excel no menu Ajuda, digite sobre o modo de segurança do office no Assistente do Office ou no Assistente de Resposta e clique em Pesquisar para exibir os tópicos retornados.

A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Office Excel Viewer 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2010
Palavras-chave: 
kbmsifixme kbfixme kbstartprogram kbtshoot kbhowto KB280504
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store