DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 291824 - Última revisão: quarta-feira, 31 de janeiro de 2007 - Revisão: 3.3

 
Para uma versão deste artigo do Microsoft Word 98, consulte 181080  (http://support.microsoft.com/kb/181080/ ) .

Nesta página

Sumário

Este artigo descreve o que são vírus de macro, o que fazer se você achar que o computador pode ter um vírus de macro do Word e como garantir que seus documentos não ficar infectados com um vírus de macro.

Mais Informações

O primeiro vírus de macro foi descoberto no segundo semestre de 1995. Desde então, apareceu outros vírus de macro.

Um vírus de macro é um programa mal-intencionado que está escrito usando a linguagem de macro de um programa, como o Word. O vírus se propaga próprio entre arquivos de dados e pode prejudicar o sistema operacional do seu computador ou seus arquivos.

Vírus de macro do Word não livremente viajar pela Internet ou qualquer outra mídia; eles podem ser transferidos somente quando um usuário abre um documento ou modelo que contém a macro de vírus.

Vírus de macro não podem ser transferidos por email, a menos que um documento afetado é incorporado na mensagem de email e o destinatário abre o documento.

Sintomas de um vírus de macro

A seguir estão alguns sintomas de vírus de macro do Word que afetam o Word e o Word documentos:
  • Quando você tentar salvar um documento, Word somente permite que você salve o documento como um modelo.

    - ou -
  • O ícone para o arquivo se parece com um modelo em vez de um documento.

    - ou -
  • Quando você abre um documento, uma caixa de diálogo mostrando o número 1 é exibida.

    - ou -
  • Os comandos de macro e Personalizar não exibido no menu Ferramentas .

    - ou -
  • Novas macros aparecem na lista de macros. As macros AutoOpen e FileSaveAs podem também aparecem; se você já tivesse macros por esses nomes, seu conteúdo pode ser modificado por vírus de macro.

    - ou -
  • Mensagens incomuns ou inesperadas são exibidas quando você abre um documento do Word ou modelo.
anotações
  • No Word 2001 para Mac, você pode definir a opção de Proteção contra vírus de macro (no menu Editar , clique em Preferências e, em seguida, clique na guia Geral ) que foi criado para notificá-lo se você abrir um arquivo que contém macros, independentemente do que fazer as macros. No Word X para Mac, você pode definir a opção de Proteção contra vírus de macro clicando em Preferências no menu de Word , clicando na guia Geral e, em seguida, clicando na opção de Proteção contra vírus de macro ativá-lo ou desativar. No Word 2004 para Mac, você pode definir a opção de Proteção contra vírus de macro clicando em Preferências no menu de Word , clicando na guia segurança e, em seguida, clicando na opção de Proteção contra vírus de macro ativá-lo ou desativar. Para uma solução permanente, você deve usar software antivírus que está especificamente projetado para detectar e impedir que vírus de macro.
  • Word não procurar vírus de macro ou remova quaisquer vírus de macro do modelos e documentos existentes. Ele apenas avisa se o documento que você está abrindo contém macros. Em seguida, você pode abrir o documento com as macros ativas ou abri-lo com as macros desativadas. Você não deve abrir um documento com macros ativo, a menos que você seja absoluta certeza de que o documento não contém nenhum vírus de macro prejudiciais.
  • Programas antivírus de terceiros devem ser atualizados com freqüência para permanecerem eficazes. Contate o fornecedor para informações de atualização.
  • Disinfectant, um utilitário antivírus freeware para Mac OS 9 e versões anteriores, não ajuda a proteger contra vírus de macro. Desenvolvimento no programa Disinfectant foi descontinuado. A versão final do Disinfectant é a versão 3.7.1.

    Para links para um software antivírus atualizado, visite os links que estão na próxima seção. AntiVirus ’s Norton, Symantec e Sophos, ambos criados para Mac OS X, ambos verificará se há vírus de macro.

Instalar um programa antivírus

Para uma solução a longo prazo para vírus de macro, instale software antivírus que foi especificamente projetado para detectar vírus de macro. Para obter informações adicionais sobre fornecedores de software antivírus, incluindo software capaz de detectar e evitando vírus de macro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
49500  (http://support.microsoft.com/kb/49500/ ) Lista de fornecedores de software antivírus
A Microsoft fornece terceiros informações de contatos para ajudá-lo a encontrar suporte técnico. Essa informações de contatos podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações contatos de terceiros.

O que fazer quando você acha que seu computador pode ser que um vírus de macro

Use os seguintes métodos como soluções temporárias somente quando você acha que seu computador podem ter um vírus de macro.

Método 1: Desativar as macros e copie o texto para um novo documento

Se você não experimentar qualquer um dos sintomas descritos anteriormente neste artigo, mas você não deseja ser afetado por um vírus de macro, mantenha pressionada a tecla SHIFT quando você abre um arquivo que pode estar infectado por um vírus de macro. Pressionar SHIFT impede que qualquer macro automática do Word sejam executados; se um vírus de macro estiver presente, ele não será carregado.

Método 2: Excluir a macro e recuperar o documento

Se você enfrentar os sintomas descritos anteriormente neste artigo, ou se você suspeitar de que você tenha um vírus de macro que não seja descrito neste artigo, siga estas etapas para excluir a macro suspeita e corrigir o documento afetado.

Observação Isso é apenas uma solução temporária; como novas macros são sendo criadas, essas etapas não podem funcionar em novas macros.
  1. Feche o Word e mova o modelo normal para a área de trabalho.
  2. Faça uma cópia de backup de um arquivo afetado.
  3. Abra o Word. No menu arquivo , clique em Abrir .
  4. Navegue até a pasta que contém o arquivo afetado.
  5. Clique para selecionar o arquivo afetado.
  6. Pressione e mantenha pressionada a tecla SHIFT e clique em Abrir . Continue mantendo a tecla SHIFT até que o arquivo afetado esteja aberto no Word.

    Observação Mantendo a tecla SHIFT ao abrir um arquivo impede que qualquer macro automática do Word sejam executados.
  7. Para excluir uma macro suspeita, use as seguintes etapas:
    1. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
    2. No Macros em menu pop-up, selecione todos os modelos Active e documentos .
    3. Selecione a macro suspeita e, em seguida, clique em Excluir . Clique em Sim quando solicitado se deseja excluir a macro.
    4. Repita a etapa c para todas as macros suspeitas.
    5. Clique em Cancelar para fechar a caixa de diálogo macro .
  8. Para recuperar o texto de um documento infectado, execute estas etapas:
    1. Selecione o documento inteiro pressionando COMMAND + A ou clicando em Selecionar tudo no menu Editar .
    2. Exclua a última marca de parágrafo do documento da seleção pressionando SHIFT+seta para esquerda.
    3. No menu Editar , clique em Copiar .
    4. No menu arquivo , clique em novo . Selecione o modelo que você deseja usar e, em seguida, clique em OK .
    5. No menu Editar , clique em Colar .
    6. Repita a etapa 7 para garantir que a macro que contém vírus não foi replicado.
    7. Salve o documento.
  9. Repita essas etapas para qualquer documento que você suspeitar que pode conter um vírus de macro.
Observação Se o método 2 não funcionar, tente o método 3.

Método 3: Usar o organizador para limpar temporariamente um vírus de macro

Use o organizador para limpar o vírus de macro. Tenha em mente que se você abrir outros arquivos depois de abrir o arquivo infectado, esses arquivos provavelmente estão infectados também.

Para remover o vírus do modelo normal, execute estas etapas:
  1. Feche todos os documentos. Se um documento infectado estiver aberto, ele pode facilmente re-infect o modelo Normal.
  2. No menu Ferramentas , clique em modelos e suplementos e, em seguida, clique no botão Gallery .
  3. Clique na guia de Macros e em seguida, renomear ou excluir todas as seguintes macros:
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • FileNew
    • Abrir
    • FileSave
    • FileSaveAs
    • Macros
    • ToolsMacro
  4. Clique em Fechar .
  5. Pressione e mantenha pressionado SHIFT enquanto clica em Salvar tudo no menu arquivo para salvar o modelo.
para remover um vírus de macro um documento infectado:

Se um arquivo estiver infectado, usar o mesmo método como nas etapas 1 a 5, mas remover as macros do modelo normal e também do documento infectado (modelo) enquanto no Gallery. Quando tiver terminado, pressione e mantenha a tecla SHIFT enquanto você clique em Salvar tudo no menu arquivo e, em seguida, vá para o próximo arquivo. Tenha em mente que, sempre que você abrir um arquivo infectado, ele infecta seu modelo normal, para que você deve remover repetidamente as macros do modelo Normal.

Método 4: Inserir o arquivo infectado em um novo documento

Esse método é útil principalmente com o vírus de macro "CAP", que remove a macro e Personalizar no menu Ferramentas .

Observação Nessa situação, modelos e suplementos no menu Ferramentas podem não funcionar.
  1. Feche o Word e mova o modelo normal para a área de trabalho.
  2. Abra o Word e, em seguida, verifique se macro e personalizar são exibidos no menu Ferramentas .
  3. Abra um novo documento. No menu Inserir , clique em arquivo .
  4. Navegue até a pasta que contém o arquivo afetado.
  5. Clique para selecionar o arquivo afetado.
  6. Pressione e mantenha pressionada a tecla SHIFT e clique em Abrir . Continue a mantenha pressionada a tecla SHIFT até que o arquivo afetado esteja aberto no Word.
    Observação Mantendo a tecla SHIFT ao abrir um arquivo impede que o Word automaticamente macros sejam executados.
  7. Para verificar se existem quaisquer macros no novo documento (nenhum deve estar listado), aponte para macro no menu Ferramentas e, em seguida, clique em macros . Na Macros em lista pop-up, clique em todos os modelos ativos e documentos . Em Nome da macro , nenhuma macro deve ser listada. Clique em Cancelar .
  8. Salve o arquivo com um nome de arquivo diferente.
  9. Exclua o arquivo infectado.

A informação contida neste artigo aplica-se a:
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office X para Mac Standard Edition
  • Microsoft Office 2001 para Mac
  • Microsoft Word 2004 for Mac
  • Microsoft Word X para Macintosh
  • Microsoft Word 2001 para Mac
Palavras-chave: 
kbmt kbinfo KB291824 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 291824  (http://support.microsoft.com/kb/291824/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store