DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 319440 - Última revisão: quarta-feira, 14 de maio de 2008 - Revisão: 7.0

Download do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
 
 

Nesta página

Sintomas

No Windows, os atrasos de logon significativo podem ocorrer quando os clientes efetuam logon. Esse problema ocorre se a maioria ou todas as condições seguintes forem verdadeiras:
  • Vários clientes simultaneamente estão fazendo logon.
  • Os clientes estão compartilhando um arquivo de diretiva grande ou alguns arquivos de diretiva grande.
  • Os clientes estão usando conexões (lentos) de largura de banda baixa.
  • Os clientes têm acesso a alguns controladores de domínio.
  • Os clientes tenham desativada para downloads de diretiva ou Registry.pol arquivo está sendo recuperado devido a uma atualização de detecção de vínculos lentos.

Causa

Esse comportamento pode ocorrer se o cliente é não é possível usar o bloqueio oportunista quando o cliente está baixando a diretiva. Essa diminuição de desempenho faz com que um atraso no download de diretivas que é mais perceptível quando acesso a controladores de domínio ocorre em uma conexão de baixa largura de banda.

Resolução

Informações sobre o Windows Server 2003 service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix Windows Server 2003

O hotfix descrito neste artigo foi substituído por outro hotfix. Para obter mais informações sobre o hotfix novo, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
930597  (http://support.microsoft.com/kb/930597/ ) Algumas configurações de diretiva baseada no Registro estão perdidas e mensagens de erro são registradas no log do aplicativo em um computador baseado no Windows XP ou em um computador baseado no Windows Vista
O hotfix adiciona e define o seguinte valor da chave do registro no Registro:
Subchave do Registro: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Entrada: BufferPolicyReads
Tipo: DWORD
Valor: 1
Observação Leituras de arquivo só será armazenado em buffer quando a entrada do Registro BufferPolicyReads existe e é definida como 1.

Pré-requisitos

Para instalar esse hotfix, você deve ter o Windows Server 2003 Service Pack 1 (SP1) instalado no x 86 e versões baseadas em Itanium do Windows Server 2003. Para obter mais informações sobre como obter o Windows Server 2003 Service Pack 1, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Userenv.dll5.2.3790.2749790,52818 De julho de 200613: 38x 86
Windows Server 2003, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Userenv.dll5.2.3790.27491,565,69618 De julho de 200601: 32IA-64SP1SP1QFE
Wuserenv.dll5.2.3790.2749790,52818 De julho de 200601: 32x 86SP1UAU
Windows Server 2003, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Userenv.dll5.2.3790.27491,070,59218 De julho de 200601: 30x 64SP1SP1QFE
Wuserenv.dll5.2.3790.2749790,52818 De julho de 200601: 30x 86SP1UAU

Informações sobre o Windows XP hotfix

Um hotfix com suporte foi disponibilizada pela Microsoft. No entanto, destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde o próximo service pack do Windows XP que contém esse hotfix.

Para resolver esse problema imediatamente, contate o Microsoft Customer Atendimento para obter o hotfix. Para obter uma lista completa de telefones do serviço de suporte a clientes da Microsoft e informações sobre os custos de suporte, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.
O hotfix adiciona e define o seguinte valor da chave do registro no Registro:
Subchave do Registro: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Entrada: BufferPolicyReads
Tipo: DWORD
Valor: 1
Observação Leituras de arquivo só será armazenado em buffer quando a entrada do Registro BufferPolicyReads existe e é definida como 1.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows XP Service Pack 2 (SP2) instalado no computador.
Para obter mais informações sobre como obter o Windows XP Service Pack 2 (SP2), clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389  (http://support.microsoft.com/kb/322389/ ) Como obter o service pack mais recente do Windows XP

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Userenv.dll5.1.2600.2913724,99222 De maio de 200612: 14x 86

Como Contornar

Para contornar esse comportamento, todos os clientes necessário baixar os arquivos de diretiva rapidamente para que outros clientes não são interrompidos de usar o bloqueio oportunista. Para fazer isso, use qualquer um dos seguintes métodos.

Adicionar controladores de domínio localmente

Quando você fizer isso, os clientes não são necessário que conectar através de um vínculo lento.

Distribuir a carga com controladores de domínio adicionais

Se não for prático colocar os controladores de domínio no mesmo site como o cliente, você pode adicionar controladores de domínio para o site principal ao qual os clientes se conectar para fornecer melhor balanceamento de carga. Esse método aumenta as chances do cliente poder acessar o arquivo de diretiva usando o bloqueio oportunista.

Dividir um arquivo de diretiva único em vários arquivos diretiva

Se o arquivo de diretiva for maior do que várias quilobytes, crie alguns arquivos de diretiva exclusivos para cobrir o mesmo intervalo de diretivas. Isso reduz a quantidade de tempo que é necessário para baixar os arquivos de diretiva, se o bloqueio oportunista está disponível ou não. Vários arquivos também aumenta a chance de que o cliente usará o bloqueio oportuno para acessar o arquivo.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Microsoft Windows Server 2003 Service Pack 2.

Mais Informações

Os clientes são afetados por esse comportamento de logon lento quando o arquivo de diretiva está sendo carregado. Os administradores podem desativar detecção de vínculos lentos (usando administrador Templates\System\Group Policy) forçar a diretiva baixa independentemente da velocidade do link. Cada modificação do arquivo de diretiva faz com que o arquivo Registry.pol para serem baixadas por clientes remotos, para cada alteração.

Para obter mais informações sobre como um vínculo lento é detectado e o comportamento padrão das extensões de diretiva de grupo através de vínculo lento, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
227369  (http://support.microsoft.com/kb/227369/ ) Comportamento padrão para as extensões de diretiva de grupo com vínculos lentos
227260  (http://support.microsoft.com/kb/227260/ ) Como um vínculo lento é detectado para perfis de usuário e a diretiva de grupo
Por padrão, o redirecionador tenta obter um bloqueio oportunista quando um arquivo é aberto remotamente. Isso permite que o redirecionador para usar o cache read-ahead para melhorar o desempenho. Para obter mais informações sobre oplocks, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
129202  (http://support.microsoft.com/kb/129202/ ) Explicação sobre o bloqueio oportunista no Windows NT
Em determinados casos, o servidor de arquivos pode rejeitar solicitações de bloqueio oportunistas. Isso geralmente ocorre se o arquivo está bloqueado para uso exclusivo/gravação. Além disso, o serviço Server executa as seguintes verificações para evitar danos de dados e para melhorar a estabilidade:
  • Verificar para determinar se o arquivo é um arquivo de sistema
  • Verificar para determinar se o vínculo de rede é considerado confiável
  • Verificação para determinar se há drivers de filtro que não terminaram seu trabalho
Para obter mais informações sobre um tópico relacionado, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
306981  (http://support.microsoft.com/kb/306981/ ) Nível oplocks II não são concedidos depois que um arquivo é bloqueado
Os usuários que acessam os arquivos usando oplocks não tenham esse comportamento porque o redirecionador executa read-ahead cache e leituras de arquivo servidas do cache redirecionador.

Se o redirecionador não abrir o arquivo remoto usando o bloqueio oportunista, informa a especificação de SMB do Windows NT 4.0 ou CIF 2.0 do MSDN:
Se um cliente contém não oplocks, todas as solicitações sejam leituras devem ser enviadas para o servidor. Leituras podem ser executadas usando dados armazenados em cache ou read-ahead, desde que o intervalo de bytes foi bloqueado pelo cliente; caso contrário, eles também devem ser enviados ao servidor.
Isso faz com que as leituras de método de carga de diretiva acessar o servidor usando a rede para cada caractere Unicode que é lido. Se o arquivo de diretiva for grande, e se a largura de banda disponível para os clientes for baixa, ocorrem atrasos significativos enquanto as diretivas são carregadas e isso criar atrasos de logon.

Para identificar essa situação, use qualquer um dos seguintes métodos.

Método 1

Você pode executar a ferramenta de Filemon.exe de terceiros a partir do seguinte site da Sysinternals:
http://technet.microsoft.com/en-us/sysinternals/default.aspx (http://technet.microsoft.com/en-us/sysinternals/default.aspx)
A saída da ferramenta FileMon.exe é semelhante:
Sistema: 8 FSCTL_REQUEST_BATCH_OPLOCK C:\WINNT\SYSVOL\domain\Policies\{Policy-GUID}\user\registry.pol BLOQUEIO não concedida
Sistema: 8 FSCTL_REQUEST_OPLOCK_LEVEL_2 C:\WINNT\SYSVOL\domain\Policies\{Policy-GUID}\user\registry.pol BLOQUEIO não concedida
Sistema: 8 FASTIO_QUERY_NETWORK_OPEN_INFO C:\WINNT\SYSVOL\domain\Policies\{Policy-GUID}\user\registry.pol êxito

Método 2

Traços do monitor de rede Microsoft exibir o nível de bloqueio = none a resposta do servidor à solicitação de arquivo aberto:
SMB: Criar R NT e X, FID = 0x4009
Código de status do NT + SMB: = 0 x 0, recurso = System, gravidade = êxito, código = STATUS_WAIT_0 (0)
+ SMB: Cabeçalho: PID = 0x00B8 TID = 0 x 0804 MID = 0x0841 UID = 0 x 1000
Comando SMB: = C NT criar e X
SMB: Word contagem = 42
SMB: Parâmetros de Word
SMB: Deslocamento Avançar = 0x0087
SMB: Word contagem = 42
SMB: Parâmetros de Word
Nível de bloqueio SMB: = NONE
SMB: Identificação do arquivo (FID) = 16393 (0x4009)
Nome do arquivo SMB: = \mydom.com\Policies\{E3FDB1FB-0FA1-484E-8751-7009DD5287BD}\User\registry.pol
Lê o byte 2 seqüencial para o arquivo de diretiva, tornando um download lento se o arquivo for grande:
107 26.234375 SMB C NT criar n X, File = \mydom.com\Policies\{E3FDB1FB-0FA1-484E-8751-7009DD5287BD}\User\registry
108 26.234375 SMB R NT criar n X, FID = 0x4009 161.123.162.142 161.123.110.40
109 26.296875 SMB C ler n X, FID = 0x4009, leitura 0 x 4 em 0 x 00000000 161.123.110.40 161.123.162.142
110 26.296875 SMB R ler X n, ler 0 x 4 161.123.162.142 161.123.110.40
111 26.343750 SMB C ler n X, FID = 0x4009, leitura 0 x 4 em 0 x 00000004 161.123.110.40 161.123.162.142
112 26.343750 SMB R ler X n, ler 0 x 4 161.123.162.142 161.123.110.40
113 26.406250 SMB C ler n X, FID = 0x4009, leitura 0 x 2 em 0 x 00000008 161.123.110.40 161.123.162.142
114 26.406250 SMB R ler X n, ler 0 x 2 161.123.162.142 161.123.110.40
115 26.453125 SMB C ler n X, FID = 0x4009, leitura 0 x 2 no 0x0000000A 161.123.110.40 161.123.162.142

Suporte técnico para versões com base em 64 x do Microsoft Windows

Se o hardware veio com uma edição x 64 do Microsoft Windows instalada, o fabricante do hardware fornecerá suporte técnico e assistência para a edição x 64 do Windows. Nesse caso, o fabricante do hardware fornece suporte porque uma edição x 64 do Windows foi incluída com o hardware. O fabricante do hardware pode ter personalizado a instalação da edição x 64 do Windows do usando componentes exclusivos. Componentes exclusivos podem incluir drivers de dispositivo específico ou podem incluir configurações opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se você precisar de ajuda técnica com uma edição x 64 do Windows. No entanto, talvez você precise entrar em contato com o fabricante diretamente. O fabricante do seu melhor é qualificado para suportar o software que o fabricante do seu instalado no hardware. Se você comprou uma edição x 64 do Windows, como um Windows Server 2003 x 64 edition separadamente, contate a Microsoft para obter suporte técnico.

Para informações de produto sobre o Windows XP Professional x 64 Edition, visite o seguinte site:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Para informações de produto sobre versões com base em 64 x do Windows Server 2003, visite o seguinte site:
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx)


A Microsoft fornece terceiros informações de contatos para ajudá-lo a encontrar suporte técnico. Essa informações de contatos podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações contatos de terceiros.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows 2000 Advanced Server SP2
Palavras-chave: 
kbmt kbwinserv2003sp2fix kbhotfixserver kbenv kbnetwork kbprb KB319440 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 319440  (http://support.microsoft.com/kb/319440/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store