DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 816073 - Última revisão: terça-feira, 31 de julho de 2007 - Revisão: 4.1

Download do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
 
 
Para uma versão deste artigo do Microsoft Windows Server 2003, consulte 890553  (http://support.microsoft.com/kb/890553/ ) .
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows

Nesta página

Sintomas

Quando você tenta compilar um programa em um computador baseado no Microsoft Windows XP, pode levar aproximadamente 30 % a 40 por cento mais para concluir que tinha quando era o mesmo hardware do computador baseado no Microsoft Windows NT.

Em um computador com hospedagem múltipla que está executando o Microsoft Windows XP, você enfrenta atrasos de entre 10 e 60 segundos quando você usa caminhos UNC (convenção de nomenclatura universal) para acessar arquivos que são armazenados em um servidor SMB (bloco) de mensagem do servidor remoto. Esse problema ocorre mais freqüentemente como o computador tenta acessar arquivos com mais freqüência. Por exemplo, o problema pode ocorrer quando um aplicativo tenta acessar arquivos em intervalos de dois segundos. O problema não ocorre quando você acessa os arquivos através de uma unidade de rede mapeada. O problema também não ocorre quando o NetBIOS sobre TCP/IP (NetBT) está desabilitado na interface de rede pelo menos um.

Causa

Esse problema pode ocorrer se você compilar um programa grande com muitos arquivos. Windows XP armazena em cache os arquivos que você está compilando e quando é atingido o limite de cache do Windows, o Windows remove os arquivos do cache. Quando ele faz isso, o Windows pode remover os arquivos que são usados com freqüência durante a compilação. Para usar esses arquivos, você deve cache-los novamente. Recaching os arquivos reduz o processo de compilação.

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows XP. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389  (http://support.microsoft.com/kb/322389/ ) Como obter o service pack mais recente do Windows XP

Hotfix informações

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version      Size    File name
   --------------------------------------------------
15-Apr-2003 23:25 5.1.2600.1206 92,160 Cscdll.dll 
15-Apr-2003 22:59 5.1.2600.1206 401,920 Mrxsmb.sys 
15-Apr-2003 22:59 5.1.2600.1206 155,392 Rdbss.sys

				

Como Contornar

Para contornar esse problema, execute estas etapas:
  1. Mapear uma unidade de rede para o servidor SMB. Para fazer isso, execute as seguintes etapas:
    1. Inicie o Windows Explorer.
    2. No menu Ferramentas , clique em Mapear unidade de rede .
    3. Na lista unidade , clique em uma letra de unidade.
    4. Na lista de pastas , digite o caminho UNC do recurso compartilhado no servidor. Use o seguinte formato:
      \\ ServerName \ SharedItem
      Como alternativa, clique em Procurar e localize o recurso compartilhado.
    5. Clique em Concluir .
  2. Desative o NetBT em uma interface de rede. Para fazer isso, execute as seguintes etapas:
    1. Clique em Iniciar , clique em Executar , digite ncpa.cpl e, em seguida, clique em OK .
    2. Clique com o botão direito do mouse na conexão de rede que você deseja configurar e, em seguida, clique em Propriedades .
    3. Se a conexão for uma conexão de rede local, clique na guia Geral , clique em Internet Protocol [TCP/IP] na caixa esta conexão usa estes itens e, em seguida, clique em Propriedades . Se a conexão não for uma conexão de rede local, clique na guia rede .
    4. Clique em Avançado e, em seguida, clique na guia WINS .
    5. Na área configuração NetBIOS , clique em Desativar NetBIOS sobre TCP/IP .
    6. Clique em OK três vezes.

Mais Informações

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.Para aplicar esse hotfix com êxito, você deve adicionar o valor ScavengerTimeLimit no registro. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize a seguinte chave no Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

    Valor mínimo: 1 (tempo em segundos)
    Valor padrão: 10 máximo valor: 120 (dois minutos)
    Tipo: DWORD

    Observação Você pode inserir qualquer valor entre 1 e 120 para ScavengerTimeLimit controlar a freqüência com a qual o segmento de recuperação limpa conexões antigas de compartilhamento de arquivo.
  3. Clique com o botão direito do mouse em Parameters , aponte para novo e, em seguida, clique em valor DWORD .
  4. Digite ScavengerTimeLimit e, em seguida, pressione ENTER para nomear o novo valor.
  5. Clique duas vezes em ScavengerTimeLimit .
  6. Na caixa dados do valor , digite 60 e, em seguida, clique em OK .
  7. Feche o Editor do Registro.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Microsoft Windows XP Service Pack 2.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB816073 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 816073  (http://support.microsoft.com/kb/816073/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store