DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 838594 - Última revisão: quarta-feira, 11 de abril de 2007 - Revisão: 2.1

 

Este artigo se aplica para um arquivo de banco de dados (.mdb) do Microsoft Access ou para um arquivo de banco de dados (.accdb) do Microsoft Access.Avançadas: Requer especialista de codificação, interoperabilidade e habilidades de multiusuário.

Nesta página

Sintomas

Ao usar o Assistente de Upsizing ao migrar os objetos de banco de dados de um banco de dados do Microsoft Access (.mdb ou .accdb) a um banco de dados Microsoft SQL Server existente e você usar o nome de fonte de dados do sistema (DSN de sistema) ou nome da fonte de usuário dados (DSN de usuário) para se conectar à instância do SQL Server, você receberá a seguinte mensagem de erro:
[DBNETLIB][ConnectionOpen(Connect()).]SQL Server não existe ou acesso negado.
Além disso, quando você clicar em OK na mensagem de erro, recebe a seguinte mensagem de erro:
O Assistente de Upsizing funciona somente com o Microsoft SQL Server (versões 6.50 SP5 ou superior). Faça logon uma fonte de dados do SQL Server.
Observação Esse problema ocorre quando o banco de dados Access e a instância do SQL Server não existem no mesmo computador.

Como Contornar

Para contornar este problema, use um DSN de arquivo para se conectar a sua instância do SQL Server quando submeter ao upsizing seu banco de dados Access. Para fazer isso, execute as seguintes etapas:
  1. Inicie o Access.
  2. Abra o banco de dados do problema.
  3. No menu Ferramentas , aponte para Utilitários de banco de dados e, em seguida, clique em Assistente de Upsizing .

    Observação No Access 2007, clique em SQL Server no grupo Mover dados na guia Ferramentas de banco de dados .
  4. Na caixa de diálogo Assistente de Upsizing , clique na opção Usar banco de dados existente e, em seguida, clique em Avançar .
  5. Na caixa de diálogo Selecionar fonte de dados , selecione o DSN apropriado para se conectar à sua instância do SQL Server na guia File Data Source .
  6. Clique em OK .
  7. Digite as informações apropriadas de autenticação para se conectar a sua instância do SQL Server se a caixa de diálogo Logon do SQL Server aparece.
  8. Siga as instruções no Assistente de Upsizing.

    Observe que o banco de dados do Access com êxito está submetidas ao upsizing sem erros.

Mais Informações

Etapas para reproduzir o problema

  1. Inicie o Access.
  2. Abra o banco de dados de exemplo Northwind.
  3. No menu Ferramentas , aponte para Utilitários de banco de dados e, em seguida, clique em Assistente de Upsizing .

    Observação No Access 2007, clique em SQL Server no grupo Mover dados na guia Ferramentas de banco de dados .
  4. Na caixa de diálogo Assistente de Upsizing , clique na opção Usar banco de dados existente e, em seguida, clique em Avançar .
  5. Na caixa de diálogo Selecionar fonte de dados , selecione o DSN apropriado para se conectar à sua instância do SQL Server na guia Machine Data Source .
  6. Clique em OK .
  7. Digite as informações apropriadas de autenticação para se conectar a sua instância do SQL Server se a caixa de diálogo Logon do SQL Server aparece.

    Observe que você recebe as mensagens de erro mencionadas na seção "Sintomas", e você não pode continuar o processo de upsizing.

Referências

Para obter informações adicionais sobre como usar o Assistente de Upsizing no Access 2002, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
330468  (http://support.microsoft.com/kb/330468/ ) Como usar o Assistente de Upsizing do Microsoft Access 2002
Para obter informações adicionais sobre problemas com o Assistente de Upsizing no Access 2002, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
328319  (http://support.microsoft.com/kb/328319/ ) Problemas com o Assistente de Upsizing do Access 2002

A informação contida neste artigo aplica-se a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbmt kbexpertiseinter kbtshoot kbdatabase kbwizard kberrmsg kbprb KB838594 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 838594  (http://support.microsoft.com/kb/838594/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store