DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 840388 - Última revisão: quarta-feira, 29 de agosto de 2007 - Revisão: 4.1

Download do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
 
 
importante Este artigo contém informações sobre como modificar o registro. Antes de modificar o registro, certifique-se de backup e certifique-se que você saiba como restaurar o registro se ocorrer um problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows

Nesta página

Sintomas

Quando você usar comportamentos para baixar informações de um arquivo para um documento HTML e compactação estática está ativada no Microsoft Internet Information Services (IIS), os dados que são baixados para o documento HTML não é exibido sempre. Normalmente, o documento carrega como esperado na primeira tentativa. No entanto, dinâmico de dados pode não aparecer ao tentar baixá-lo novamente.

Causa

Esse problema ocorre porque o Microsoft Internet Explorer sempre lê dados compactados como sendo armazenadas em cache, mesmo se a configuração de cache-control Especifica um valor diferente.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   16-Apr-2004  01:58  6.0.2800.1421  485,888  Urlmon.dll       
   16-Apr-2004  01:59  6.0.2800.1421  589,824  Wininet.dll
				

Informações sobre a instalação

Aviso Se você usar o Editor do Registro incorretamente, você pode causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.

Depois de instalar esse hotfix, siga estas etapas:
  1. Feche o Internet Explorer.
  2. Clique em Iniciar e, em seguida, clique em Executar .
  3. Na caixa Abrir , digite regedit e, em seguida, clique em OK .
  4. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_TEMPORARYFILES_FOR_NOCACHE_840387
  5. Clique em Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  6. Digite iexplore.exe e, em seguida, pressione ENTER.
  7. Clique com o botão direito do mouse iexplore.exe e, em seguida, clique em Modificar .
  8. Na caixa dados do valor , digite 00000001 e, em seguida, clique em OK .
  9. No menu arquivo , clique em Sair para fechar o Editor do Registro.

Como Contornar

Para contornar este comportamento para HTML dinâmico (DHTML) a funcionalidade, desativar a compactação estática no IIS para compatibilidade máxima.

Situação

A Microsoft confirmou que este é um problema no Microsoft Internet Explorer 6.

Referências

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
255801  (http://support.microsoft.com/kb/255801/ ) Como determinar se a compactação de HTTP está em uso
Para obter mais informações sobre como desenvolver soluções baseadas na Web para o Microsoft Internet Explorer, visite os seguintes sites:

http://msdn2.microsoft.com/en-us/ie/default.aspx (http://msdn2.microsoft.com/en-us/ie/default.aspx)

http://msdn2.microsoft.com/en-us/library/aa286532.aspx (http://msdn2.microsoft.com/en-us/library/aa286532.aspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer (Programming) 6.0
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbie600sp2fix kbie600presp2fix kbfix kbbug KB840388 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 840388  (http://support.microsoft.com/kb/840388/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store