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Base de Dados de Conhecimento

ID do artigo: 842827 - Última revisão: quinta-feira, 25 de outubro de 2007 - Revisão: 1.3

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Sintomas

Quando você faz logoff de um computador com Microsoft Windows XP, o sistema não pode descarregar seu perfil de usuário corretamente. Além disso, o seguinte erro pode ser registrado no log do aplicativo:

Tipo de evento: erro
Origem do evento: Userenv
Categoria do evento: nenhum
IDENTIFICAÇÃO de evento: 1524
Descrição:
Windows não pode descarregar seu arquivo de registro de classes - ele ainda está em uso por outros aplicativos ou serviços. O arquivo será descarregado quando não estiver em uso.

Quando fizer logon no computador novamente, a subchave de registro HKEY_CURRENT_USER\Software\Classes não é carregada. Além disso, certas operações COM falham. Por exemplo, as operações de COM para formulários do Outlook falhar.

Causa

Esse problema ocorre porque, quando fizer logon no computador, o serviço do cliente WebDav armazena em cache um identificador para a subchave de registro HKEY_CURRENT_USER\Software\Classes durante a inicialização por usuário.

A subchave de registro HKEY_CURRENT_USER\Software\Classes é o arquivo usrclass.dat no seu perfil de usuário. A subchave de registro HKEY_CURRENT_USER\Software\Classes é usada para por usuário COM registros. Portanto, a subchave de registro HKEY_CURRENT_USER\Software\Classes não pode ser descarregada quando fizer logoff do computador devido a alça em cache.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Você deve ter o Windows XP SP2 instalado para aplicar esse hotfix.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Advapi32.dll5.1.2600.3039617,47222 De novembro de 200613: 07x 86SP2SP2QFE
Webclnt.dll5.1.2600.303968.09622 De novembro de 200613: 07x 86SP2SP2QFE

Como Contornar

Para contornar esse problema, use o Microsoft usuário perfil seção limpeza serviço (UPHClean). UPHClean monitora o computador enquanto o Windows está descarregando os perfis de usuário. UPHClean força recursos que estão abertos para fechar. Portanto, o computador pode descarregar os perfis de usuário.

Para baixar e instalar o UPHClean, visite o seguinte site:
http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582 (http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582)

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

A subárvore do Registro HKEY_CLASSES_ROOT é a exibição mesclada de subchave do Registro HKEY_CURRENT_USER\Software\Classes e a subchave de Registro HKEY_LOCAL_MACHINE\Software\Classes. Quando o sistema lê a partir da subárvore do Registro HKEY_CLASSES_ROOT, os dados por usuário que estão localizados na subárvore HKEY_CURRENT_USER do Registro substitui os dados por computador que estão localizados na subárvore do Registro HKEY_LOCAL_MACHINE. Se o sistema grava para a subárvore do Registro HKEY_CLASSES_ROOT, os dados são redirecionados para a subchave de registro HKEY_CURRENT_USER\Software\Classes. A subchave de registro HKEY_CURRENT_USER\Software\Classes é o arquivo usrclass.dat no perfil ’s usuário. Portanto, os usuários podem criar seus próprios registros de classe COM porque usuários regulares normalmente tem acesso somente leitura para a subchave de Registro HKEY_LOCAL_MACHINE\Software\Classes.

Quando o problema descrito neste artigo ocorre, a subchave de registro HKEY_CURRENT_USER\Software\Classes não aparece no registro na próxima vez que o usuário fizer logon computador. Portanto, os registros de COM por usuário estão faltando.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbpubtypekc kbqfe kbhotfixserver kbtshoot kbexpertiseinter kbprb KB842827 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 842827  (http://support.microsoft.com/kb/842827/en-us/ )
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