DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 894077 - Última revisão: sexta-feira, 16 de novembro de 2007 - Revisão: 3.3

Download do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
 
 

Nesta página

Sintomas

Modo de exibição de árvore do Microsoft Windows Explorer pode exibir uma pasta que não tenha um nome ou que tem um nome incorreto depois que um aplicativo externo cria uma pasta ou renomeia uma pasta. Esse problema pode ocorrer com uma pasta de extensão de espaço para nome que é um ponto de junção no sistema de arquivos.

Quando o modo de exibição de árvore do Windows Explorer manipula uma notificação de alteração para o shell de aplicativo externo, a notificação de alteração para o shell indica que uma pasta foi criada ou tiver sido renomeada.

Causa

Os arquivos e pastas na extensão do espaço para nome são armazenadas na pasta arquivo de sistema que é usada para registrar o ponto de junção. A função SHChangeNotify gera um sistema de arquivos ITEMIDLIST. Essa ação ocorre quando a função SHChangeNotify é chamada por um aplicativo para notificar o shell quando uma pasta de sistema de arquivo foi criada ou tiver sido renomeada. Modo de exibição de árvore do Windows Explorer manipula a notificação de alteração, passando o sistema de arquivos ITEMIDLIST à interface IShellFolder da pasta que contém o item que está sendo criado ou modificado. Esta ação é executada para obter o nome de exibição do item. Notificações de alteração para os itens sob a pasta de ponto de junção não são tratadas corretamente. Esse problema ocorre porque a extensão de espaço para nome espera a serem passados um ITEMIDLIST é gerado pelo espaço para nome em vez de na pasta de sistema de arquivo.

Resolução

Microsoft Windows 2000

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Você precisará instalar o Microsoft Windows 2000 Service Pack 4 antes de aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações do registro

Após os arquivos de hotfix são instalados, você pode ativar o hotfix usando as configurações de diretiva para o shell na seguinte chave do Registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer
Nome: CompareJunctionness
Tipo: REG_DWORD
Dados do valor: 1

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version        Size       File name 
   --------------------------------------------------------- 
   18-Apr-2005  11:28  5.0.3900.7040  2,359,568  Shell32.dll

Windows XP

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Você precisará instalar o Microsoft Windows XP Service Pack 2 antes de aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações do registro

Após os arquivos de hotfix são instalados, você pode ativar o hotfix usando as configurações de diretiva para o shell na seguinte chave do Registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer
Nome: CompareJunctionness
Tipo: REG_DWORD
Dados do valor: 1

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time    Version         Size      File name     
   ----------------------------------------------------------------
   14-Feb-2005  21:32   6.0.2900.2610  8,451,584  Shell32.dll 
   14-Feb-2005  21:32   6.0.2900.2606    473,600  Shlwapi.dll

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
  • the operating system: Microsoft Windows 2000 SP4
Palavras-chave: 
kbmt kbautohotfix kbfix kbqfe kbhotfixserver KB894077 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 894077  (http://support.microsoft.com/kb/894077/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store