DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 896017 - Última revisão: quarta-feira, 29 de agosto de 2007 - Revisão: 4.3

Download do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
 
 
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de fazer backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows

Nesta página

Sintomas

Quando você tenta baixar um arquivo usando o Microsoft Internet Explorer, você pode enfrentar o seguinte sintoma:

Quando você clica em Salvar , Abrir ou Cancelar na caixa de diálogo Download de arquivo , a janela que inicia a caixa de diálogo Download de arquivo inesperadamente fecha.

Causa

Esse problema pode ocorrer se você estiver executando o Microsoft Windows XP Service Pack 2 (SP2). Esse problema ocorre devido a uma alteração no comportamento no Internet Explorer quando ele é executado no Windows XP SP2.

O MIME tratamento recurso é alterado quando ele processa um download a partir de uma janela pop-up. Nesse cenário, o recurso de manipulação de MIME fecha a janela pop-up quando o conteúdo baixado é enviado do servidor Web usando o cabeçalho HTTP "disposição do conteúdo; anexo".

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Você deve ter o Windows XP SP2 instalado para aplicar o hotfix. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389  (http://support.microsoft.com/kb/322389/ ) Como obter o service pack mais recente do Windows XP

Requisitos de reinicialização

Reinicie o computador após aplicar o hotfix.

Informações sobre a substituição do hotfix

O hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version         Size       File name
   ----------------------------------------------------------
   25-Mar-2005  05:46  6.0.2900.2640   1,484,800  Shdocvw.dll

Informações sobre a instalação do hotfix

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstale seu sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Observação Essa atualização também está incluída em atualizações cumulativas começando depois do MS05-025 (883939). A atualização cumulativa não requer as seguintes etapas para habilitar o comportamento alterado. As seguintes alterações de registro são necessárias somente se você instalar esse hotfix específico (896017).

Depois de instalar esse hotfix e, em seguida, reinicie o computador, você deve configurar uma configuração de registro para ativar as alterações que faz com que esse hotfix. Para fazer isso, execute as seguintes etapas:
  1. Feche o Internet Explorer se ele estiver sendo executado.
  2. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  3. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
    Observação Se a subchave FeatureControl não existir, adicione-o. Para fazer isso, execute as seguintes etapas:
    1. Clique com o botão direito do mouse principal , aponte para novo e, em seguida, clique em chave .
    2. Na caixa New Key # 1 , digite FeatureControl e, em seguida, pressione ENTER.
  4. Clique com o botão direito do mouse FeatureControl , aponte para novo e, em seguida, clique em chave .
  5. Na caixa New Key # 1 , digite FEATURE_Enable_WindowOpen_when_ContentDisposition_Attachment_KB896017 e, em seguida, pressione ENTER.
  6. Clique com o botão direito do mouse FEATURE_Enable_WindowOpen_when_ContentDisposition_Attachment_KB896017 , aponte para novo e, em seguida, clique em Valor DWORD .
  7. Na caixa novo valor # 1 , digite iexplore.exe e, em seguida, pressione ENTER.
  8. Clique com o botão direito do mouse iexplore.exe e, em seguida, clique em Modificar .
  9. Na caixa dados do valor , digite 00000001 e, em seguida, clique em OK .
  10. Feche o Editor do Registro.

Como Contornar

Para contornar este problema, altere o código HTML cliente para usar um valor de "destino" para o comando POST enviado ao servidor. Por exemplo, considere o seguinte código de exemplo:
 <form method="POST" action="download.asp">
para solucionar esse problema, altere este código de exemplo para o código a seguir:
 <form method="POST" action="download.asp" target="_top">

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Service Pack 2 nas seguintes plataformas
    • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbbug kbfix kbqfe kbhotfixserver KB896017 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 896017  (http://support.microsoft.com/kb/896017/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store