DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 905726 - Última revisão: terça-feira, 4 de dezembro de 2007 - Revisão: 2.7

Nesta página

Sintomas

Depois de instalar um service pack ou uma atualização do Microsoft Office, você é solicitado a reiniciar o computador inesperadamente.

Causa

Este problema pode ocorrer se o service pack ou a atualização precisar modificar um arquivo em uso no momento. O arquivo pode estar sendo usado por um programa em execução quando você instala o service pack ou a atualização. Algumas vezes, o programa que está usando o arquivo não é do Office.

Este problema pode ocorrer se uma ou mais das seguintes condições forem verdadeiras:
  • Um dispositivo sincronizado com o Microsoft Outlook está encaixado com o computador cliente. Além disso, o ActiveSync está em execução.
  • Um programa do Office está em execução.
  • O Microsoft Office Communicator 2005 está em execução.
Observação Esta lista não é abrangente. Pode existir outros programas instalados que causem esse problema.

Resolução

Antes de instalar o service pack ou a atualização, feche todos os programas ou serviços em execução que possam interferir na instalação do service pack ou da atualização.

Os seguintes métodos oferecem informações sobre como fechar alguns dos programas e serviços mais comuns que possam causar esse problema. Use os seguintes métodos, dependendo da situação.

Como fechar o ActiveSync

Para fechar o ActiveSync, encerre o processo Wcescomm.exe. Para encerrar o processo Wcescomm.exe, consulte a seção "Como encerrar o processo de um programa em execução em segundo plano".

Observação Um usuário ou dispositivo conectado ao serviço será desconectado ao encerrar o processo.

Como fechar um programa do Office

Para fechar um programa do Office, clique em Sair no menu Arquivo. Se o programa do Office não estiver visível na tela, pressione ALT+TAB para alternar para o programa do Office. Como alternativa, clique no botão da barra de tarefas do programa do Office.

Observação Um processo de um programa do Office pode continuar sendo executado em segundo plano se um problema fizer com que ele feche de maneira anormal. Se suspeitar de um processo de que um programa do Office esteja em execução em segundo plano, encerre o processo. Para fazer isso, consulte a seção "Como encerrar o processo de um programa em execução em segundo plano".

Como fechar o Communicator 2005

Para fechar o Communicator 2005, faça logoff do Communicator, feche e saia do programa. Para fazer isso, execute as seguintes etapas:
  1. No menu Connect, clique em Sign Out.
  2. No menu Connect, clique em Close.

    Observação Quando você fecha o Communicator 2005, o programa é minimizado para a área de notificação.
  3. Clique com o botão direito do mouse no ícone do Communicator 2005 na área de notificação e clique em Sair.

Como encerrar o processo de um programa em execução em segundo plano

Importante O encerramento de um processo pode causar resultados indesejáveis. Isso inclui instabilidade do sistema e a perda de dados. Quando você encerra um processo, não existe a possibilidade de salvar seu estado ou outros dados antes de seu encerramento.

Para encerrar o processo de um programa em execução em segundo plano, use um dos seguintes métodos.

Método 1: Usar o Gerenciador de tarefas

Para usar o Gerenciador de tarefas e encerrar um processo, execute as seguintes etapas:
  1. Pressione CTRL+ALT+DEL.
  2. Na guia Processos, clique em nome_do_arquivo_do_processo e em Finalizar processo.

    Observação Nesse método, nome_do_arquivo_do_processo representa o nome do arquivo do processo que deseja finalizar.

Método 2: Usar o comando Taskkill

Para usar o comando Taskkill e finalizar um processo, execute as seguintes etapas:
  1. Clique em Iniciar, em Executar, digite cmd e clique em OK.
  2. No prompt de comando, digite taskkill /im nome_do_arquivo_do_processo e pressione ENTER.

    Observações
    • Neste método, nome_do_arquivo_do_processo representa o nome do arquivo do processo que deseja finalizar.
    • Para obter informações adicionais sobre o comando Taskkill, digite taskkill /? no prompt de comando e pressione ENTER.
  3. No prompt de comando, digite exit para fechar a janela Prompt de comando.

Como impedir a reinicialização inesperada do computador quando você implanta um service pack ou uma atualização do Office

Se você for um administrador que está implantando um service pack do Office ou uma atualização do Office, poderá usar um script para fechar os programas ou os serviços que possam interferir na instalação do service pack ou da atualização.

A Microsoft fornece exemplos de programação apenas por questões ilustrativas, sem garantias expressas ou implícitas. Isso inclui, mas não está limitado a, as garantias implícitas de comercialização ou adequação a um propósito específico. Esse artigo presume que você conheça a linguagem de programação que está sendo demonstrada e também as ferramentas usadas para criar e depurar procedimentos. Os engenheiros de suporte da Microsoft podem ajudar a explicar a funcionalidade de um procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades.

Para usar um script e fechar programas ou serviços, crie um script semelhante ao seguinte.
; TechNet Sample 2005
; http://www.microsoft.com/technet/scriptcenter/resources/qanda/sept04/hey0927.mspx
; For more information about how to use scripts to manage processes, visit the following Microsoft Web site:
; http://www.microsoft.com/technet/scriptcenter/guide/sas_prc_overview.mspx

strComputer = "."
Set objWMIService = GetObject _
    ("winmgmts:\\" & strComputer & "\root\cimv2")
Set colProcessList = objWMIService.ExecQuery _
    ("Select * from Win32_Process Where Name = 'Communicator.exe'")
For Each objProcess in colProcessList
    objProcess.Terminate()
Next

Mais Informações

Freqüentemente, a instalação de um service pack do Office ou de uma atualização do Office não exige que você reinicialize o computador. No entanto, existem situações em que você deve reiniciar o computador.

Se for necessário reiniciar o computador após a instalação de um service pack ou de uma atualização do Office, as informações sobre a reinicialização serão incluídas na documentação que acompanha o service pack ou a atualização do Office. Se você instalar um service pack ou uma atualização do Office que exija a reinicialização do computador, o problema descrito nesse artigo não se aplicará.

A informação contida neste artigo aplica-se a:
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Access 2003
  • Microsoft Office InfoPath 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Project Professional 2003
  • Microsoft Office Project Standard 2003
  • Microsoft Office Project Server 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Visio Professional 2003
  • Microsoft Office XP Professional Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Project 2002 Professional Edition
  • Microsoft Project Server 2002
  • Microsoft Publisher 2002 Standard Edition
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Project 2000 Standard Edition
  • Microsoft Publisher 2000 Standard Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
Palavras-chave: 
kbsetup kbtshoot kbprb KB905726
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store