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Base de Dados de Conhecimento

ID do artigo: 910678 - Última revisão: quarta-feira, 29 de agosto de 2007 - Revisão: 2.2

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Sintomas

Quando você executa o Assistente de microinstalação Sysprep para instalar um Microsoft Windows XP com Service Pack 2 (SP2) imagem, o assistente pode parar de responder após inicia o processo de instalação do driver de vídeo. Esse problema ocorre se a entrada OempnpDriversPath no arquivo Sysprep.inf aponta para os Intel vídeo drivers mais recentes no site da Dell ou no site da Intel.

Você perceber esse problema se o driver de vídeo Intel é configurado usando o Services.exe - instalação comando.

Causa

Esse problema ocorre devido a um problema com o thread da interface (GUI) do usuário gráfica no processo do Services.exe. Quando inicia o processo Services.exe, os seguintes eventos ocorrem na seguinte ordem:
  1. Todos os arquivos .dll vinculadas estaticamente são inicializados.
  2. O arquivo Acgenral.dll carrega o arquivo Shell32.dll.
  3. O arquivo Shell32.dll carrega o arquivo Comctl32.dll embora Services.exe nunca usa este binário.
  4. Quando o segmento svcctrlMain para o arquivo Shell32.dll é executado um \ função, o thread svcctrlMain transforma em um thread de modo GUI. Além disso, o processo do Services.exe transforma em um processo no modo GUI.
  5. O thread svcctrlMain interrompe a execução quando o processo do Services.exe ainda está sendo executado.
Quando esses eventos ocorrerem, todos os aspectos modo GUI do Services.exe são concluídos, mas Services.exe não pode retornar ao modo de GUI.

Quando o co-instalador de driver de dispositivo Intel é iniciado no processo do Services.exe, a função UpdateDriverForPlugAndPlayDevices chama o arquivo Newdev.dll. O arquivo Newdev.dll é executado no contexto do Services.exe porque ele é um processo de plug and play. No entanto, não há nenhum aspecto de modo GUI para esse processo é visível para o usuário. Portanto, Newdev.dll cria um arquivo Silencioso apresenta algumas configurações de propriedade padrão. Em seguida, Newdev.dll tenta executar silenciosamente esse arquivo. No entanto, Newdev.dll não é possível executar este arquivo silenciosamente porque Services.exe não pode retornar ao modo de GUI.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows XP Service Pack 2 com (SP2) instalado no computador. Você deve ter todos as mais recentes disponíveis atualizações do Windows instaladas no computador. Você deve ter o hotfix KB883667 instalado no computador.

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação de serviço
Acadproc.dll5.1.2600.279539,42414 De novembro de 200514: 58x 86SP2SP2QFE

Mais Informações

Para obter mais informações sobre a terminologia padrão usada para descrever as atualizações de software da Microsoft, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software


Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Service Pack 2 nas seguintes plataformas
    • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbbug kbfix kbpubtypekc KB910678 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 910678  (http://support.microsoft.com/kb/910678/en-us/ )
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