DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 910813 - Última revisão: segunda-feira, 3 de março de 2014 - Revisão: 13.0

 

Nesta página

Sintomas

Ao tentar iniciar um dos jogos da Microsoft listados na seção "Aplica-se a", você recebe uma das seguintes mensagens de erro:
Mensagem de erro 1
D3dx9_25.dll o arquivo não foi encontrado
Mensagem de erro 2
D3dx9_27.dll o arquivo não foi encontrado

Causa

Esse problema pode ocorrer se o arquivo do Microsoft DirectX mencionada na mensagem de erro está corrompido ou não é copiado.

Resolução

Baixe e instale a versão mais recente do DirectX

Para resolver esse problema, baixe e instale a versão mais recente do DirectX End-User Runtimes Web Installer. Para fazer isso, visite o seguinte site da Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en)
Observação Você pode receber a seguinte mensagem de erro durante a instalação:
O software que você está instalando não passou no teste para verificar sua compatibilidade com esta versão do Windows do logotipo do Windows. (Diga-me por que este teste é importante.)
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
822798  (http://support.microsoft.com/kb/822798/ ) Não é possível instalar algumas atualizações ou programas

Copiar o arquivo manualmente

Para resolver esse problema, copie o arquivo D3dx9_25.dll ou o D3dx9_27.dll a partir do CD/1 DVD do CD/DVD do jogo pack correspondente na pasta jogo. Para fazer isso, execute as etapas apropriadas para sua versão do Windows:

O Windows 7 ou Windows Vista

  1. Insira o disco de CD/1 DVD para seu jogo intothe unidade de CD/DVD do computador.
  2. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    botão Iniciar
    e, em seguida, clique em documentos.
  3. Localize e, em seguida, clique em computador.
  4. Localize e, em seguida, clique na unidade de CD/DVD.
  5. Localize e clique na seguinte pasta:
    CDDrive:\ DirectX9
    Observação Nesse caminho, CDDriverepresenta a letra da unidade de CD.
  6. Clique duas vezes emApr2005_d3dx9_25_x86.cab, clique com o botãod3dx9_25.dlle, em seguida, clique em Copiar.
    Observação Use o arquivo Apr2005_d3dx9_25_x64.cab para o versionof com base em x64 do sistema operacional Windows.
  7. Localize o followingfolder para o seu jogo:
    Unidade: Games \ \Program Files\MicrosoftTítulo do jogo
    Observação Nesse caminho, Unidaderepresenta a letra da unidade em que o jogo está instalado, e Título do jogo representa o jogo que você deseja reparar.
  8. Botão direito do mouse a pasta do jogo que corresponde ao gamethat instalado no computador e, em seguida, clique emColar.

    Observação Se você instalou mais de um jogo no computador, repeatsteps 7 8 para os outros jogos.

Windows XP

  1. Insira o disco de CD/1 DVD para seu jogo intothe unidade de CD/DVD do computador.
  2. Clique em Iniciar, aponte paraprogramas, aponte para Acessóriose thenclick Windows Explorer.
  3. Localize e, em seguida, clique no followingfolder:
    CDDrive:\ DirectX9
    Observação Nesse caminho, CDDriverepresenta a letra da unidade de CD.
  4. Clique duas vezes emApr2005_d3dx9_25_x86.cab, clique com o botãod3dx9_25.dlle, em seguida, clique em Copiar.
    Observação Use o arquivo Apr2005_d3dx9_25_x64.cab para o versionof com base em x64 do sistema operacional Microsoft Windows.
  5. Localize a seguinte pasta do seu jogo:
    Unidade: Games \ \Program Files\MicrosoftTítulo do jogo
    Observação Nesse caminho, Unidade representa a letra da unidade da unidade em que o jogo está instalado, e Título do jogo representa o jogo que você deseja reparar.
  6. Botão direito do mouse a pasta do jogo que corresponde ao gamethat instalado no computador e, em seguida, clique emColar.

    Observação Se você tiver instalado mais de um jogo no computador, repeatsteps, 5 e 6 para os outros jogos.

Mais Informações

Se precisar de mais ajuda, visite o site Serviços de suporte técnico da Microsoft para encontrar outras soluções. Este site fornece os seguintes serviços:

A informação contida neste artigo aplica-se a:
  • Microsoft Flight Simulator X Deluxe
  • Microsoft Flight Simulator X Standard
  • Microsoft Flight Simulator X Acceleration Expansion Pack
  • Microsoft Flight Simulator X Service Pack 1
  • Microsoft Age of Empires III
  • Microsoft Age of Empires III : The WarChiefs
  • Microsoft Age of Empires III: The Asian Dynasties
  • Microsoft Dungeon Siege II
  • Fable: The Lost Chapters PC
  • Microsoft Gears of War (PC)
  • Microsoft Halo 2 for Windows Vista
  • Microsoft Shadowrun (PC)
  • Microsoft Viva Pinata (PC)
  • Microsoft Zoo Tycoon 2
  • Microsoft Zoo Tycoon 2: African Adventure
  • Microsoft Zoo Tycoon 2: Dino Danger
  • Microsoft Zoo Tycoon 2: Endangered Species
  • Microsoft Zoo Tycoon 2: Marine Mania
  • Microsoft Zoo Tycoon 2: Ultimate Collection
  • Microsoft Fable III for PC
Palavras-chave: 
dftsdahomeportal kberrmsg kbsetup kbtshoot kbmt KB910813 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.
Clique aqui para ver a versão em Inglês deste artigo: 910813  (http://support.microsoft.com/kb/910813/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store