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Base de Dados de Conhecimento

ID do artigo: 917777 - Última revisão: quarta-feira, 29 de agosto de 2007 - Revisão: 3.4

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Sintomas

Você pode enfrentar um ou mais dos seguintes problemas de impressora em um computador que esteja executando o Microsoft Windows Server 2003, Microsoft Windows XP ou Microsoft Windows 2000:
  • Quando você tenta abrir a caixa de diálogo Imprimir, ele demora muito para abrir.
  • Quando você usa o Assistente para adicionar impressora para instalar uma impressora de rede que está hospedada em um servidor que esteja executando o serviço SMB, o Assistente para adicionar impressora pode parar de responder. O problema ocorrer após os arquivos de driver são copiados.
  • Quando você seleciona uma impressora de rede diferentes na caixa nome da impressora no Assistente para adicionar impressora, pode haver um atraso antes que a alteração seja aplicada. Esse problema pode ocorrer mesmo que as condições na seção "Causa" não se aplicam à impressora de rede que você seleciona.

Causa

Esse problema ocorre devido a um erro no spooler (spoolss.dll). Esse problema ocorre se as seguintes condições forem verdadeiras:
  • O tamanho da estrutura DEVMODE usado pelo driver da impressora é maior do que 4.096 bytes.
  • O nome da impressora tem um número ímpar de caracteres. Por exemplo, o nome de impressora de rede seguintes, MyPrinterName contém um número ímpar de caracteres (13):
    \\SMBPrinterServer\ MyPrinterName
    O problema não ocorre se o nome da impressora tiver um número par de caracteres.

Resolução

Informações sobre o Windows Server 2003 service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix Windows Server 2003

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows Server 2003 Service Pack 1 (SP1) instalado no computador.

Observação Windows Server 2003, versões com base em 64 x não exigem Windows Server 2003 SP1 aplicar esse hotfix.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Spoolss.dll5.2.3790.2805167,93604 De outubro de 200617: 31x 64
Windows Server 2003, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Spoolss.dll5.2.3790.2805253,95204 De outubro de 200617: 32IA-64
Windows Server 2003, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Spoolss.dll5.2.3790.280587,55204 De outubro de 200617: 15x 86

Informações sobre o Windows XP hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows XP, x 86 versões
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Spoolss.dll5.1.2600.300874.75204 De outubro de 200617: 13x 86

Windows 2000

Para contornar esse problema no Windows 2000, use um número par de caracteres para o nome da impressora.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Server 2003 Service Pack 2.

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

Suporte técnico para versões com base em 64 x do Microsoft Windows

O fabricante do hardware fornece suporte técnico e assistência para versões com base em 64 x do Windows. O fabricante do hardware fornece suporte porque uma versão x 64 do Windows foi incluída com o hardware. O fabricante do hardware pode ter personalizado a instalação do Windows com componentes exclusivos. Componentes exclusivos podem incluir drivers de dispositivo específico ou podem incluir configurações opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se precisar de ajuda técnica com sua versão de 64 x do Windows. No entanto, talvez você precise entrar em contato com o fabricante diretamente. O fabricante do seu melhor é qualificado para suportar o software que o fabricante do seu instalado no hardware.

Para informações de produto sobre o Microsoft Windows XP Professional x 64 Edition, visite o seguinte site:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Para informações de produto sobre versões com base em 64 x do Microsoft Windows Server 2003, visite o seguinte site:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003presp2fix kbbug kbfix kbqfe kbhotfixserver kbpubtypekc KB917777 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 917777  (http://support.microsoft.com/kb/917777/en-us/ )
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