DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 925757 - Última revisão: segunda-feira, 4 de maio de 2015 - Revisão: 5.0

 

Nesta página

INTRODUÇÃO

Este artigo descreve passo a passo como ativar ou desativar a exibição de uma mensagem de aviso toda vez que você clicar em um hiperlink em um programa do Microsoft Office 2007 ou em um programa do Microsoft Office 2010.

Mais Informações

Importante: Essa seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Portanto, certifique-se de seguir estes passos cuidadosamente. Para obter mais proteção, faça backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro caso ocorra um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número do artigo a seguir para visualizá-lo na Base de Conhecimento Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows


No Office 2007 e no Office 2010, quando você clica em um hiperlink ou em um objeto que se vincula a um arquivo executável, a seguinte mensagem aviso é exibida:
Abrindo "caminho/nome_do_arquivo".
Hiperlinks podem ser prejudiciais ao seu computador e aos seus dados. Para proteger seu computador, clique somente nos hiperlinks de fontes confiáveis. Você deseja continuar?
Esse comportamento ocorre independentemente das suas configurações de nível de segurança.

Observação: Para localizar as configurações de nível de segurança, aponte para Macro no menu Ferramentas e, em seguida, clique em Segurança.

Além disso, quando você abrir imagens TIFF ou arquivos de imagem MDI (Microsoft Document), você recebe a seguinte mensagem de aviso:
Abrindo "caminho/nome_do_arquivo".
Alguns arquivos podem conter vírus ou serem prejudiciais ao seu computador. É importante saber se este arquivo provém de uma fonte confiável. Você gostaria de abrir este arquivo?
Você recebe essa mensagem de aviso, mesmo que você já tenha implementado a chave do registro descrita neste artigo. Essa mensagem de aviso vem do arquivo HLINK.dll quando o link de navegação é tratado. Você pode diferenciar o Office 2007 ou mensagem de aviso de hiperlink do Office 2010 da mensagem de aviso HLINK olhando para o caminho do arquivo na mensagem de aviso entre aspas. A mensagem do Office 2007 ou do Office 2010 contém aspas. A mensagem HLINK não contém aspas. O Office 2007 e o Office 2010 tentam determinar se o tipo de arquivo não é seguro, verificando a extensão, o progid, classid e o tipo de MIME do documento.

Como ativar ou desativar avisos de hiperlink globalmente

Para que possamos habilitar avisos de hiperlink para o 2007 Office programas e para o Office 2010 programas para você, vá para a "Corrigir para mim"a seção. Se você preferir habilitar a configuração sozinho, vá para a "Desejo corrigir sozinho"a seção.

Corrigir para mim



Para corrigir esse problema automaticamente, clique no botão Corrigi-lo ou no link. Na caixa de diálogo Download de Arquivo , clique em Executar e, em seguida, siga as etapas no Assitente de Correção.
Recolher esta imagemExpandir esta imagem
Habilitar avisos de hiperlink (http://go.microsoft.com/?linkid=9773262)
Microsoft Fix it 50681
Recolher esta imagemExpandir esta imagem


Observação
  • Este assistente pode estar apenas em inglês. No entanto, a correção automática também funciona em outras versões de idioma do Windows.
  • Se você não estiver no computador que apresentou o problema, salve a solução encontrada pelo Fix it em uma unidade flash ou em um CD e execute-o no computador que apresentou o problema.

Em seguida, vá para a "O problema foi corrigido?"a seção.



Desejo corrigir sozinho

Para ativar ou desativar os avisos de hiperlink nos programas do Office 2007 e nos programas do Office 2010 quando um endereço http:// address, a notes:// address ou um ftp:// address for usado, você deve criar uma nova subchave de registro. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar, e em seguida, clique em Executar.
  2. Na caixa de diálogo Abrir , digite regedit e, em seguida, clique em OK.

    Observação
    • Você precisará modificar apenas uma dessas subchaves do registro. Você não precisa modificar ambas.
    • Se a subchave de segurança já existir, vá diretamente para a etapa 6 após selecionar a subchave de segurança.
  3. No Editor do registro, localize uma das seguintes subchaves de registro do Office 2007:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common
    Ou, no Editor de registro, localize uma das seguintes subchaves de registo do Office 2010:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common
  4. Clique na subchave do registro, aponte para novo no menu Editar e, em seguida, clique em chave.
  5. Tipo Segurança, e então pressione Enter para indicar a chave.
  6. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD.
  7. Tipo DisableHyperlinkWarning, e então pressione Enter para nomear a entrada.
  8. No painel direito, clique com o botão DisableHyperlinkWarning e, em seguida, clique em Modificar.
  9. Na caixa de diálogo Editar valor DWORD , clique Decimale digite 1 ou 0 em dados do valor.

    Observação: Um valor 0 habilita a mensagem de aviso de hiperlink. Um valor de 1 desabilita a mensagem de aviso de hiperlink.
  10. Clique em OK.
  11. Saia do Editor de Registro.

Como ativar ou desativar avisos de hiperlink por protocolo

Para desativar a exibição de avisos de segurança para um protocolo específico, siga estas etapas:
  1. Clique em Iniciar, Executar, tipo Regedite, em seguida, clique em OK.
  2. Localize a seguinte subchave do registro:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\xx.0\Common\Security\Trusted Protocols\All Applications
    Observação: Nessa subchave, substitua "xx.0" 12.0 para o Outlook 2007 e com 14.0 para o Outlook 2010.
  3. Clique na subchave de todos os Aplicativos.
  4. No menu Editar , aponte para Novo e, em seguida, clique em Chave.
  5. Digite o nome do protocolo que você deseja excluir. Por exemplo, para desativar a exibição de um aviso de segurança para as "notas:" protocolo, digite Observações:.

    Observação
    Certifique-se de que você incluir o caractere de dois-pontos (:).
  6. Pressione Enter.
  7. Saia do Editor de Registro.

Se você ainda receber uma mensagem de aviso

Após você desativar mensagens de aviso, você ainda pode receber uma mensagem de aviso do Microsoft Windows. Se você continuar recebendo uma mensagem de aviso depois de executar as etapas neste artigo, use um dos seguintes métodos para resolver o problema.

Observação: Método 1 se aplica apenas ao Windows XP e a versões anteriores do Windows. Para o Windows Vista e versões posteriores do Windows, use o método 2.

Método 1: Desativar a opção "Confirmar abertura após download" para o tipo de arquivo que você está tentando abrir

  1. Clique duas vezes em Meu Computador.
  2. No menu Ferramentas , clique em Opções de Pasta.
  3. Na guia Tipos de Arquivo , selecione a extensão de nome de arquivo apropriado (por exemplo, WMV) na caixa Tipos de Arquivo Registrados e, em seguida, clique em Avançado.
  4. Clique para desmarcar a caixa de seleção Confirmar abertura após o download e, em seguida, clique em OK.
  5. Na caixa de diálogo Opções de Pasta , clique em Fechar.

Método 2: Modificar a HKEY_CLASSES_ROOT \<CLSID>subchave de registro \EditFlags</CLSID>

Use este método se a mensagem de aviso afetar vários computadores.

Para desativar a mensagem de aviso, execute as seguintes etapas:
  1. Clique em Iniciar, Executar, tipo Regedite, em seguida, clique em OK.
  2. Localize a seguinte subchave do registro:
    HKEY_CLASSES_ROOT\<CLSID>\EditFlags
    Por exemplo, se a extensão de nome de arquivo WMV, selecione HKEY_CLASSES_ROOT\WMVFile\EditFlags
  3. Clique em EditFlags e, em seguida, clique em Renomear no menu Editar .
  4. Tipo OldEditFlags, e então pressione ENTER.
  5. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD.
  6. Tipo EditFlags, e então pressione ENTER.
  7. No menu Editar , clique em Modificar.
  8. Na caixa de diálogo Editar Valor DWORD , clique em Hexadecimal em Base.
  9. Tipo 10000e, em seguida, clique em OK.
Para ativar novamente a mensagem de aviso, execute as seguintes etapas:
  1. Clique em Iniciar, Executar, tipo Regedite, em seguida, clique em OK.
  2. Localize a seguinte subchave do registro:
    HKEY_CLASSES_ROOT\<CLSID>\EditFlags
  3. Clique em EditFlags e, em seguida, no menu Editar , clique em Modificar .
  4. Tipo 0e, em seguida, clique em OK.

Observação: Mesmo depois de executar essas etapas, você receberá a mensagem de aviso se você abrir arquivos no Office 2010 em Modo de Exibição Protegido.



O problema foi corrigido?

  • Verifique se o problema foi corrigido. Se o problema tiver sido corrigido, você terá concluído esta seção. Se o problema não for corrigido, você poderá Contate o suporte (http://support.microsoft.com/contactus) .
  • Aguardamos seus comentários. Para fornecer comentários ou relatar quaisquer problemas com essa solução, deixe um comentário sobre o "Corrigir para mim (http://blogs.technet.com/fixit4me/) "blog, ou envie-em um e-mail (mailto:fixit4me@microsoft.com?Subject=KB) para que possamos atendê-lo ainda melhor.

A informação contida neste artigo aplica-se a:
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Access 2007
  • Microsoft Office Excel 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office SharePoint Designer 2007
  • Microsoft Office Word 2007
  • Microsoft Excel 2010
  • Microsoft Word 2010
  • Microsoft PowerPoint 2010
  • Microsoft Publisher 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Outlook 2010
  • Microsoft OneNote 2010
  • Microsoft Office Home and Business 2010
  • Microsoft Office Home and Student 2010
  • Microsoft Office Professional 2010
Palavras-chave: 
kbexpertisebeginner kbhowto kbfixme kbmsifixme kbmt KB925757 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.
Clique aqui para ver a versão em Inglês deste artigo: 925757  (http://support.microsoft.com/kb/925757/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store