DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 928491 - Última revisão: quinta-feira, 15 de novembro de 2007 - Revisão: 2.2

Download do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
 
 
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows

Nesta página

Sintomas

Quando você navega por um aplicativo da Web Microsoft ASP.NET no Microsoft Internet Explorer 6, clique no botão Voltar . No entanto, o Internet Explorer não exibe a página da Web anterior. Em vez disso, Internet Explorer incorretamente continua a exibir a página atual. Esse problema ocorre se as seguintes condições forem verdadeiras:
  • Você está executando o Microsoft Windows XP Service Pack 2 (SP2).
  • O método de compactação GZIP é habilitado no servidor Web que hospeda o aplicativo ASP.NET.
  • O aplicativo ASP.NET executa uma solicitação de postback.

Causa

Esse problema ocorre porque Internet Explorer acrescenta um cookie interno à entrada de cache do aplicativo ASP.NET se ocorrer uma solicitação de postback. Além disso, o cookie interno é usado para localizar a página anterior. Se o método de compactação GZIP estiver ativado, uma nova entrada de cache é acrescentada sem o cookie interno. Por isso, a página anterior não pode ser encontrada no cache quando você clica no botão Voltar .

Resolução

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Você deve ter o Microsoft Windows XP Service Pack 2 (SP2) instalado para aplicar esse hotfix.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes que são aplicados no computador.

Informações do registro

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Após você aplica o hotfix, é necessário modificar as configurações de registro para permitir que o hotfix. Você pode modificar as configurações do Registro para um usuário específico ou para todos os usuários.

Configurações do Registro para um usuário específico

Use um dos seguintes métodos para habilitar o hotfix para um usuário específico.
Método 1
Execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte chave no Registro:
    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para novo e, em seguida, clique em chave .
  4. Digite FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 e, em seguida, pressione ENTER.
  5. No menu Editar , aponte para novo e, em seguida, clique em Valor da seqüência .
  6. Tipo * , e, em seguida, pressione ENTER.
  7. No menu Editar , clique em Modificar .
  8. Digite 1 e, em seguida, clique em OK .
  9. No menu arquivo , clique em Sair .
Método 2
Execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte chave no Registro:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para novo e, em seguida, clique em chave .
  4. Digite FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 e, em seguida, pressione ENTER.
  5. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  6. Tipo * , e, em seguida, pressione ENTER.
  7. No menu Editar , clique em Modificar .
  8. Digite 1 e, em seguida, clique em OK .
  9. No menu arquivo , clique em Sair .

Configurações do Registro para todos os usuários

Use um dos seguintes métodos para habilitar o hotfix para todos os usuários.
Método 1
Execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte chave no Registro:
    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para novo e, em seguida, clique em chave .
  4. Digite FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 e, em seguida, pressione ENTER.
  5. No menu Editar , aponte para novo e, em seguida, clique em Valor da seqüência .
  6. Tipo * , e, em seguida, pressione ENTER.
  7. No menu Editar , clique em Modificar .
  8. Digite 1 e, em seguida, clique em OK .
  9. No menu arquivo , clique em Sair .
Método 2
Execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK
  2. Localize e, em seguida, clique na seguinte chave no Registro:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para novo e, em seguida, clique em chave .
  4. Digite FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 e, em seguida, pressione ENTER.
  5. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  6. Tipo * , e, em seguida, pressione ENTER.
  7. No menu Editar , clique em Modificar .
  8. Digite 1 e, em seguida, clique em OK .
  9. No menu arquivo , clique em Sair .

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Urlmon.dll6.0.2900.3038600,06420 De novembro de 200613: 49x 86

Como Contornar

Para contornar esse problema, instale o Microsoft Internet Explorer 7.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbpubtypekc KB928491 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 928491  (http://support.microsoft.com/kb/928491/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store