DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 932471 - Última revisão: quarta-feira, 10 de setembro de 2008 - Revisão: 2.0

Download do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
 
 

Nesta página

Sintomas

Quando você tenta abrir ou criar um documento XML Paper Specification (XPS) protegido usando o visualizador XPS que acompanha o Microsoft .NET Framework 3.0, você receber a seguinte mensagem de erro:
Não é possível abrir este documento porque suas permissões expiraram.
Observação O visualizador XPS é um componente do Microsoft .NET Framework 3.0. O .NET Framework 3.0 está incluído no Windows Vista.

Causa

O visualizador XPS usa a funcionalidade Rights Management Services (RMS) no Microsoft Windows para criar e abrir documentos XPS protegido por RMS. O RMS usa um arquivo de manifesto XML para armazenar informações de configuração.

O problema descrito na seção "Sintomas" ocorre porque o arquivo de manifesto define uma data de expiração incorreto para a funcionalidade de RMS do visualizador XPS. Se a data do sistema é posterior à data de validade que define o arquivo de manifesto, você receberá a mensagem de erro mencionada na seção "Sintomas". Por exemplo, se o arquivo de manifesto define a data de validade para 31 de dezembro de 2006, e a data do sistema for posterior a 31 de dezembro de 2006, esse problema ocorre.

Resolução

Informações sobre o hotfix

Um hotfix está incluído no .NET Framework 3.5 e no .NET Framework 3.5 Service Pack 1. Para resolver imediatamente esse problema, instale a versão mais recente do .NET Framework usando o Windows Update. Ou, baixe o service pack mais recente do site da Microsoft:
http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en (http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en)

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft .NET Framework 3.0
  • Microsoft .NET Framework 3.5 Service Pack 1
Palavras-chave: 
kbmt kbvistasp1fix kbhotfixserver kbqfe kbpubtypekc KB932471 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 932471  (http://support.microsoft.com/kb/932471/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store