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Base de Dados de Conhecimento

ID do artigo: 943459 - Última revisão: segunda-feira, 13 de julho de 2009 - Revisão: 2.0

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Sintomas

Considere o seguinte cenário:
  • Um cliente cria uma conexão de SMB (bloco) do servidor mensagem com um servidor baseado no Windows Server 2003 usando o protocolo de autenticação Kerberos versão 5.
  • Um arquivo é aberto através dessa conexão SMB. Um bloqueio oportunista (bloqueio) é definido no arquivo.
  • Após um tempo longo ocioso, o tíquete do Kerberos expira.
Nesse cenário, o servidor tenta quebrar o bloqueio. No entanto, um longo atraso ocorre antes do bloqueio eventualmente é quebrado no servidor. Além disso, o cliente recebe um erro de "status_network_session_expired".

Causa

O servidor envia uma solicitação para o cliente para quebrar o bloqueio. Em seguida, o cliente responde a essa solicitação. O servidor retorna o erro "status_network_session_expired" em vez de processar a resposta do cliente, porque a sessão já expirou. No entanto, o cliente não é possível autenticar novamente com o servidor. Nessa situação, o servidor tem um tempo longo para o bloqueio para tempo limite de espera.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows Server 2003 Service Pack 1 ou Windows Server 2003 2 instalado no computador. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003 com Service Pack 1, versões com base em 86 x
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Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
SRV.sys5.2.3790.3076361.47222 De janeiro de 200811: 08x 86
Windows Server 2003 com Service Pack 2, x 86-based versões
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Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
SRV.sys5.2.3790.4222358,40022 De janeiro de 200811: 18x 86
Windows Server 2003 com Service Pack 1, versões com base em Itanium
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Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
SRV.sys5.2.3790.30761,110,52822 De janeiro de 200815: 56IA-64
Windows Server 2003 com Service Pack 2, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
SRV.sys5.2.3790.42221,111,04022 De janeiro de 200816: 18IA-64
Windows Server 2003 com Service Pack 1, versões com base em 64 x
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Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
SRV.sys5.2.3790.3076674,30422 De janeiro de 200815: 49x 64
Windows Server 2003 com Service Pack 2, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
SRV.sys5.2.3790.4222647,68022 De janeiro de 200816: 19x 64

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Como Contornar

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows
Para contornar esse problema, reduza o valor do bloqueio quebra de tempo limite para menos de 35 segundos para reduzir o tempo que o servidor espera antes de ele interrompe uma bloqueio. No entanto, você deve ser muito cuidado ao usar essa solução, porque essa solução alternativa pode causar efeitos negativos, como perda de dados em cache, dependendo do seu ambiente.

Para alterar o valor de tempo limite de quebra de bloqueio, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize a seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. Use uma das opções a seguir, conforme apropriado para sua situação:
    1. Se a entrada de registro OplockBreakWait estiver disponível sob a subchave parâmetros, vá para a etapa 5.
    2. Se a entrada de registro OplockBreakWait não estiver disponível, você deve criar esta entrada. Para fazer isso, clique com o botão direito do mouse a subchave parâmetros, aponte para novo e, em seguida, clique em Valor DWORD .
  4. Digite OplockBreakWait e, em seguida, pressione ENTER.
  5. Clique com o botão direito do mouse OplockBreakWait e, em seguida, clique em Modificar .
  6. Na caixa dados do valor , digite um valor apropriado e, em seguida, clique em OK .
  7. Feche o Editor do Registro.
  8. Reinicie o computador.
Observação A entrada de registro OplockBreakWait Especifica o tempo que o servidor aguarda para um cliente responder a uma solicitação de quebra de bloqueio. Por padrão, o servidor espera 35 segundos antes de ele divide uma bloqueio por força. Você pode especificar um valor menor para essa entrada do Registro para reduzir o tempo de espera. No entanto, um menor tempo de espera pode potencialmente causar perda de dados armazenados em cache. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
296264  (http://support.microsoft.com/kb/296264/ ) Configurando o bloqueio oportunista no Windows

Mais Informações

Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe KB943459 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 943459  (http://support.microsoft.com/kb/943459/en-us/ )
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