DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 981259 - Última revisão: sexta-feira, 29 de março de 2013 - Revisão: 1.0

Download do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
 
 

Nesta página

Sintomas

Um controlador de domínio que esteja executando o Windows Server 2003 Service Pack 2 (SP2) pára de responder intermitentemente.

Observação Você deve reiniciar o controlador de domínio para recuperar o problema.

Quando esse problema ocorre, os seguintes eventos são registrados no log do serviço de diretório:

Tipo de evento: erro
Origem do evento: NTDS ISAM Categoria do evento: (14)
Identificação de evento: 623
Descrição:
NTDSA NTDS (412): O armazenamento de versão para esta instância (0) atingiu seu tamanho máximo de <number></number>. É provável que uma transação de longa duração está impedindo a limpeza de armazenamento de versão e fazendo com que ele aumente de tamanho. As atualizações serão rejeitadas até que a transação de longa duração foi completamente confirmada ou revertida.
Transação de longa duração possível:
SessionId: <id></id>
Contexto de sessão: <context></context>
Contexto de sessão ThreadId: <id></id>
Limpeza: 1

Tipo de evento: aviso
Origem do evento: NTDS geral
Categoria do evento: Processamento interno
Identificação de evento: 1173
Descrição:
Evento interno: Active Directory tem encontrou a seguinte exceção e parâmetros associada.
Exceção: c0000005
Parâmetro: 0
Dados adicionais
Valor de erro: <value></value>
Identificação interna: <id></id>

Observações
  • Evento 1173 é registrado somente quando o log de diagnóstico é aumentado para 4/5.
  • Evento 1173 e evento 623 não estão conectados ao mesmo tempo. Evento 1173 geralmente é registrado algum tempo antes do evento 623 é registrado. O intervalo de tempo pode ser várias horas.

Causa

Esse problema ocorre porque o agente de sistema de diretório (DSA) (Ntdsa. dll) não inicializar uma estrutura depois que a estrutura é alocada. Quando essa estrutura não inicializada é acessada, ocorre uma exceção de violação de acesso. A exceção termina o thread atual e limpar as transações. Portanto, essas transações se acumulam no armazenamento de versão. Quando o armazenamento de versão está cheio, o controlador de domínio pára de responder.

Resolução

Informações sobre hotfix

Um hotfix compatível está disponível na Microsoft. No entanto, esse hotfix destina-se apenas a corrigir o problema descrito neste artigo. Aplica esse hotfix somente aos sistemas que apresentarem o problema descrito neste artigo. Esse hotfix pode receber testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não for exibido, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou qualquer solução de problemas for necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a perguntas de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e atendimento ao cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?WS=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, seu computador deve estar executando o Windows Server 2003 Service Pack 2 (SP2). Além disso, esse computador deve ser um controlador de domínio.

Para obter mais informações sobre como obter um Windows Server 2003 service pack, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para Windows Server 2003

Requisito de reinicialização

Você terá que reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo

A versão em inglês (Estados Unidos) deste hotfix instala arquivos que tenham os atributos listados nas tabelas a seguir. As datas e horários desses arquivos estão listados em formato Tempo Universal Coordenado (UTC). As datas e horários desses arquivos no computador local são exibidos em sua hora local com a diferença do horário de verão (DST) atual. Além disso, as datas e horas podem ser alteradas quando você executa certas operações nos arquivos.
Observações de informações de arquivo do Windows Server 2003
  • Além dos arquivos listados nessas tabelas, esse hotfix também instala um arquivo de catálogo de segurança associadas (KBnúmero. cat) que está assinado com uma assinatura digital da Microsoft.
Para todas as versões baseadas em x86 compatíveis do Windows Server 2003 Service Pack 2 (SP2)
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Ntdsa. dll5.2.3790.46741,527,80803 De março de 201008:27x86
Para todas as versões baseadas em x64 com suporte do Windows Server 2003 Service Pack 2 (SP2)
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataformaRequisito de SPRamificação do serviço
Ntdsa. dll5.2.3790.46742,975,23203 De março de 201006:20x64SP2Não aplicável
Wntdsa.dll5.2.3790.46741,527,80803 De março de 201006:20x86SP2WOW
Para todas as versões compatíveis baseadas em IA-64 do Windows Server 2003 Service Pack 2 (SP2)
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataformaRequisito de SPRamificação do serviço
Ntdsa. dll5.2.3790.46744,282,88003 De março de 201006:20IA-64SP2Não aplicável
Wntdsa.dll5.2.3790.46741,527,80803 De março de 201006:20x86SP2WOW

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
314980  (http://support.microsoft.com/kb/314980/ ) Como configurar o log de eventos de diagnóstico do Active Directory no Windows Server 2003 e no Windows 2000 Server
Para obter mais informações sobre o armazenamento de dados, visite o seguinte site da TechNet:
Funciona como o armazenamento de dados (http://technet.microsoft.com/en-us/library/cc772829(WS.10).aspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Service Pack 2 nas seguintes plataformas
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Palavras-chave: 
kbautohotfix kbhotfixserver kbfix kbsurveynew kbqfe kbexpertiseadvanced kbmt KB981259 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 981259  (http://support.microsoft.com/kb/981259/en-us/ )
Compartilhar
Opções de suporte adicionais
Fóruns de Suporte do Microsoft Community
Contate-nos diretamente
Localize um parceiro certificado da Microsoft
Microsoft Store