DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 149083 - Última revisão: sexta-feira, 19 de janeiro de 2007 - Revisão: 1.4

 

Sintomas

Quando você usa um computador que está executando o Windows 95, Windows 98 ou Windows Millennium Edition (Me), você pode receber uma das seguinte mensagem de erro:
Não existem páginas pilha sobressalentes. Talvez seja necessário aumentar a configuração de 'MinSPs' em System.ini para evitar falhas de pilha possíveis. Não há nnn SPs alocados.
Thread de finalização devido a problema de estouro de pilha. Um vxd consumidos muito espaço em pilha. Aumentar a configuração de MinSPs em System.ini ou remova do vxd instalado recentemente. Não há nnn SPs alocados. Pressione qualquer tecla para continuar.

Causa

Esse comportamento pode ocorrer quando o Windows encontra um estouro interno de pilhas usados por drivers de dispositivo baseado no Windows de 32 bits. Verifique Observe que isso não relacionados ao "STACKS =" linha no arquivo config.sys, que é usado para drivers de dispositivo baseado no MS-de 16 bits.

Condições de estouro de pilha são indicativo de erros no driver do dispositivo. Drivers de dispositivo são alocados 4 kilobytes (KB) ou uma página, de espaço a ser usado como uma pilha. Se o driver de dispositivo usa mais de 4 KB de memória, ocorre uma condição de estouro de pilha.

Windows separa um número de páginas de memória extra ou páginas de pilha sobressalente, a ser usado temporariamente para que seu computador não pára de responder (travar) devido a uma condição de estouro de pilha. Quando a condição de estouro de pilha tiver passado, o Windows recupera a página temporária. O número de páginas de pilha sobressalentes padrão é dois.

Se o Windows detecta que ele ficou sem páginas de pilha disponível, você receberá a mensagem de erro mencionada na seção "Sintomas" deste artigo. Windows continua a funcionar corretamente, a menos que um driver de dispositivo encontra uma condição de estouro de pilha quando não existem páginas livre de pilha sobressalentes.

Resolução

Para resolver esse comportamento, adicione a seguinte linha à seção [386Enh] do arquivo System.ini e reinicie o computador:
MinSPs = 4
Se o comportamento persistir, aumente o número de páginas de pilha sobressalentes em incrementos de 4 (por exemplo, 8, 12, 16).

Observação : cada página de pilha sobressalentes requer 4 KB de memória.

Para editar o arquivo System.ini para o Windows 95, 98 e 98se:
  1. Clique em Iniciar , clique em Executar , digite sysedit na caixa Abrir e, em seguida, clique em OK .
  2. Clique em System.ini no menu janela .
  3. Na seção [386Enh], digite a seguinte linha:
    MinSPs = 4
  4. No menu arquivo , clique em Sair e clique em Sim para salvar as alterações.
  5. Reinicie o computador.
Para editar o arquivo System.ini para o Windows Me:

  1. Clique em Iniciar , clique em Procurar, arquivos ou pasta s.
  2. Na caixa "Procurar por arquivos ou pastas nomeados" digite "System.ini" (sem as aspas) e certifique-se de que a caixa drop-down 'Examinar' lista "disco rígido local (C:). Clique no botão Localizar agora .
  3. Quando os resultados da pesquisa aparecem no painel à direita, não se esqueça clique duas vezes no arquivo System.ini que é arquivo listado C:\Windows "Na pasta". Isso deve abrir o arquivo System.ini dentro do bloco de notas.
  4. Na seção [386Enh], adicionar ou editar a seguinte linha como applicible:
    "MinSPs = 4" (sem as aspas)
  5. No menu Arquivo, clique em Salvar , em seguida, clique no menu arquivo novamente e clique em Sair .
  6. Reinicie o computador.

Mais Informações

Observação : as seguintes informações provenientes de fontes de fora da Microsoft. A Microsoft fornece-la para você como uma cortesia e não verificou a precisão e a validade.

Se você estiver executando o Norton AntiVirus pela Symantec, você pode visitar o seguinte URL para obter informações do site da Symantec:
http://service1.symantec.com/SUPPORT/nav.nsf/aab56492973adccd8825694500552355/7c1f9d53b991d7c688256541006b00c3?OpenDocument (http://service1.symantec.com/SUPPORT/nav.nsf/aab56492973adccd8825694500552355/7c1f9d53b991d7c688256541006b00c3?OpenDocument)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Palavras-chave: 
kbmt kbenv kberrmsg kbprb KB149083 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 149083  (http://support.microsoft.com/kb/149083/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft