DetailPage-MSS-KB

Base de Dados de Conhecimento

ID do artigo: 222101 - Última revisão: terça-feira, 22 de novembro de 2005 - Revisão: 6.4

 

Nesta página

Sumário

Este artigo descreve os recursos e documentações disponíveis para você para automatizar aplicativos do Microsoft Office. Essas informações podem ser aplicadas independentemente da definição da linguagem de programação que você escolher para automatizar um aplicativo do Office. Este artigo também ilustra como você pode começar escrever código de automação através da execução passo você a documentação para encontrar as informações que você precisa realizar uma tarefa específica por meio de automação.

Mais Informações

Onde posso encontrar a documentação do modelo de objeto?

Os modelos de objeto para os aplicativos do Office estão documentados em uma referência de linguagem para ambas as versões do Office: Microsoft Office 97 Visual Basic for Applications Language Reference
ISBN 1-57231-339-0

Microsoft Office 2000 Visual Basic for Applications Language Reference
ISBN 1-57231-955-0.
A referências de idioma estão disponíveis no MSDN e na Ajuda online fornecida com o Microsoft Office. Eles também podem ser adquiridos em formato impresso. Para pedir informações, visite:
http://mspress.Microsoft.com
A tabela a seguir lista os arquivos de Ajuda para cada aplicativo do Office.

Recolher esta tabelaExpandir esta tabela
AplicativoVersão 97 (ou 8.0)Versão 2000 (ou 9.0)Versão 2002 (ou 10)Versão 2003 (ou 11)
OfficeVbaoff8.hlpVbaoff9.chmVbaof10.chmVbaof11.chm
AcessoAcvba80.hlpAcmain9.chmAcmain10.chm, Vbaac10.chmACMAIN11.chm, VBAAC10.chm
ExcelVbaXl8.hlpVbaxl9.chmVbaxl10.chmVBAXL10.chm
MapPointN/DMappoint.chm (ver.2001)Mappoint.chmMAPPOINT.chmn (versão 2004)
OutlookVbaoutl.hlpVbaoutl9.chmVbaol10.chmVBAOL11.chm
PowerPointVbappt.hlpVbappt9.chmVbapp10.chmVBAPP10.chm
WordVbawrd8.hlpVbawrd9.chmVbawd10.chmVBAWD10.chm
GráficoVbagrp8.hlpVbagrp9.chmVbagr10.chmVBAGR10.chm
FrontPageN/DVbafp4.chm, Vbafpom4.chmVbafpd10.chm, vbafpw10.chmVBAFPD10.chm, VBAFPW10.chm
FichárioVbabdr8.hlpVbabdr8.hlpDescontinuado


Os arquivos de Ajuda que acompanham o Microsoft Office 97 são instalados por padrão em:
C:\Arquivos de programas\Microsoft Office\Office
Se você não conseguir localizar o arquivo de Ajuda do Office 97 VBA que necessário, ele provavelmente não foi instalado quando você inicialmente executou a instalação do Office 97. Para instalar o arquivo de Ajuda, execute a instalação do Office para adicionar o arquivo de ajuda VBA. Observe que o arquivo de ajuda VBA do Outlook 97 não é instalado pela instalação do Office. Para informações sobre como instalar o arquivo de ajuda VBA do Outlook 97, consulte o seguinte artigo na Base de dados de Conhecimento da Microsoft:
166738  (http://support.microsoft.com/kb/166738/ ) OL97: Como instalar a Ajuda do Visual Basic
Os arquivos de Ajuda que acompanham o Microsoft Office 2000 são instalados por padrão em:
C:\Arquivos de Programas\Microsoft Office\Office\1033
Os arquivos de Ajuda que acompanham o Microsoft Office são instalados por padrão em:
C:\Program Files\Microsoft Office\Office10\1033
C:\Program Files\Microsoft Office\Office11\1033
Observação : programas do Microsoft Office 2000, Microsoft Office XP e instalação do Microsoft Office 2003 instalar os arquivos ajuda VBA "no primeiro uso." Portanto, você não pode consulte o arquivo de ajuda nesse diretório se você não anteriormente tentou acessar a Ajuda do VBA no aplicativo do Office.

Como é possível usar a documentação do modelo de objeto?

Há vários métodos que você pode usar para encontrar a documentação para uma classe específica, método ou propriedade:
  • Pesquise o arquivo de ajuda VBA:

    No Visual Basic Editor do aplicativo do Office, clique em conteúdo e índice no menu Ajuda . Na guia conteúdo , selecione a referência de idioma desejado e clique em Exibir . A Ajuda do VBA para a referência da linguagem escolhida aparece. Neste ponto, você pode usar tanto o índice ou na guia Localizar para localizar informações sobre uma classe específica, método ou propriedade.
  • Use ajuda contextual em um módulo ou no Painel imediato:

    No Visual Basic Editor do aplicativo do Office, digite a classe, método ou propriedade na janela de código de um módulo ou na Janela imediata , realce o texto e pressione a tecla F1. O tópico da Ajuda para o item é exibido.
  • Use o Pesquisador de objetos:

    Pressione a tecla F2 no Editor do Visual Basic aplicativo do Office exibir o Pesquisador de objetos . O Pesquisador de objetos lista todas as classes que expõe o aplicativo e os métodos ou propriedades associadas a cada classe. Para exibir a Ajuda em uma classe específica ou um membro da classe, selecione-o no Pesquisador de objetos e pressione a tecla F1.

Como posso saber quais classes, métodos e propriedades para usar?

Se você já não estiver familiarizado com o modelo de objeto do aplicativo que você pretende automatizar, você pode usar o gravador de macro do aplicativo para ter uma idéia. Para ilustrar, suponha que você deseja automatizar o Microsoft Word para adicionar algum texto para um novo documento e, em seguida, salvar o documento, mas você não souber quais métodos e propriedades para usar; você pode iniciar com o gravador de macro:
  1. Inicie o Microsoft Word.
  2. Clique em macro no menu Ferramentas e clique em Gravar nova macro . Anote o nome da nova macro e clique em OK para iniciar a gravação.
  3. Inicie um novo documento.
  4. Digite um e pressione a tecla ENTER.
  5. Digite dois e pressione a tecla ENTER.
  6. Digite três .
  7. Clique em Salvar no menu arquivo e salve o documento como "C:\doc1.doc."
  8. Clique no botão Parar gravação (ou clique em macro no menu Ferramentas e selecione Parar gravação ).
  9. Para exibir o código VBA que gerou o gravador de macro de suas ações, clique em macro no menu Ferramentas e selecione macros . Selecione o nome da nova macro na lista e clique em Editar . O Editor do Visual Basic aparece com a macro gravada:
     Documents.Add
     Selection.TypeText Text:="one"
     Selection.TypeParagraph
     Selection.TypeText Text:="two"
     Selection.TypeParagraph
     Selection.TypeText Text:="three"
     ActiveDocument.SaveAs FileName:="Doc1.doc", FileFormat:=wdFormatDocument,_
       LockComments:=False, Password:="", AddToRecentFiles:=True, _ 
       WritePassword:="", ReadOnlyRecommended:=False, _
       EmbedTrueTypeFonts:=False, SaveNativePictureFormat:=False, _
       SaveFormsData:=False, SaveAsAOCELetter:= False
    					
Você pode se beneficiar bastante dos Noções básicas sobre como cada classe ajusta o modelo de objeto e aprender a descrição e o tipo de todos os parâmetros para os métodos e propriedades que você usar.

Iniciar com examinando a primeira linha da macro gravada: Documents.Add. Realce documentos no módulo de código para a macro gravado e pressione a tecla F1. O tópico da Ajuda fornece importantes informações a seguir:
  • "Propriedade de documentos" retorna uma coleção documentos representando todos os documentos abertos.
  • O "propriedade de documentos" se aplica ao objeto Application.
Retornar para a macro gravada, realce Adicionar no módulo de código e pressione a tecla F1. Um tópico da Ajuda será exibida explicando que muitos objetos diferentes têm um método Add. Clique em documentos para ver a Ajuda para o método Add da coleção Documents. O tópico da Ajuda fornece importantes informações a seguir:
  • "Adicionar método" adiciona um novo documento vazio à coleção de documentos abertos.
  • "Adicionar método" pode levar dois argumentos, dos quais são opcionais.
Agora examine a próxima linha na macro gravada: Selection.TypeText Text: = "um". Realce a seleção no módulo de código e pressione a tecla F1:
  • "Propriedade de seleção" retorna o objeto Selection que representa um intervalo selecionado ou o ponto de inserção.
  • O "propriedade de seleção" se aplica ao objeto Application.
Retornar para a macro gravada, realce TypeText no módulo de código e pressione a tecla F1:
  • O "Método TypeText" insere o texto especificado.
  • O "Método TypeText" tem um argumento necessário do tipo String.
  • O "Método TypeText" se aplica ao objeto Selection.
Em seguida, consulte o tópico de Ajuda para TypeParagraph :
  • O "Método TypeParagraph" insere um novo parágrafo em branco.
  • O "Método TypeParagraph" se aplica ao objeto Selection e não possui argumentos.
Examine os tópicos da Ajuda para a propriedade ActiveDocument e o método SaveAs :
  • "Propriedade ActiveDocument" retorna um objeto Document que representa o documento com o foco. "ActiveDocument" se aplica ao objeto Application.
  • O "método SaveAs" salva um documento. Dependendo da versão do Word, esse método tem de 11 a 16 argumentos, somente uma delas é necessária. "Salvar como" se aplica a um objeto de documento.
Talvez você tenha notado que a propriedade Documents , a propriedade Selection e a propriedade ActiveDocument são todas as propriedades aplicadas ao objeto Application , mas ainda não são qualificadas com "Aplicativo" na macro gravada. O objeto Application é o objeto padrão para todas as propriedades e, portanto, pode ser omitido ao escrever código em uma macro VBA. Isso não é o caso, ao escrever código de automação; todas as propriedades e métodos devem ser totalmente qualificados no seu código de automação.

Ao exame da macro gravada, você verá que o método SaveAs tem um argumento para o qual ele passa a constante interna wdFormatDocument . Dependendo da linguagem de programação que você escolher para seu controlador de automação, talvez seja necessário passar o valor numérico para constantes internas. O tópico da Ajuda para o método SaveAs não fornece essas informações e você pode localizá-lo no Pesquisador de objetos . Pressione a tecla F2 para exibir o Pesquisador de objetos . Tipo:

wdFormatDocument

Na janela de pesquisa e pressione ENTER a chave. No painel inferior do Pesquisador de objetos , você vê o equivalente numérico do wdFormatDocument(=0) , bem como outras informações sobre a constante.

Referências

Onde posso encontrar alguns automação amostras de código?

As informações apresentadas até agora oferece boa base para escrever código de automação. Base de dados de Conhecimento é um excelente recurso para localizar automação amostras de código escritas em Visual Basic, Visual C++ e MFC. Aqui estão apenas alguns:

Para desenvolvedores de Visual Basic

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
220595  (http://support.microsoft.com/kb/220595/ ) Como automatizar o Outlook usando o Visual Basic
219151  (http://support.microsoft.com/kb/219151/ ) Como automatizar o Microsoft Excel a partir do Visual Basic
147650  (http://support.microsoft.com/kb/147650/ ) Como navegar objetos do Excel a partir do Visual Basic
142387  (http://support.microsoft.com/kb/142387/ ) Como criar automação de w/OLE de gráfico do Excel a partir do Visual Basic
184974  (http://support.microsoft.com/kb/184974/ ) Como usar automação (OLE) com o Word
220607  (http://support.microsoft.com/kb/220607/ ) Como automatizar o Microsoft Word para criar mala direta a partir do Visual Basic
222929  (http://support.microsoft.com/kb/222929/ ) Como automatizar o PowerPoint utilizando o Visual Basic no Office 2003, no Office XP Developer e no Office 2000 Developer

Desenvolvedores em Visual C++ (usando o MFC)

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
178749  (http://support.microsoft.com/kb/178749/ ) Como criar um projeto de automação usando MFC e uma biblioteca de tipos
179706  (http://support.microsoft.com/kb/179706/ ) Como usar MFC para automatizar o Excel e criar e formatar uma nova pasta de trabalho
186120  (http://support.microsoft.com/kb/186120/ ) Como usar MFC para automatizar o Excel e preencher um intervalo com uma matriz
186122  (http://support.microsoft.com/kb/186122/ ) Como usar MFC para automatizar Excel 2000 e Excel 2002 e obter uma matriz de um intervalo no Excel 2000 e no Excel 2002
220911  (http://support.microsoft.com/kb/220911/ ) Como automatizar o Microsoft Word para executar uma mala direta usando o Visual C++ e do MFC
222960  (http://support.microsoft.com/kb/222960/ ) Como automatizar o PowerPoint utilizando o Visual C++ 5.0 ou o Visual C++ 6.0 com O Microsoft Foundation Classes

Desenvolvedores de C/C ++ (sem MFC)

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
216686  (http://support.microsoft.com/kb/216686/ ) Como automatizar o Excel a partir do C++ sem usar MFC ou # Import
181473  (http://support.microsoft.com/kb/181473/ ) Como usar automação OLE de um aplicativo C em vez de C++

Desenvolvedores de Visual J ++

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
219430  (http://support.microsoft.com/kb/219430/ ) Como criar/formato uma planilha do Excel usando Visual J ++ automação
215484  (http://support.microsoft.com/kb/215484/ ) Como automatizar o PowerPoint usando o Visual J ++ 6.0

Visual FoxPro desenvolvedores

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
142193  (http://support.microsoft.com/kb/142193/ ) Como usar automação OLE para adicionar dados a planilha do Excel
180901  (http://support.microsoft.com/kb/180901/ ) Como criar uma tabela categorizada no Word 97 ou no Office Word 2003 do Visual FoxPro para Windows 5.0 e versões posteriores
181926  (http://support.microsoft.com/kb/181926/ ) Como automatizar a mala direta para o Word usando ODBC e OLE
194306  (http://support.microsoft.com/kb/194306/ ) Como torná-lo imprimir duplex usando automação de OLE do FoxPro
230154  (http://support.microsoft.com/kb/230154/ ) Como automatizar o PowerPoint usando o Visual FoxPro
241942  (http://support.microsoft.com/kb/241942/ ) Como evitar erro de impressão do Word com Propriedade BackgroundPrintingStatus
Para obter informações adicionais, incluindo código de exemplo e recursos para automatizar o Microsoft Office, visite o seguinte site:
http://support.microsoft.com/gp/ofd (http://support.microsoft.com/gp/ofd)

A informação contida neste artigo aplica-se a:
  • Microsoft Office 2003, All Editions
  • Microsoft Visual Basic 4.0 Professional Edition
  • Microsoft Visual Basic 5.0 Professional Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic 4.0 Enterprise Edition
  • Microsoft Visual Basic 5.0 Enterprise Edition
  • Microsoft Visual C++ 4.0 Professional Edition
  • Microsoft Visual C++ 5.0 Professional Edition
  • Microsoft Visual C++ 6.0 Professional Edition
  • Microsoft Visual J++ 6.0 Standard Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2003 Professional Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 97 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 97 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 97 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Visual FoxPro 5.0a
  • Microsoft Visual FoxPro 6.0 Professional Edition
  • Microsoft MapPoint 2002 Standard Edition
  • Microsoft MapPoint 2001 Standard Edition
Palavras-chave: 
kbmt _ik11561 _ik11593 kbautomation kbgrpdso kbhowto kbvba kbvbp400 kbvbp500 kbvbp600 KB222101 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 222101  (http://support.microsoft.com/kb/222101/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft