DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 223789 - Última revisão: terça-feira, 23 de Janeiro de 2007 - Revisão: 5.0

Nesta página

Sumário

Este artigo explica os vários métodos que pode utilizar para minimizar a quantidade de metadados nos livros.

Ao criar, abrir ou guardar um livro no Microsoft Excel, o livro poderá incluir conteúdo que não pretende partilhar com outros utilizadores ao distribuir o livro electronicamente. Estas informações são conhecidas como metadados. Os metadados são utilizados para vários fins: para melhorar a edição, a visualização, o arquivo e a obtenção de documentos do Office.

Alguns metadados são rapidamente acessíveis através da interface de utilizador do Excel. Outros metadados só são acessíveis através de meios extraordinários, como a abertura de um livro num editor de ficheiros binários de baixo nível.

Seguem-se alguns exemplos de metadados que poderão ser armazenados nos livros:
  • O nome do utilizador
  • As iniciais do utilizador
  • O nome da empresa ou organização
  • O nome do computador do utilizador
  • O nome do servidor de rede ou disco rígido onde guardou o livro
  • Outras propriedades do ficheiro e informações de resumo
  • Partes não visíveis de objectos OLE incorporados
  • Revisões do documento
  • Texto ou células ocultos
  • Vistas personalizadas
  • Comentários
Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).

Mais Informação

Os metadados são criados de várias formas nos livros do Excel. Consequentemente, não existe um único método para remover todo este conteúdo dos livros. As secções que se seguem descrevem as áreas onde os metadados podem ser guardados nos livros do Excel.

Instalar a actualização mais recente

Estão disponíveis as actualizações que se seguem. Para obter informações adicionais sobre estas actualizações, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
305095  (http://support.microsoft.com/kb/305095/ ) Histórico das actualizações do Office XP
269356  (http://support.microsoft.com/kb/269356/ ) Overview and history of Excel 2000 updates
232652  (http://support.microsoft.com/kb/232652/ ) Overview and history of Excel patches

Como eliminar o nome de utilizador dos programas

Para visualizar ou alterar o nome de utilizador, siga estes passos:
  1. No menu Ferramentas, clique em Opções. Clique no separador Geral. Verá a caixa de edição Nome de utilizador.
  2. Se pretende que nenhuma destas informações apareça nos livros, introduza informações não identificadoras ou espaços na caixa de edição e, em seguida, clique em OK para aceitar as alterações.
Quaisquer novos livros criados pelo utilizador conterão estas informações, em vez dos valores predefinidos introduzidos quando instalou o Office pela primeira vez. No entanto, é possível que os livros existentes já contenham estas informações.

Como remover informações de resumo pessoais

Quando cria ou guarda um livro no Microsoft Excel, as informações de resumo podem ser guardadas no livro. Existem vários métodos que pode utilizar para aceder a estas informações:
  • Abra o livro. No menu Ficheiro, clique em Propriedades. Os separadores Sumário, Estatísticas, Conteúdo e Personalizar podem conter várias propriedades, tais como o nome do utilizador, o nome do gestor e o nome da empresa.
  • No Explorador do Windows, clique com o botão direito do rato no livro e, em seguida, clique em Propriedades no menu de atalho. Os separadores existentes na caixa de diálogo Propriedades poderão conter informações que pretenda remover.
  • É possível utilizar uma macro do Microsoft Visual Basic for Applications ou outro código de programação para ler as propriedades apresentadas na caixa de diálogo Propriedades.
Para remover informações de resumo de um livro ou modelo existente, siga estes passos:
  1. Abra o livro ou modelo.
  2. No menu Ficheiro, clique em Propriedades.
  3. No separador Sumário, elimine texto que não pretenda distribuir existente nas caixas de edição Autor, Gestor, Empresa e outras.
  4. No separador Personalizar, elimine quaisquer propriedades que contenham informações que não pretenda distribuir.
  5. Quando terminar, clique em OK. No menu Ficheiro, clique em Guardar.
  6. No menu Ficheiro, clique em Fechar.
Após a conclusão destes passos, o livro não conterá propriedades de resumo.

Remover informações de resumo pessoais quando ligado a uma rede

Se tiver sessão iniciada numa rede, o seu nome de utilizador de rede poderá ser apresentado na caixa de edição Autor do separador Sumário e no campo Guardado pela última vez por do separador Estatísticas, quando guardar um livro. Esta situação pode ocorrer mesmo que tenha removido todas as outras informações pessoais do computador.

Para remover informações de resumo de um livro quando estiver ligado a uma rede, siga estes passos:
  1. Se o livro estiver armazenado num servidor de rede, copie-o para o disco rígido local.
  2. Inicie o computador, mas não inicie sessão na rede. Quando for apresentada a caixa de diálogo de início de sessão de rede, clique em Cancelar ou prima ESC.

    Nota: se não conseguir iniciar o Windows premindo a tecla ESC (por exemplo, o computador tem o Microsoft Windows NT), não poderá utilizar estes passos.
  3. Abra o livro.
  4. No menu Ficheiro, clique em Propriedades.
  5. No separador Sumário, elimine o texto existente em Autor, Gestor, Empresa e outras caixas de edição que contenham informações que não pretenda distribuir.
  6. No separador Personalizar, elimine quaisquer propriedades que contenham informações que não pretenda distribuir.
  7. Quando terminar, clique em OK. No menu Ficheiro, clique em Guardar.
  8. No menu Ficheiro, clique em Fechar.
Quando iniciar sessão na rede, não abra o ficheiro. Se o fizer, o nome de utilizador de rede poderá ser escrito no ficheiro. No entanto, é possível utilizar o Explorador do Windows para copiar o ficheiro para um servidor de rede ou para uma disquete.

Como remover comentários dos livros

O Microsoft Excel permite adicionar comentários a livros. Normalmente, os comentários contêm o nome da pessoa que os criou.

No Microsoft Excel, os comentários são apresentados como um pequeno triângulo vermelho no canto superior direito de uma célula. Para visualizar os comentários, clique com o botão direito do rato na célula e, em seguida, clique em Eliminar comentário no menu de atalho.

Quaisquer novos comentários criados não deverão conter o nome do utilizador, uma vez que o eliminou da caixa de diálogo Opções, conforme descrito anteriormente na secção "Como eliminar o nome de utilizador dos programas" deste artigo.

Como eliminar informações de cabeçalhos e rodapés

Os cabeçalhos e rodapés dos livros podem conter informações de identificação. Para eliminar informações de cabeçalhos e rodapés, siga estes passos:
  1. Abra o livro.
  2. No menu Ficheiro, clique em Configurar página. Clique no separador Cabeçalho/Rodapé e altere o cabeçalho e o rodapé de modo a que não contenham informações de identificação.
  3. Quando terminar, clique em OK.
Repare que cada folha de cálculo de um livro contém o seu próprio cabeçalho e rodapé; assim, terá de repetir este processo em todas as folhas de cálculo.

Como remover hiperligações de livros

Os livros poderão conter hiperligações para outros documentos ou páginas Web, numa intranet ou na Internet. Normalmente, as hiperligações são apresentadas como cadeias de texto sublinhadas, a azul.

Para eliminar manualmente uma única hiperligação de um livro, clique com o botão direito do rato na hiperligação, aponte para Hiperligação no menu de atalho e, em seguida, clique em Remover hiperligação.

Para eliminar todas as hiperligações de um livro, pode utilizar uma macro do Visual Basic for Applications. Para obter informações adicionais sobre como escrever uma macro, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
213790  (http://support.microsoft.com/kb/213790/ ) No menu command to select all hyperlinks within a worksheet
156353  (http://support.microsoft.com/kb/156353/ ) No menu choice to select all hyperlinks

Como remover estilos de livros

Os livros no Microsoft Excel poderão incluir estilos que contenham metadados. Pode remover estes estilos ou mudar o respectivo nome. Para o fazer, siga estes passos:
  1. Abra o livro que contém os estilos.
  2. No menu Formatar, clique em Estilo.
  3. Seleccione o estilo a que pretende mudar o nome ou eliminar. Clique em Eliminar para eliminar o estilo ou clique na caixa Nome do estilo para mudar o respectivo nome.

Como visualizar células, linhas e colunas ocultas em livros do Microsoft Excel

No Microsoft Excel, é possível ocultar linhas e colunas inteiras de células numa folha de cálculo.

Para visualizar todas as células de uma folha de cálculo, siga estes passos:
  1. Clique no botão Seleccionar tudo, no canto superior esquerdo da folha de cálculo. Ou prima CTRL+SHIFT+SPACE.
  2. No menu Formatar, aponte para Linha e, em seguida, clique em Mostrar.
  3. No menu Formatar, aponte para Coluna e, em seguida, clique em Mostrar.
Todas as células estarão agora visíveis.

Repare que uma célula poderá ter ainda a respectiva altura ou largura definida com um valor muito pequeno, dificultando a visualização da mesma. Se for este o caso, siga estes passos:
  1. Clique no botão Seleccionar tudo, no canto superior esquerdo da folha de cálculo. Ou prima CTRL+SHIFT+SPACE.
  2. No menu Formatar, aponte para Linha e, em seguida, clique em Ajustar automático.
  3. No menu Formatar, aponte para Coluna e, em seguida, clique em Ajustar automaticamente.
Este procedimento força o redimensionamento de todas as células de modo a mostrar o respectivo conteúdo.

De realçar que ainda é possível que não consiga visualizar adequadamente o conteúdo da célula; por exemplo, se o conteúdo da célula estiver formatado para utilizar um tipo de letra branco numa célula com uma cor de fundo branca. Para alterar as propriedades do tipo de letra das células seleccionadas, clique em Células no menu Formatar e, em seguida, clique no separador Tipo de letra.

Como mostrar folhas de cálculo ocultas nos livros do Microsoft Excel

Os livros no Microsoft Excel podem conter folhas ocultas com informações. Para mostrar folhas, aponte para Folha no menu Formatar e, em seguida, clique em Mostrar. Se uma folha estiver oculta, pode seleccionar a folha e clicar em OK.

Nota: se o comando Mostrar não estiver disponível, não existem folhas ocultas ou o livro está protegido. No menu Ferramentas, aponte para Protecção e, em seguida, clique em Desproteger livro. Se lhe for pedido para introduzir uma palavra-passe, introduza-a para desproteger o livro.

Como remover ligações de livros do Microsoft Excel

Os livros do Microsoft Excel podem conter fórmulas com ligações a células de outros livros. Se enviar um livro que contenha ligações para outro utilizador, os nomes dos outros livros poderão ser determinados utilizando a caixa de diálogo Ligações.

Para remover ligações de um livro, é necessário remover todas as referências a outros livros das fórmulas do livro. Uma forma de o fazer é seguindo estes passos:
  1. No menu Editar, clique em Ligações.
  2. Seleccione o nome do livro para o qual tem a ligação que pretende remover e clique em Alterar origem.
  3. Seleccione o livro que está a editar actualmente; por exemplo, se estiver a editar C:\Dados\Teste.xls, seleccione C:\Dados\Teste.xls. Em seguida, clique em OK.
  4. Repita os passos 2 e 3 para qualquer outro livro a que este esteja ligado.
  5. Quando terminar, clique em OK.
Repare que ao executar estes passos, poderá afectar os resultados das fórmulas do livro; é mesmo possível que algumas fórmulas não apresentem os resultados correctos.

Outro método para remover as ligações a outros livros consiste em converter as fórmulas nos respectivos resultados. Para o fazer, siga estes passos:
  1. Seleccione uma célula que contenha uma fórmula com ligação a outro livro.
  2. No menu Editar, clique em Copiar.
  3. No menu Editar, clique em Colar especial. Clique em Valores e, em seguida, clique em OK.
A fórmula é eliminada, mas o resultado da fórmula mantém-se.

Como remover alterações registadas de livros partilhados do Microsoft Excel

O Microsoft Excel inclui a funcionalidade Registar alterações que permite registar as alterações efectuadas num livro partilhado por um utilizador. Para remover alterações registadas de um livro, siga estes passos:
  1. Abra o livro.
  2. No menu Ferramentas, aponte para Registar alterações e, em seguida, clique em Realçar alterações.
  3. Clique para desmarcar a caixa de verificação Registar alterações durante a edição. Clique em OK.
  4. Clique em Sim para colocar o livro em modo de utilização exclusiva (o livro deixa de ser partilhado).

Como eliminar vistas de livros do Microsoft Excel

As vistas personalizadas de livros do Microsoft Excel poderão conter o nome do utilizador, especialmente se estiver a utilizar livros partilhados.

Para eliminar vistas de um livro, siga estes passos:
  1. No menu Ver, clique em Vistas personalizadas.
  2. Seleccione uma vista que contenha o seu nome ou outra informação de identificação e clique em Eliminar.
Tenha em atenção que ao eliminar vistas poderá afectar a forma como é impresso o livro se utilizar o Gestor de relatórios para imprimir relatórios.

Como eliminar informações da lista de distribuição de um livro

Se enviar um livro por correio electrónico utilizando uma lista de distribuição, as informações de encaminhamento poderão ser anexadas ao livro. Para remover estas informações do livro, terá de o guardar num formato que não retenha informações da lista de distribuição.

No Microsoft Excel, guarde o livro num formato de ficheiro antigo como, por exemplo, o formato SYLK, Excel 4.0 ou Lotus 1-2-3. Feche o livro e, em seguida, reabra o novo ficheiro. Uma vez que as informações da lista de distribuição já não existem, é possível guardar agora o ficheiro como um livro do Microsoft Excel.

Pode também seguir estes passos:
  1. No menu Ficheiro, aponte para Enviar para e, em seguida, clique em Destinatário da distribuição.
  2. Clique em Limpar para eliminar a lista de distribuição. Em seguida, clique em OK.
  3. No menu Ficheiro, clique em Guardar.
O livro é guardado sem quaisquer informações da lista de distribuição.

Como eliminar informações de endereços de correio electrónico de um livro

As informações de Destinatário de correio são mantidas no documento do Office quando envia correio utilizando a opção Enviar ficheiro no Microsoft Office XP. O Excel 2002 mantém os endereços de correio electrónico de PARA, CC e BCC quando o utilizador usa a opção Destinatário de envio de ficheiro e o cabeçalho do correio electrónico é activado directamente para o documento.

Para remover estas informações, siga estes passos:
  1. Com o ficheiro aberto, clique em Opções no menu Ferramentas.
  2. Seleccione o separador Segurança e clique para seleccionar a caixa de verificação Remover informações pessoais das propriedades do ficheiro ao guardar.
  3. Clique no botão OK para fechar a caixa de diálogo Opções e guarde o ficheiro.
O ficheiro é guardado sem os endereços de correio electrónico.

Como eliminar o nome do utilizador de código do Visual Basic

Quando grava uma macro do Visual Basic no Microsoft Excel, a macro gravada é iniciada por um cabeçalho semelhante ao seguinte:
   ' Macro1 Macro
   ' Macro gravada em 3-11-1999 por J. Silva
				
Para remover o seu nome de todas as macros gravadas, siga estes passos:
  1. Abra o livro que contém as macros.
  2. No menu Ferramentas, aponte para Macro e, em seguida, clique em Editor do Visual Basic. Ou prima ALT+F11.
  3. Na janela do projecto, faça duplo clique no módulo que contém as macros.
  4. Elimine o nome do utilizador do código da macro gravada.
Quando terminar, prima ALT+Q para voltar ao programa. Em seguida, clique em Guardar no menu Ficheiro.

Como eliminar referências do Visual Basic a outros ficheiros

No editor do Visual Basic, é possível criar uma referência a outro ficheiro. Se um utilizador abrir um livro que contenha referências a outros ficheiros, poderá visualizar os nomes dos ficheiros referenciados.

Para eliminar estas referências, siga estes passos:
  1. Abra o livro que contém as referências.
  2. No menu Ferramentas, aponte para Macro e, em seguida, clique em Editor do Visual Basic. Ou prima ALT+F11.
  3. No menu Tools, clique em References.
  4. Clique para desmarcar a caixa de verificação junto do ficheiro referenciado. Quando terminar, clique em OK para fechar a caixa de diálogo References - VBAProject.
  5. Prima ALT+Q.
  6. No menu Ficheiro, clique em Guardar.
Nota: a eliminação de referências a outros ficheiros poderá comprometer o funcionamento correcto das macros do livro.

Como eliminar informações sobre a rede ou o disco rígido de um livro

Quando guarda um livro no disco rígido local ou num servidor de rede, as informações que identificam o disco rígido local ou o servidor de rede poderão ser escritas no livro.

Para eliminar estas informações do livro, siga estes passos:
  1. Abra o livro.
  2. No menu Ficheiro, clique em Guardar como. Guarde o livro na unidade de disquetes (normalmente, A:).
  3. No menu Ficheiro, clique em Fechar.
  4. Remova a disquete da respectiva unidade.
Pode agora utilizar o Explorador do Windows para copiar o livro da disquete para qualquer disco rígido ou servidor de rede.

Nota: devido à limitação de espaço de uma disquete (normalmente de 1,44 MB), não é possível utilizar este método se o tamanho do ficheiro do livro exceder a quantidade de espaço livre na disquete.

Objectos incorporados em livros poderão conter metadados

Se incorporar um objecto num livro, o objecto mantém as respectivas propriedades, independentemente do que pretenda fazer com o livro. Por exemplo, se incorporar um documento do Microsoft Word num livro do Microsoft Excel, ambos têm as suas próprias propriedades.

Pode eliminar os metadados de um objecto incorporado abrindo o mesmo, removendo quaisquer metadados, reactivando o documento principal (no exemplo anterior, o livro do Excel) e, em seguida, guardando-o.

Nota: quando abre um objecto incorporado num livro, apenas parte do objecto é apresentada no livro. O objecto pode conter informações adicionais que não são apresentadas. Se pretende que um livro contenha apenas uma representação do objecto incorporado e não o conteúdo real, siga estes passos:
  1. Seleccione o objecto. No menu Ficheiro, clique em Cortar.
  2. No menu Editar, clique em Colar especial para colar o objecto no livro utilizando um formato de metaficheiro.
Depois de executar este procedimento não será possível editar o objecto incorporado; no entanto, este não conterá quaisquer metadados.

Como remover identificadores exclusivos de documentos do Office 97

Devido à concepção dos programas incluídos no Microsoft Office 97, os documentos criados ou guardados nos programas do Office 97 poderão conter um identificador exclusivo. Para obter informações adicionais sobre estes identificadores e como removê-los, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
222180  (http://support.microsoft.com/kb/222180/ ) How and why unique identifiers are created in Office documents
Nota: este identificador exclusivo não existe nas versões mais recentes de programas do Microsoft Office.

Sugestões gerais sobre segurança

Seguem-se algumas sugestões gerais que pode utilizar para aumentar o nível de segurança no seu ambiente informático:
  • Quando não estiver a trabalhar no computador, utilize uma protecção de ecrã com palavra-passe, uma palavra-passe de ligação ou a funcionalidade de bloqueio do Windows NT.
  • Se o computador tiver pastas partilhadas, certifique-se de que aplica palavras-passe às mesmas, de modo a que apenas os utilizadores autorizados possam aceder às suas partilhas. Para uma maior segurança, utilize controlo de acesso ao nível de utilizador para poder controlar exactamente quem pode aceder às partilhas do computador.
  • Quando eliminar um ficheiro, esvazie a Reciclagem imediatamente. Poderá pretender considerar a utilização de um utilitário que apague ou substitua totalmente os ficheiros quando estes forem eliminados.
  • Quando criar cópias de segurança dos dados, armazene os ficheiros de cópia de segurança num local seguro como, por exemplo, um cofre, um compartimento de cofre-forte ou um armário com fechadura. Armazene uma cópia dos ficheiros de cópia de segurança num local externo seguro, caso o local principal fique inutilizável.
  • Os documentos importantes devem ser protegidos por palavra-passe, para assegurar que só serão abertos pelos utilizadores autorizados. As palavras-passe devem ser armazenadas num local diferente e seguro. Note que, se não conseguir lembrar-se de uma palavra-passe, não será possível recuperar o conteúdo de um documento protegido por palavra-passe.
  • Não distribua documentos em formato electrónico. Em vez disso, imprima-os. Não utilize elementos de identificação como, por exemplo, tipos de letra característicos, marcas de água, logótipos ou papel especial, a menos que seja necessário (por exemplo, para uma apresentação).
  • O correio electrónico não é anónimo. Não envie um documento por correio electrónico se o facto de a sua identidade ser anexada de alguma forma ao documento lhe causar algum tipo de preocupação.
  • Não envie documentos através da Internet utilizando os protocolos HTTP ou FTP. As informações enviadas através destes protocolos são enviadas como "texto simples", o que significa que é tecnicamente possível (embora improvável) interceptá-las.

Obter mais informações

Para obter informações adicionais sobre os tópicos abordados neste artigo, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
223396  (http://support.microsoft.com/kb/223396/ ) OFF: Como minimizar metadados em documentos do Microsoft Office
222180  (http://support.microsoft.com/kb/222180/ ) How and why unique identifiers are created in Office documents
314800  (http://support.microsoft.com/kb/314800/ ) PPT2002: Como minimizar metadados em apresentações do Microsoft PowerPoint
314797  (http://support.microsoft.com/kb/314797/ ) PPT2000: Como minimizar metadados em apresentações do Microsoft PowerPoint
223793  (http://support.microsoft.com/kb/223793/ ) PPT97: Como minimizar metadados em apresentações do Microsoft PowerPoint
290945  (http://support.microsoft.com/kb/290945/ ) WD2002: Como minimizar metadados em documentos do Microsoft Word
237361  (http://support.microsoft.com/kb/237361/ ) COMO: Minimizar metadados em documentos do Microsoft Word 2000
223790  (http://support.microsoft.com/kb/223790/ ) WD97: Como minimizar metadados em documentos do Microsoft Word

A informação contida neste artigo aplica-se a:
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Palavras-chave: 
kbhowto kbofficeupdate KB223789
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft