DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 237541 - Última revisão: quinta-feira, 26 de Outubro de 2006 - Revisão: 3.3

Disponível transferência de hotfix
Ver e solicitar transferências de hotfix
 
 

Sintomas

Contadores do Monitor de desempenho do Microsoft Exchange Server poderão não estar disponíveis depois de tem movido os serviços do Exchange Server para o segundo nó de um cluster do Windows NT. Não é possível utilizar o nome virtual do Exchange Server ou o nome de computador real quando seleccionar o computador no Monitor de desempenho disponíveis os contadores.

Causa

O comportamento ocorre quando a ordem do software instalado em nós de servidor de cluster é diferente. A chave de desempenho para cada um dos serviços do Exchange Server contém o índice na chave de registo HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Perflib\009\Counters , onde existem os contadores e apelidos para os serviços do Exchange Server. Se instalar software num cluster por uma ordem diferente, os valores para cada serviço são diferentes para cada servidor no cluster. A replicação de registo num cluster está actualmente definida para replicar todas as subchaves da chave do serviço em particular, incluindo a chave de desempenho. Isto substitui os valores de um servidor com os valores de outro servidor no cluster. Por conseguinte, os valores na chave contadores no segundo nó já não corresponder os índices nas chaves de desempenho dos serviços.

Resolução

Agora é disponibilizada pela Microsoft uma correcção suportada, mas destina-se apenas a corrigir o problema descrito neste artigo. Aplique-a apenas em computadores que tenham este problema específico.

Para resolver este problema, contacte o suporte técnico da Microsoft para obter a correcção. Para obter uma lista completa de números de telefone do suporte técnico da Microsoft e informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)
Nota : em casos especiais, os custos normalmente inerentes às chamadas de suporte poderão ser anulados se um técnico de suporte da Microsoft determinar que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem na atualização específica em questão.

A versão inglesa desta correcção deverá ter os seguintes atributos de ficheiro ou posteriores:

Componente: Programa de configuração do

Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão
Srvrmax.exe5.5.1960.10

Depois de obter a correcção, siga estes passos para aplicá-lo:
  1. Criar uma nova pasta no disco rígido e, em seguida, copie o conteúdo da pasta Server\Setup\I386 a partir do CD-ROM do Exchange Server 5.5 para esta nova pasta.
  2. Mude o nome do ficheiro Setup.exe na pasta no disco rígido para Setup.old e mude o nome do ficheiro Srvrmax.exe para Setup.exe.
  3. Execute o Setup.exe a partir da pasta no disco rígido.
  4. Quando o processo de instalação estiver concluído, aplicar o service pack mais recente do Exchange Server 5.5, mesmo que já foi aplicada anteriormente. Para obter informações adicionais sobre como obter o service pack mais recente para o Exchange Server 5.5, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
    191014  (http://support.microsoft.com/kb/191014/EN-US/ ) XGEN: Como obter o Service Pack mais recente do Exchange Server 5.5

Como contornar

A correcção disponível apenas corrige o comportamento em novas instalações do Exchange Server num ambiente de cluster. Caso já tenha instalado o Exchange Server, execute os seguintes passos para corrigir manualmente o comportamento:
  1. No administrador de cluster do Microsoft Windows NT, clique com o botão direito do rato no serviço de directório.

    Nota : se tem de estar na consola para executar o programa de administrador de clusters Windows NT; não é possível executar o programa a partir de uma localização remota.
  2. Clique no separador Registo Replication , remova todas as entradas existentes e, em seguida, clique em Aplicar para aplicar estas alterações.

    Nota : é muito importante que remova ALL entradas existentes no separador Registo replicação antes de prosseguir para o passo seguinte.
  3. Adicione as seguintes entradas para o serviço de directório:
    SYSTEM\CurrentControlSet\Services\MSExchangeDS\Diagnostics

    SYSTEM\CurrentControlSet\Services\MSExchangeDS\Parameters
  4. Repita os passos acima para adicionar entradas especificadas para cada um dos seguintes serviços do Exchange Server:
    • O serviço system attendant:
      SYSTEM\CurrentControlSet\Services\MSExchangeSA\Diagnostics

      SYSTEM\CurrentControlSet\Services\MSExchangeSA\Parameters
    • O agente de transferência de mensagens transfer agent:
      SYSTEM\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

      SYSTEM\CurrentControlSet\Services\MSExchangeMTA\Parameters
    • O arquivo de informações:
      SYSTEM\CurrentControlSet\Services\MSExchangeIS\Diagnostics

      SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersPublic

      SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

      SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

      SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersNetIF
      Nota : Certifique-se de que não são replicadas as chaves de raiz para cada serviço (por exemplo, a chave SYSTEM\CurrentControlSet\Services\MSExchangeDS ).
  5. Agora tem recarregar os contadores do Monitor de desempenho em cada nó no cluster, depois de efectuar as alterações para replicação de registo. Necessita de localizar os seguintes ficheiros .ini. Estes ficheiros estão localizados no directório Exchsrvr\bin por predefinição.
    Dsactrs.ini
    Mtaperf.ini
    Mdbperf.ini
    Este ficheiro está localizado no directório %Winnt%\System32 por predefinição:
    Eseperf.ini
    Para carregar os contadores, numa linha de comandos no directório que contém os ficheiros .ini, introduza os seguintes comandos:
    unlodctr MSExchangeDS
    LODCTR dsactrs.ini
    UNLODCTR MSExchangeMTA
    LODCTR mtaperf.ini
    UNLODCTR MSExchangeIS
    LODCTR mdbperf.ini
    UNLODCTR ESE97
    LODCTR eseperf.ini
    Os ficheiros lodctr.exe e unlodctr.exe estão incluídos na pasta %Winnt%\System32.
  6. Reinicie ambos os nós do cluster do Exchange Server.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no início deste artigo.

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 5.5 Standard Edition
Palavras-chave: 
kbmt kbhotfixserver kbqfe exc55 kbbug kbfix kbqfe KB237541 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 237541  (http://support.microsoft.com/kb/237541/en-us/ )
Artigo KB retiradoExclusão de Responsabilidade para Conteúdo sem Suporte na KB
Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser actualizado.
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft