DetailPage-MSS-KB

Base de Dados de Conhecimento

Artigo: 2618570 - Última revisão: quarta-feira, 26 de Setembro de 2012 - Revisão: 3.0

 

Sintoma

Considere o seguinte cenário:
  • Instalar uma instância de Microsoft SQL Server 2008 R2 em um servidor que tem instâncias de Microsoft SQL Server 2005 e Microsoft SQL Server 2008 instalado.
    Observação Algumas ou todas as ocorrências antigas em execução no momento da instalação.
  • Tente executar um backup Virtual Backup Device Interface (VDI) do SQL Server 2005 ou do SQL Server de 2008.
Nesse cenário, a operação de backup VDI falha. Além disso, os seguintes erros são gerados nos logs de SQL Server:
Tempo de erro> Backup erro: 3201, gravidade: 16, estado: 7.
Erro de tempo> Backup não é possível abrir o dispositivo de backup 'Local da pasta>'. Erro do sistema operacional 0x80770006 (Falha ao recuperar o texto para este erro. Motivo: 15105).
Observação Esses erros, "Evento de tempo" é um espaço reservado para o tempo que o erro ocorre em "Local da pasta" é um espaço reservado para o local da pasta de backup.

Causa

Esse problema ocorre porque o servidor de SQL Server e o cliente SQL Server usam diferentes versões do arquivo Sqlvdi. dll quando você executar uma operação de backup de VDI.

Quando você instala o SQL Server 2008 R2, as cópias em disco do arquivo Sqlvdi. dll no SQL Server 2005 ou 2008 de SQL Server são substituídas pelo arquivo Sqlvdi. dll no SQL Server 2008 R2. No entanto, a versão antiga do arquivo Sqlvdi. dll permanece na memória quando as instâncias são executados durante a instalação.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Resolução

Para resolver esse problema, reinicie cada versão mais antiga da instância do SQL Server que executando durante a instalação de instância SQL Server 2008 R2. Para evitar esse problema, antes de instalar o SQL Server 2008 R2, siga estas etapas:
  1. Pare todas as instâncias de SQL Server no servidor.
  2. Instale SQL Server 2008 R2.
  3. Reinicie as instâncias de SQL Server que você parou.

Mais informações

Você pode usar o simulador de Backup SQL Server para detectar qual versão do arquivo Sqlvdi. dll está instalado. Para obter mais informações sobre como usar o simulador de Backup SQL Server, visite o seguinte site da Microsoft:
Informações gerais sobre o simulador de Backup SQL Server (http://blogs.msdn.com/b/sqlserverfaq/archive/2010/10/27/sql-server-backup-simulator.aspx)
Para obter mais informações sobre VDI, exiba a especificação de VDI. O seguinte arquivo está disponível para download no Microsoft Download Center:
Reduzir esta imagemExpandir esta imagem
Download
Baixe agora o pacote do SQL Server 2005 Virtual Backup dispositivo Interface (VDI) especificação. (http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17282) Para obter mais informações sobre como transferir ficheiros de suporte da Microsoft, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
119591  (http://support.microsoft.com/kb/119591/ ) Como obter arquivos de suporte da Microsoft de serviços on-line
A Microsoft examinou esse ficheiro em busca de vírus. A Microsoft usou o software de detecção de vírus mais atual que estava disponível na data em que o ficheiro foi publicado. O arquivo está armazenado em servidores com segurança avançada que ajudam a evitar qualquer alteração não autorizada no arquivo.

A informação contida neste artigo aplica-se a:
  • Microsoft SQL Server 2008 R2 Enterprise
  • Microsoft SQL Server 2008 Enterprise
  • Microsoft SQL Server 2012 Enterprise
  • Microsoft SQL 2005 Server Enterprise
Palavras-chave: 
kbsurveynew kbtshoot kbexpertiseadvanced atdownload kbmt KB2618570 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática… erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2618570  (http://support.microsoft.com/kb/2618570/en-us/ )
Partilhar
Opções de suporte adicionais
Fóruns de Suporte da Comunidade Microsoft
Contacte-nos directamente
Encontre um parceiro certificado Microsoft
Loja Microsoft